LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   nvidia logo (http://www.linuxquestions.org/questions/slackware-14/nvidia-logo-151767/)

abs 02-29-2004 04:07 AM

nvidia logo
 
hi
i installed the nvidia drivers today. and WOW! for me, nv was the default thing but full sreen movies sucked. i had to change the modeline to get the screen in the middle too. reverted back to the original values when i installed the driver and everything looks crisper too.

just one thing, the logo. i can't get it to go away! in the /usr/share/doc/NVIDIA...README file, there's a section on options (app D). it says
Quote:

Option "NoLogo" "boolean"
Disable drawing of the NVIDIA logo splash screen at
X startup. Default: the logo is drawn.
so what's boolean? i've tried "1", "TRUE", "True", "on". what else? (NoLogo = 1 means Logo = 0, right?) :P

At0mic_PC 02-29-2004 10:07 AM

1 means true.
0 means false.

I assume 0 would mean off.

itsjustme 02-29-2004 12:08 PM

Give "enable" a try and see if that works.

Edit: I searched around and saw a couple of examples like that. Don't know if they actually work though.

Good luck

vinay_s_s 02-29-2004 01:09 PM

Just give:

Option "nologo"

Atmchicago 02-29-2004 02:37 PM

What they said should work, but I usually like to keep the logo because that way I know the driver is working. It doesn't really hurt to have it pop up.

abs 02-29-2004 04:16 PM

Quote:

Originally posted by vinay_s_s
Just give:

Option "nologo"

doesn't work.

@At0mic_PC: i know the booleans of 1 and 0. the word/variable here is "NoLogo". unless this was stupidly named, 1 shoulg be NoLogo (and 0 would be NoLogo = FALSE hence Logo = TRUE)

@Atmchicago: once it's up and running, i'd rather not keep seeing it. coz i switch X on and off quite frequently. if i set runlevel to 4 and i see the logo just once, then it's fine.

itsjustme 02-29-2004 04:22 PM

Did you try:

Option "NoLogo" "enable" ?

r_jensen11 02-29-2004 05:52 PM

The manual says to use the following:

Code:

Option "NoLogo" "on"
make sure that you have it inserted in the right spot in the file, though, or it might not work well....

notAslacker 02-29-2004 06:02 PM

no logo
 
abs,

Nvidia drivers are great but that logo screen is evil.

I tested the following driver options, running slack 9.1, 2.6.1 kernel, and nvidia 5336 stuff:

Option "NOLOGO" "1"
Option "NoLogo" "True"
Option "nOlOgO" "TRUE"

Each one prevented the logo. Option "NoLogo" "True", of all choices should have stopped the screen from showing. So maybe there is a typo or error somewhere else in your config file. Or you might try reinstalling the drivers. If you can't get the logo to go away, post XF86Config.

Quote:

so what's boolean?
"Boolean" gets its name from George Boole, the grandpa of modern logic; predicate calculus around 1850. In general boolean means something with two exclusively possible values.

Quote:

i've tried "1", "TRUE", "True", "on". what else? (NoLogo = 1 means Logo = 0, right?)
Looks good. Bools usually get (true or false) and (0 or 1+); where a value=0 means false and a value >=1 means true.

--notaslacker

abs 02-29-2004 07:43 PM

Quote:

Originally posted by itsjustme
Did you try:

Option "NoLogo" "enable" ?

yup. doesn't work.

Quote:

Originally posted by r_jensen11
The manual says to use the following:

Code:

Option "NoLogo" "on"
make sure that you have it inserted in the right spot in the file, though, or it might not work well....

doesn't work either. i found that in the man page too. i've put it in the "ServerFlags" section.

Quote:

Originally posted by notAslacker
abs,

Nvidia drivers are great but that logo screen is evil.
...
"Boolean" gets its name from George Boole, the grandpa of modern logic; predicate calculus around 1850. In general boolean means something with two exclusively possible values.

Looks good. Bools usually get (true or false) and (0 or 1+); where a value=0 means false and a value >=1 means true.

lol i know what a boolean is. i meant what does it need to be in that file so it's understood. and yes, the logo is quite a pain.

also, <= -1 is also true. in most programming languages that i know of, true is NOT false i.e. non-zero. dunno about how fractions type-cast to int/bool.

itsjustme 02-29-2004 08:01 PM

Quote:

Originally posted by abs
i've put it in the "ServerFlags" section.
It seems like that is not good.
I saw in another forum that it should go in the nvidia device section and it also said:
Option "NoLogo" "on"

Try moving to just below the - Driver "nvidia" - line, maybe.

Good luck...

Wynd 02-29-2004 08:17 PM

I have

Section "Device"
# ...
Option "NoLogo" "True"
# ...
EndSection

r_jensen11 02-29-2004 08:22 PM

I got it to work. I put it right underneath the line that reads
Code:

Driver "nvidia"
and it works.

abs 02-29-2004 08:30 PM

Quote:

Originally posted by itsjustme
I saw in another forum that it should go in the nvidia device section and it also said:
Option "NoLogo" "on"

Try moving to just below the - Driver "nvidia" - line, maybe.

Good luck...

yup, worked. thanks.

the Device section appears twice. in the first, there's a Driver "vga" line and it's Driver "nv" in the repeat of the section. i changed the nv line as per the nvidia docs and added nologo line below the VideoRam line.

just changed the "vga" to "nvidia" also to see if there's a diff.

edit:
no apparent diff.

itsjustme 03-01-2004 01:54 PM

Quote:

Originally posted by abs
just changed the "vga" to "nvidia" also to see if there's a diff.

edit:
no apparent diff.

I think you'll see a change if you run glxgears with each driver.


All times are GMT -5. The time now is 03:30 PM.