LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-02-2009, 03:14 PM   #1
egregor
Member
 
Registered: Sep 2009
Distribution: slackware, Salix, bsd's
Posts: 35

Rep: Reputation: 17
nvidia driver slowing xfce desktop selection box and icons showing


After I configured my nvidia card (96.43.13 driver) in my slack 13 huge-smp system, xfce desktop selection box became very slow and resource consuming and when I switched to desktop from for ex. firefox the icons delayed to show up (maybe more than 1 sec!!). The other aplications that like games and KDE ran OK.
Using other distros (sabayon) I don't have this.


What could be the source of the problem? Later I will try with another kernel and report.

Slackware is so great.
Thanks

Last edited by egregor; 09-02-2009 at 03:15 PM.
 
Old 09-02-2009, 04:16 PM   #2
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 421

Rep: Reputation: 58
Quote:
Originally Posted by egregor View Post
After I configured my nvidia card (96.43.13 driver) in my slack 13 huge-smp system, xfce desktop selection box became very slow and resource consuming and when I switched to desktop from for ex. firefox the icons delayed to show up (maybe more than 1 sec!!).
You should only run the huge kernel to troubleshoot issues. It has most option already compiled into the kernel which makes it bigger (it is called huge!) so it occupies more memory. You might also be experiencing a disk cache issue which would make your system slower.

Try to switching to the generic-smp kernel. You'll need to run mkinitrd... to install an init tree. It will only load those modules your system needs. Don't forget to update lilo.conf and re-run lilo too.
 
Old 09-02-2009, 04:28 PM   #3
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Sounds like the compositing issue with ARGB visuals - see CHANGES_AND_HINTS.TXT
 
Old 09-03-2009, 09:51 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,432

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
From CHANGES_AND_HINTS.TXT
Quote:
If you notice Xfce's Terminal and perhaps some other applications being drawn
very slowly in X, then you should try explicitly disabling the Composite
extension in /etc/X11/xorg.conf, or set XLIB_SKIP_ARGB_VISUALS=1 in your
environment prior to starting X. For more information on this, see:
http://bugzilla.xfce.org/show_bug.cgi?id=2792
From Robby Workman in http://bugzilla.xfce.org/show_bug.cgi?id=2792
Quote:
David and I just had a chat with Olivier in #xfce, and he advised that this is
essentially a user configuration problem. If the Composite extension is
enabled in xorg.conf, then Terminal will use ARGB32 window even if the
compositor is disabled in Xfce, moving or resizing ARGB32 is slow [if you don't
have hardware accelerated rendering.
From Olivier Fourdan in http://bugzilla.xfce.org/show_bug.cgi?id=2792
Quote:
Actually, these are different things. XLIB_SKIP_ARGB_VISUALS=1 instructs Xlib
not to advertise ARGB visuals. A compositor can be used even when without ARGB
(ie when XLIB_SKIP_ARGB_VISUALS is set), and (technically) nothing would
prevent an application from using ARGB visuals without a compositor (although
the use of ARGB visuals without a compositor will unlikely produce the expected
result, ie transparency

Let's not forget that the embedded compositor in xfwm4 can be enabled/disabled
on the fly without restarting, but the visual use by applications cannot be
changed that easily.

It would be better IMHO not to use ARGB in that case anyway.
From /usr/doc/NVIDIA_GLX-1.0/html/appendix-s.html
Quote:
This driver supports OpenGL rendering to 32-bit ARGB windows when the AddARGBGLXVisuals X config file option is enabled
I use the nvidia 96.43.13 driver, and I need to add
Code:
Option "AddARGBGLXVisuals" "True"
to the device section for the videocard in my xorg.conf to enable compositing. I do not see any problems in xfce.
Perhaps the above xorg.conf option will work better for you.
 
Old 09-08-2009, 07:13 PM   #5
egregor
Member
 
Registered: Sep 2009
Distribution: slackware, Salix, bsd's
Posts: 35

Original Poster
Rep: Reputation: 17
Hi. I read the nvidia manual, the bugzilla link and CHANGES_AND_HINTS.TXT.
Then I tested all these options and its combinations (nvidia-xconfig --no-composite, addargbglxvisuals, the environment variable one, ...), however it all gave the same result.
I perceived if there is some window behind the one being resized instead of the desktop area, the rendering is fast.


Thanks
 
Old 09-08-2009, 08:01 PM   #6
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,432

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Please post your xorg.conf.
 
Old 09-08-2009, 10:26 PM   #7
egregor
Member
 
Registered: Sep 2009
Distribution: slackware, Salix, bsd's
Posts: 35

Original Poster
Rep: Reputation: 17
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Thu Jun 25 18:57:07 PDT 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
# Option "AddARGBGLXVisuals" "0"
# Option "DisableGLXRootClipping" "1"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection
 
Old 09-08-2009, 10:27 PM   #8
egregor
Member
 
Registered: Sep 2009
Distribution: slackware, Salix, bsd's
Posts: 35

Original Poster
Rep: Reputation: 17
I omitted the fonts section. It was created by nvidia with little modifications.

And I forgot to say in earlier posts, these new tests were made using 2.6.29.6 generic smp kernel.


My PC specs are modest however without binary nvidia runs fast xfce: amd 32bits 3000+, 1GB ram, geforce mx 4000.

Last edited by egregor; 09-08-2009 at 10:39 PM.
 
Old 09-09-2009, 06:27 AM   #9
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,432

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Have you tried with these settings:
Quote:
Option "AddARGBGLXVisuals" "True"
and this section removed or commented out
Quote:
Section "Extensions"
Option "Composite" "Disable"
EndSection
and without XLIB_SKIP_ARGB_VISUALS=1 set in the environment?

This is what works for me.
 
Old 09-14-2009, 01:21 AM   #10
egregor
Member
 
Registered: Sep 2009
Distribution: slackware, Salix, bsd's
Posts: 35

Original Poster
Rep: Reputation: 17
Angry

Yes. I tried it all. I got to try now using the non-smp kernel.
With compiz it works nice! grrr


Thanks

Last edited by egregor; 09-14-2009 at 01:35 AM.
 
Old 12-12-2009, 11:34 AM   #11
mkoco
Member
 
Registered: Feb 2008
Location: US, New Jersey
Distribution: Slackware
Posts: 88

Rep: Reputation: 17
Was this problem ever resolved? I have the same exact issue on GeForce 3.
 
  


Reply

Tags
nvidia, slackware, xfce


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo/Xfce question ... icons not showing up. chigurh8 Gentoo 2 09-09-2009 01:07 AM
Icons not showing up in certain programs (Debian, XFCE) Rehumanize Linux - Software 0 01-10-2009 05:34 PM
XFCE desktop stopped showing icon knockout_artist Linux - Newbie 1 11-20-2008 09:21 AM
Drive icons showing on desktop Turd Flop Down Mleg Linux - Software 0 06-15-2008 11:22 PM
showing desktop icons master Slackware 7 07-03-2005 01:45 PM


All times are GMT -5. The time now is 03:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration