LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-03-2004, 11:06 PM   #1
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
Nvidia & glxgears, am I too slow?


I think I have my slack box set up as well as it can be. The one thing that bothers me though is the video. I believe I have everything set up right, but glxgears seems so slow compared to the numbers other people seem to be posting. Here's a sample:
Code:
shilo@shilo:~$ glxgears
393 frames in 5.0 seconds = 78.600 FPS
414 frames in 5.0 seconds = 82.800 FPS
416 frames in 5.0 seconds = 83.200 FPS
417 frames in 5.0 seconds = 83.400 FPS
415 frames in 5.0 seconds = 83.000 FPS
318 frames in 5.0 seconds = 63.600 FPS
164 frames in 5.0 seconds = 32.800 FPS
162 frames in 5.0 seconds = 32.400 FPS
163 frames in 5.0 seconds = 32.600 FPS
161 frames in 5.0 seconds = 32.200 FPS
164 frames in 5.0 seconds = 32.800 FPS
159 frames in 5.0 seconds = 31.800 FPS
164 frames in 5.0 seconds = 32.800 FPS
161 frames in 5.0 seconds = 32.200 FPS
154 frames in 5.0 seconds = 30.800 FPS
X connection to :0.0 broken (explicit kill or server shutdown).
The 32 FPS is where I maximized the window running the gears.

My specs:

Slackware -current
2.6.5 kernel
Vanta TNT2 16mb Video card
Nvidia driver
800mhz AMD Athlon
256M ram

Here's a sample from my /etc/X11/xorg.conf

Code:
# This loads the GLX module
    Load       "glx"
# This loads the DRI module
#    Load       "dri"
 
(snip)

# Device configured by xf86config:

Section "Device"
    Identifier  "RIVA TNT2"
    Driver      "nvidia"
    Option "NoLogo" "on"
    #VideoRam    16384
    # Insert Clocks lines here if appropriate
EndSection

(snip)

# Section "DRI"
#    Mode 0666
# EndSection
and here's most of the output from glxinfo:
Code:
shilo@shilo:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control
client glx vendor string: NVIDIA Corporation
client glx version string: 1.3
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
    GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
    GLX_NV_swap_group, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGI_swap_control, GLX_NV_float_buffer
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
    GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: RIVA TNT2/AGP/3DNOW!
OpenGL version string: 1.4.1 NVIDIA 53.36
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_point_parameters,
    GL_ARB_texture_env_add, GL_ARB_texture_mirrored_repeat,
    GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object, GL_ARB_window_pos,
    GL_EXT_texture_env_add, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_compiled_vertex_array, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
    GL_EXT_point_parameters, GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_stencil_wrap,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
    GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_vertex_array,
    GL_IBM_rasterpos_clip, GL_IBM_texture_mirrored_repeat,
    GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_fog_distance,
    GL_NV_packed_depth_stencil, GL_NV_texgen_reflection,
    GL_NV_texture_env_combine4, GL_SGIS_multitexture, GL_SUN_slice_accum
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess
Sorry to have such a lengthy post. Is this the best performance I can expect given my "top of the line" hardware?

Thank in advance,

Shilo
 
Old 05-03-2004, 11:21 PM   #2
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
I dont' know much about nvidia, or the Riva TNT card... But 80 fps seems a bit slow to me.

For a little reference, I get about 2000 fps with glxgears from my Radeon 9000 Pro.
No, not the same class, but that tells you why I think 80-32 is too slow.

However, it does say direct rendering is enabled. Which is good, and usually means you're working fine.

I would try uncommenting the DRI section at the end of your XF86Config file.

--Shade
 
Old 05-03-2004, 11:35 PM   #3
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Original Poster
Rep: Reputation: 49
Thanks for the quick response.

I uncommented the lines
Code:
# Section "DRI"
#    Mode 0666
# EndSection
No change.

Code:
shilo@shilo:~$ glxgears
412 frames in 5.0 seconds = 82.400 FPS
421 frames in 5.0 seconds = 84.200 FPS
421 frames in 5.0 seconds = 84.200 FPS
416 frames in 5.0 seconds = 83.200 FPS
285 frames in 5.0 seconds = 57.000 FPS
163 frames in 5.0 seconds = 32.600 FPS
163 frames in 5.0 seconds = 32.600 FPS
162 frames in 5.0 seconds = 32.400 FPS
160 frames in 5.0 seconds = 32.000 FPS
162 frames in 5.0 seconds = 32.400 FPS
X connection to :0.0 broken (explicit kill or server shutdown).
 
Old 05-03-2004, 11:41 PM   #4
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
A critical factor is whether you are running this in a minimized window, or a full screen. The full screen numbers will be considerably less. -- J.W.
 
Old 05-03-2004, 11:46 PM   #5
imagreg
Member
 
Registered: Mar 2004
Distribution: Slackware 10.0
Posts: 76

Rep: Reputation: 15
Hi shilo...

Was just wondering if you upgraded your kernel. And if so...did you reinstall the nvidia driver. The numbers that you posted look extremely slow. Your xf86config file looks fine. I am using an nvidia card and my numbers are:

4432 frames in 5.0 seconds = 886.400 FPS
10209 frames in 5.0 seconds = 2041.800 FPS
25322 frames in 5.0 seconds = 5064.400 FPS
4328 frames in 5.0 seconds = 865.600 FPS
18886 frames in 5.0 seconds = 3777.200 FPS
22175 frames in 5.0 seconds = 4435.000 FPS
19288 frames in 5.0 seconds = 3857.600 FPS
25525 frames in 5.0 seconds = 5105.000 FPS

My computer is decent but nothing state of the art.

By the way...which driver did you install from nvidia?

Greg

Last edited by imagreg; 05-03-2004 at 11:49 PM.
 
Old 05-03-2004, 11:46 PM   #6
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Original Poster
Rep: Reputation: 49
J.W.

Quote:
The 32 FPS is where I maximized the window running the gears.
Thanks, I figured that out.
 
Old 05-03-2004, 11:51 PM   #7
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Original Poster
Rep: Reputation: 49
imagreg-

Yes, I upgraded my kernel to 2.6.5. I upgraded my Nvidia drivers right after that. I installed the 5336 drivers.

Code:
shilo@shilo:~$ lsmod
Module                  Size  Used by
nvidia               2070120  12

(snip)

via_agp                 5824  1

(snip)

agpgart                28072  2 via_agp
Yeah, I was kinda thinking the numbers seemed slow, too.

Last edited by shilo; 05-03-2004 at 11:52 PM.
 
Old 05-03-2004, 11:54 PM   #8
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
do you have DMA enabled??
try this..
from a term window type
Code:
hdparm -tT /dev/hd??
just replace the ?? with your hard drive number........
post your output...........
 
Old 05-04-2004, 12:00 AM   #9
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Original Poster
Rep: Reputation: 49
320mb-

Yes, I have DMA enabled.

Code:
root@shilo:/home/shilo# hdparm -tT /dev/hda
 
/dev/hda:
 Timing buffer-cache reads:   484 MB in  2.02 seconds = 239.76 MB/sec
 Timing buffered disk reads:   76 MB in  3.06 seconds =  24.86 MB/sec
root@shilo:/home/shilo# hdparm -tT /dev/hda1
 
/dev/hda1:
 Timing buffer-cache reads:   368 MB in  2.00 seconds = 183.66 MB/sec
 Timing buffered disk reads:   80 MB in  3.13 seconds =  25.57 MB/sec
root@shilo:/home/shilo# hdparm /dev/hda
 
/dev/hda:
 multcount    =  0 (off)
 IO_support   =  1 (32-bit)
 unmaskirq    =  1 (on)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)
 geometry     = 59320/16/63, sectors = 59794560, start = 0
 
Old 05-04-2004, 04:19 AM   #10
Grymme
Member
 
Registered: Apr 2004
Location: Sweden
Distribution: Slackware
Posts: 44

Rep: Reputation: 15
You just included your driver-setting in your XF86Config

Thus I can't see if you have the driver activated in the screen-section. This might be the problem.

Here's the start of my screen-section:
Code:
Section "Screen"
    Identifier  "Screen 1"
    #Device      "VESA Framebuffer"
    Device      "Nvidia driver"
    Monitor     "My Monitor"
Chances are that you're still running your screen with the VESA Framebuffer if you didn't change. VESA Framebuffer is slow...

Last edited by Grymme; 05-04-2004 at 04:24 AM.
 
Old 05-04-2004, 06:52 AM   #11
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
I think you also need to uncomment

# Load "dri"

in the first portion of XF86Config
 
Old 05-04-2004, 08:57 AM   #12
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Re: Nvidia & glxgears, am I too slow?

Quote:
Originally posted by shilo

--<snip>--
Sorry to have such a lengthy post. Is this the best performance I can expect given my "top of the line" hardware?

Thank in advance,

Shilo
Yep, thats about it for a card this old.
 
Old 05-04-2004, 09:11 AM   #13
Grymme
Member
 
Registered: Apr 2004
Location: Sweden
Distribution: Slackware
Posts: 44

Rep: Reputation: 15
I'm not so sure about that Aussie. When I ran without hardware acceleration I got around 300 fps on glxgears on my athlon xp 2000+

80 fps with hardware acceleration on a 800mhz seems very low even for an old card like that.
 
Old 05-04-2004, 09:39 AM   #14
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
Thats all u can get from TNT2. I too have a nVidia Riva TNT2 (32MB) and 85fps in window mode is the maximum i can get in any distro (so i figured out that its not distro related) .
May be its time for me and u to buy a state of the art Videocard ;-) !
 
Old 05-04-2004, 11:51 AM   #15
rolins
LQ Newbie
 
Registered: May 2004
Posts: 4

Rep: Reputation: 0
I too have a vanta 16mb and im able to get around 390FPS in glxgears. Heres what I did.

in your ~/.bashrc add this to turn off vsync

"export __GL_SYNC_TO_VBLANK=0" without quotes.

If you dont have .bashrc then your have to create one by typing

"touch ~/.bashrc"

Then set xfree to 16 bits instead of 24 bits.

Thats it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slow FPS in glxgears with nVidia drivers installed jojotx0 Linux - Software 1 11-29-2005 03:58 PM
Quake 3 no sound, glxgears seems slow, should I use the 2.6.7 Kernel? opafire Slackware 4 10-27-2004 10:02 PM
Slow FPS in glxgears, GeForce FX 5200 GT_Onizuka Linux - Hardware 6 02-01-2004 07:28 PM
nvidia glxgears slow.... itsjustme Linux - General 7 12-28-2003 01:42 AM
glxgears - is my system slow?! Thermodynamic Linux - Software 2 08-01-2003 06:01 PM


All times are GMT -5. The time now is 07:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration