LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-29-2007, 04:19 AM   #1
Slack1_more
Member
 
Registered: Sep 2004
Location: Australia
Distribution: Slackware 10.0, 10.1, 11. and now 12!
Posts: 54

Rep: Reputation: 16
Angry Numeric Keypad not working in KDE


Why is the numeric keypad on my standard keyboard not working with KDE?
I start up my Slackware 12 and boot into a console window in which I can use the numeric keypad with gay abandon (no, I'm not gay, it's just a manner of speaking ), but when I run startx and I'm in KDE, it does not matter what I do with the num lock key or the KDE Control Centre, I cannot access the numbers on the keypad!
This is most frustrating as I use(d to use) the keypad all the time!

It's as if those keys were disabled, yet I'm sure that:
1) I had the numeric keypad working when I first started KDE after installing Slackware 12
2) I did not touch the xorg.conf keyboard section at all (just the video and mouse)
3) The problem seemed to rear its ugly head after I had used the KDE Control Centre for the first time.

Relevant information (that I can think of):

It's a standard US keyboard, defined as such to both Linux and KDE.
setxkbmap -print:
xkb_keymap {
xkb_keycodes { include "xfree86+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+us" };
xkb_geometry { include "pc(pc105)" };

XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

xorg.conf

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
EndSection

 
Old 07-29-2007, 05:09 AM   #2
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
KDE has its own keyboard settings. In the Control Center, look at Regional&Accessibility -> Keyboard Layouts and see if it's correctly defined.
 
Old 07-30-2007, 01:42 PM   #3
SCerovec
Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware x86 and ARM and Porteus
Posts: 655

Rep: Reputation: 45
If that fails, just erase the ~/.kde dir and start all over, this time a lot more carefull!
 
Old 08-17-2007, 04:16 AM   #4
Slack1_more
Member
 
Registered: Sep 2004
Location: Australia
Distribution: Slackware 10.0, 10.1, 11. and now 12!
Posts: 54

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by SCerovec View Post
If that fails, just erase the ~/.kde dir and start all over, this time a lot more carefull!
I'm sorry about the inordinately long delay, but I've been away and could not log in.
Could you please explain what you mean?
As I understand it, there's a heck of a lot of stuff under .kde, and I don't know what would happen if I followed your instructions, except maybe I'd have to re-install KDE.

Would you mind being more specific?

Thanks for your help
 
Old 08-17-2007, 04:59 AM   #5
Ekardnam
LQ Newbie
 
Registered: Nov 2003
Location: Sweden
Distribution: Slackware
Posts: 27

Rep: Reputation: 15
No, you don't have to reinstall KDE, but all of your settings etc. will vanish. If you want to try, I recommend you to simply rename/move ~./kde as a backup.

Now to your problem: I'm sorry if this sounds stupid, but is your Num Lock turned on? I think mine wasn't by default. You can change it in KControl, Peripherals->Keyboard->NumLock on KDE Startup.
 
Old 08-17-2007, 09:10 AM   #6
Slack1_more
Member
 
Registered: Sep 2004
Location: Australia
Distribution: Slackware 10.0, 10.1, 11. and now 12!
Posts: 54

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Ekardnam View Post
No, you don't have to reinstall KDE, but all of your settings etc. will vanish. If you want to try, I recommend you to simply rename/move ~./kde as a backup.

Now to your problem: I'm sorry if this sounds stupid, but is your Num Lock turned on? I think mine wasn't by default. You can change it in KControl, Peripherals->Keyboard->NumLock on KDE Startup.
I understand that a lot will vanish, thank you for your reply, but I wonder what I will need to do to recreate those settings.Will I need to simply use KDE Control Center or is there something more I need to do?

In response to your question, if you see my original post, I have tried using Control Center and, of course, toggled the Num Lock key, but I cannot get those keypad numbers to appear in any input field under KDE, although they work fine in a console.

Regards,
 
Old 08-20-2007, 06:26 PM   #7
SCerovec
Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware x86 and ARM and Porteus
Posts: 655

Rep: Reputation: 45
@Slack1_more
move the
Code:
/home/<Your user name>/.kde
directory or rename it to something else.
Next time when You log in to KDE, the whole directory (.kde) residing in Your home will be recreated.
.kde directory contains Your bookmarks, passwords, remembered input-fields and settings. Your Mail should be elsewhere (check in kmail if You use it). And documents should be elsewhere too .
The only risk in deleting said .kde is contained in posting success thus closing this thread
 
Old 04-22-2008, 03:50 PM   #8
yiehya
LQ Newbie
 
Registered: Feb 2006
Posts: 1

Rep: Reputation: 0
Problem solved on my Mandriva

Thank you
I had the same problem which made me suffer a lot.

Now after deleting the ~/.kde components, abd re-logged in again, everything went the way I want
and the Num keyboard is working and typing numbers.

thank you
 
  


Reply

Tags
keyboard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Numeric keypad behavior zeppelin1 Linux - Newbie 2 06-02-2007 04:30 AM
How to change the period-sign at the numeric keypad to a comma splx General 0 10-12-2006 03:23 PM
Numeric Keypad Inoperative after RH v9.0 reinstall nckeecho Red Hat 4 04-19-2006 11:12 AM
unsupported keycode from USB numeric keypad wilsonronl Linux - Hardware 0 09-10-2005 04:36 PM
Numeric keypad arrow keys arielgr Linux - Newbie 2 08-23-2005 11:04 AM


All times are GMT -5. The time now is 09:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration