LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   ntfs mounting in slackware (http://www.linuxquestions.org/questions/slackware-14/ntfs-mounting-in-slackware-106939/)

littlenicky 10-21-2003 08:56 PM

ntfs mounting in slackware
 
i was just wondering if anyone can help me, i am trying to mount my ntfs drives when i'm under linux, i have got them mounted to the folders i want, but the thing that doesnt seem to work is making them read only, does anyone know how to make them read only ?

trickykid 10-21-2003 09:01 PM

Actually the support to read NTFS filesystems is only in read-only. How or what are you seeing that is different in telling you so?

littlenicky 10-21-2003 09:52 PM

my friend was telling me to make sure it is read only or else u will screw up ur windows partitions... he said u have to type "ro" somewhere in the command line but whenever i did that, it said it didnt work

187807 10-21-2003 10:13 PM

re: NTFS mounting stuff...
 
Quote:

Originally posted by littlenicky
my friend was telling me to make sure it is read only or else u will screw up ur windows partitions... he said u have to type "ro" somewhere in the command line but whenever i did that, it said it didnt work
Well, given the current kernel development, write support is available (albeit experimental and with certain qualifications regarding file size and filename)...

Your friend is right. It is best to make SURE that the mount is read-only.

Just for *hits and giggles...I mounted my NTFS part with the following command (I'm running Slack9.1 and the 2.6-test7 kernel):

mount /dev/hda2 /mnt/xp


Well, after that I did a "mount" and saw that /mnt/xp was, in fact, mounted in (rw) mode...apparently I had forgotten to disable NTFS (rw) capability when I compiled the kernel.

That aside, how can we make SURE that we mount the NTFS part in read-only form?

Two ways according to my experience. Using my above example, I could issue:

mount -r /dev/hda2 /mnt/xp


A subsequent "mount" command verifies that my NTFS part is in fact mounted in read-only mode.

Another option is:

mount --ro /dev/hda2 /mnt/xp

(note the two dashes in front of "ro" instead of the one dash in front of "r" as in the above example).


I receive the same verification of my NTFS read-only status after issuing another "mount" command.


Try the above out...your mileage may vary, but I'll bet it doesn't vary by much.

Good luck...let us know what happens.

littlenicky 10-22-2003 01:31 AM

thanks man that worked pretty sweet...


All times are GMT -5. The time now is 11:27 PM.