LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-26-2014, 08:42 AM   #1
kenw232
Member
 
Registered: May 2006
Posts: 44

Rep: Reputation: 0
NSA SELinux can be turned off in kernel?


I'm running a slackware 14.1 production server. I compiled my own kernel 3.10.18. I'm seeing a bunch of these in my kernel error log:

[12891.745177] type=1401 audit(1390744778.400:3): SELinux: unrecognized netlink message type=20 for sclass=32
[12891.745177]
[12891.746369] type=1401 audit(1390744778.400:4): SELinux: unrecognized netlink message type=20 for sclass=32
[12891.746369]
[12891.747570] type=1401 audit(1390744778.400:5): SELinux: unrecognized netlink message type=20 for sclass=32
[12891.747570]

I noticed under "Security options" when compiling the kernel there is "NSA SELinux Support". Can this be turned off without impact? Account logins and passwd and PAM will all still work correct? Is there anything I need to know about this? What does it even do? Does it impact ext4 at all?

I actually get those above messages when I run /sbin/ss to see connections and whatnot. It also says
Jan 26 09:43:42 server [ 559.018776] audit_printk_skb: 12 callbacks suppressed

Thanks for any help.

uname -a:
Linux central 3.10.18 #13 SMP Sat Dec 14 15:53:39 EST 2013 x86_64 Intel(R) Xeon(R) CPU E5520 @ 2.27GHz GenuineIntel GNU/Linux

Last edited by kenw232; 01-26-2014 at 08:45 AM.
 
Old 01-26-2014, 09:07 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,026

Rep: Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966
NSA SELinux support is not set in Slackware kernels.

Code:
bash-4.2$ grep SELINUX config-*
config-generic-3.10.17:# CONFIG_SECURITY_SELINUX is not set
config-huge-3.10.17:# CONFIG_SECURITY_SELINUX is not set
bash-4.2$
And AFAIK PAM is not shipped in Slackware.

A bit of advice: when compiling your own kernel on Slackware, first take as a basis a config file provided by Slackware, run make oldconfig, then customize it as need be.

Last edited by Didier Spaier; 01-26-2014 at 09:09 AM.
 
Old 01-26-2014, 09:16 AM   #3
55020
Member
 
Registered: Sep 2009
Location: Yorks. W.R. 167397
Distribution: Slackware
Posts: 320
Blog Entries: 4

Rep: Reputation: 299Reputation: 299Reputation: 299
Yes it can be turned off without impact. SELinux implements mandatory access control. It is not enabled in Slackware's own kernels.

If you are new to compiling your own kernel, it is generally better to start from a Slackware configuration (which embodies many years of wisdom and experience) and only make changes that you understand, rather than starting with the kernel's defaults (which, frankly, are quite random).
 
Old 01-26-2014, 10:34 AM   #4
kenw232
Member
 
Registered: May 2006
Posts: 44

Original Poster
Rep: Reputation: 0
Great, thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mysqld won't start with Selinux enforcing turned on jdnow09 Linux - General 3 06-24-2009 01:37 PM
Is Clarkconnect compiled with GRSecurity or SeLinux turned on? enyawix Linux - Security 4 06-22-2009 09:17 PM
rhel 4 - new kernel 2.6.27-10 - now SELinux causes kernel panic legcard Linux - Kernel 3 02-09-2009 08:09 PM
where to get selinux kernel patchs? dansawyer Linux - Security 9 09-18-2006 10:06 PM
SELinux of NSA! SlackerLX Linux - Distributions 1 08-21-2005 04:28 AM


All times are GMT -5. The time now is 12:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration