LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-04-2005, 06:18 PM   #1
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Rep: Reputation: 30
Not all RAM is used - Highmem?


Have new install of slack 10.0. When booting I get the following from dmesg:
only 896MB will be used.
Use a HIGHMEM enabled kernel.
896MB LOWMEM available
------------------------------------------
I have 1.5 Gig of RAM.
1)Where do I get HIGHMEM enabled kernel?
2)I find references to performance issues with
HIGHMEM. Any comments?
3)Pointers and URLs to docs are welcomed!

thanks
tim
 
Old 05-04-2005, 06:38 PM   #2
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
For 1.5GB I think you'll have to enable high-mem. There are some low-mem patches that enable up to 1GB around, you might google for those. Enabling all your ram is going to require a recompile of the kernel though, I don't think there are stock Slackware kernels with this enabled.

Enabling high-mem has been known to slow some systems down a notch, but it's usually nothing noticable in a desktop environment.

--Shade
 
Old 05-04-2005, 06:59 PM   #3
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Shade
For 1.5GB I think you'll have to enable high-mem. There are some low-mem patches that enable up to 1GB around, you might google for those. Enabling all your ram is going to require a recompile of the kernel though, I don't think there are stock Slackware kernels with this enabled.

Enabling high-mem has been known to slow some systems down a notch, but it's usually nothing noticable in a desktop environment.

--Shade
Thanks Shade:
to enable high-mem, what module should I look for?

FYI: My slack is on another partition of this machine, so can't run
make menuconfig w/o rebooting, but can fake it on this RH 9.0
partition.

Quick google on ["enable Highmem" slackware module]
is not showing any slackware docs that I can see.
Have URLs to docs?

cheers
tim
 
Old 05-04-2005, 07:22 PM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Unfortunatly it can't be enabled with a module (you will have to rebuild the kernel) and it's not a Slackware specific thing (Slackware doesn't apply any patch to the kernel).
You'll find it (when using make menuconfig) under Processor type and features -> High Memory Support
 
Old 05-04-2005, 07:27 PM   #5
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by gbonvehi
Unfortunatly it can't be enabled with a module (you will have to rebuild the kernel) and it's not a Slackware specific thing (Slackware doesn't apply any patch to the kernel).
You'll find it (when using make menuconfig) under Processor type and features -> High Memory Support
No problem. Can rebuild. Thanks for the pointer above.
:-)
tim
 
Old 05-05-2005, 01:18 AM   #6
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Rep: Reputation: 45
Trying to refresh memory, its in,
processor type and features > high mem support

Afterwards, follow the kernel compiling guide in the first few posts.

Highmem works fine in most cases, but for me, it worked on 2 machines, but not my laptop. it kept giving me file system and data corruption. So take care, but it should work.
 
Old 05-05-2005, 08:41 AM   #7
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
There's two options for high mem... <4GB and <64GB. I had to enable 4GB support for my system, with 1GB of memory. It's no real biggie, but it will require a kernel recompile.



BTW, is anybody else spooked that it's a relatively trivial thing to buy a computer with more than 100X *RAM* than my first computer had *HARD DISK*? The truly 1337 gamerz use Hercules Monochrome. Hercules > j00!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FGLRX + Highmem - was working before, not a newbie, help needed... cosmyco Linux - Hardware 1 10-06-2005 11:53 AM
Error when recompiling 2.4.31 Kernel for SMP and HIGHMEM mjgould Slackware 15 09-28-2005 04:11 PM
Win98SE Pentium166MMX/64MB RAM vs Linux AthlonXP+ 3000/512MB RAM : Lucent LT WinModem t3gah Linux - Software 2 04-22-2005 01:01 PM
How do I enable the kernel for HIGHMEM? Mike Healan Mandriva 5 05-19-2004 12:40 PM
kernel recompiled with highmem-- still can't use all 2GB RAM nknowles Linux - General 0 12-04-2003 07:35 PM


All times are GMT -5. The time now is 02:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration