LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Not able to run 'links -g <URL> (http://www.linuxquestions.org/questions/slackware-14/not-able-to-run-links-g-url-4175415585/)

honeybadger 07-08-2012 05:37 PM

Not able to run 'links -g <URL>
 
I installed Slackware 13.37 and everything was working fine but then due to some (stupid) reasons I reinstalled. I installed some software from source (mainly tripwire and so on). But apart from that I installed nothing else.
This was a simillar configration I had and everything was working properly.
But now when I run links -g <URL> it shuts down with the error 'svgalib: Cannot open /dev/mem' (?!?!?). Are you running this program as root or suid-root.
Any pointers would be appereciated.
Thanks for reading.

silendo 07-08-2012 05:56 PM

The ".links" there is in the home directory? I think that this can be the main problem :)

honeybadger 07-08-2012 07:15 PM

Sorry that did not work. I looked at the .links directory but it only contained bookmarks.
Anyway I deleted the directory and but still the same error.

Any more suggestions?

I looked up the permissions of links. It seems ok (0755). I ran 'ldd /usr/bin/links' and it has /usr/lib/libvga.so.1.

Hope this helps.

volkerdi 07-08-2012 08:35 PM

Were you previously using a framebuffer but no longer are? As far as I'm aware, what you're describing has been normal for non-framebuffer "links -g" since the libvga helper kernel module went away (it's no longer supported for anything close to a recent kernel).

honeybadger 07-09-2012 03:27 AM

Framebuffers - thats it.
I am dual booting with BT and so I had some parameters passed to grub to make my screen resolution 800x600 (got bad eyesight. Made the grub parameters to default and everything is working fine.
Thanks a lot for the obervation volkerdi.

ottavio 07-09-2012 02:57 PM

You've marked this thread as solved but I have exactly the same error, the difference with me is that this happens only in X, not when run from pure console, in which case it's fine. What should I look at? I have removed the ~.links directory. My system is 13.37 32-bit. Thanks

EDIT: I have vga=default in lilo.conf if this can help.

ponce 07-09-2012 03:20 PM

excerpts from "man links"
Quote:

-g Run Links in graphics mode. If not given, Links will run in text mode. Running in graphics mode means that Links will probe all compiled-in graphics devices and run on the first found. If none found, links will not run in text mode. This option works only if --enable-graphics was given to ./configure.
...
-driver <driver name>
Graphics driver to use. Drivers are: x, svgalib, fb, directfb, pmshell, atheos. List of drivers will be shown if you give it an unknown driver. Available drivers depend on your operating system and available libraries.
Code:

$ links -g -driver x http://www.google.com
Unknown graphics driver x.
The following graphics drivers are supported:
fb, svgalib

when you run links -g in console it probably works for you because you have a framebuffer console, so links uses the fb driver.
if you launch X and you don't run it using the framebuffer driver, the -g mode can't work because svgalib isn't supported and the framebuffer is not available.

ottavio 07-09-2012 03:29 PM

Ah ok, if I put together this statement:
Quote:

Originally Posted by volkerdi (Post 4722527)
the libvga helper kernel module went away (it's no longer supported for anything close to a recent kernel).

with this:
Quote:

Originally Posted by ponce (Post 4723172)
the -g mode can't work because svgalib isn't supported and the framebuffer is not available.

it's all clear now.

Soderlund 11-19-2012 09:53 AM

Just thought I'd add, if anyone's struggling with this:

Rebuild links from the official sources, but change the -without-x ./configure option to -with-x in the links.SlackBuild. Then it works in X with -g.


All times are GMT -5. The time now is 01:24 AM.