LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-15-2007, 10:07 PM   #1
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 339

Rep: Reputation: 27
Non-root user has read-only access to fat-c partition


I have a fat32 partition mounted at /fat-c. My non-root users seem to have only read-only access to it, whereas root does. What am I missing - it's a fat32 partition, so you can't assign access rights to it. How do I give write access to non-root users? Slackware 11, 2.6.12.1 kernel.
 
Old 05-15-2007, 10:12 PM   #2
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Maybe with this line in fstab:

/dev/sda1 /mnt/sda1 vfat auto,users,suid,dev,exec 0 0
 
Old 05-15-2007, 10:59 PM   #3
folkenfanel
Member
 
Registered: Sep 2004
Location: formerly Fanelia and Zaibach
Distribution: Slackware-current with KDE 4.8.5
Posts: 303

Rep: Reputation: 36
Thumbs up From my fstab

/dev/hda1 /disc/win vfat auto,rw,umask=000 1 0
 
Old 05-16-2007, 08:06 PM   #4
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 339

Original Poster
Rep: Reputation: 27
Quote:
/dev/sda1 /mnt/sda1 vfat auto,users,suid,dev,exec 0 0
/dev/hda1 /disc/win vfat auto,rw,umask=000 1 0
/dev/hda1 /fat-c vfat auto,user,exec,rw 0 0
None of these work. I seem to be missing something. I created a user and made them a member of every group, and that user still has no write access to it.
 
Old 05-16-2007, 11:04 PM   #5
folkenfanel
Member
 
Registered: Sep 2004
Location: formerly Fanelia and Zaibach
Distribution: Slackware-current with KDE 4.8.5
Posts: 303

Rep: Reputation: 36
Wink Hi again

Hi!

I will explain this a bit more clearly:

----------------------------------------------
d | mp | fs | options
----------------------------------------------
/dev/hda1 /disc/win vfat auto,rw,umask=000 1 0

d=your device and partition
mp=your mount point
fs=your filesystem
options=options

That comes from "mount" e.g.

mount -t reiserfs /dev/hda6 /disc/disc6

where "reiserfs" is the filesystem, "/dev/hda6" is the partition and "/disc/disc6" is a mount point, this is, a folder anywhere inside my root folder. That "mount point" has to be created before I attempt to mount something using it.

Now let's get it...
 
Old 05-16-2007, 11:11 PM   #6
folkenfanel
Member
 
Registered: Sep 2004
Location: formerly Fanelia and Zaibach
Distribution: Slackware-current with KDE 4.8.5
Posts: 303

Rep: Reputation: 36
Wink ...we are still here

Let's do it!

You said you had:
/dev/sda1 /mnt/sda1 vfat auto,users,suid,dev,exec 0 0
/dev/hda1 /disc/win vfat auto,rw,umask=000 1 0
/dev/hda1 /fat-c vfat auto,user,exec,rw 0 0

The one in the middle works for me, (as a matter of fact it has worked that way since 2003) and it could work for you as well, BUT you have to have in mind that you have to redirect that to an existing mount point in YOUR system. As you said you HAD a "/fat-c" folder, I bet the fstab line for you would be:

/dev/hda1 /fat-c vfat auto,rw,umask=000 1 0

You can also use the former, (with "/disc/win" or whatever you like), by creating the folder beforehand

mkdir /disc/win

(or whatever name you might want to use)

May the Source be with you!
 
Old 05-16-2007, 11:19 PM   #7
TheLateJC
Member
 
Registered: Apr 2007
Location: Sydney
Distribution: Debian. (Formerly Slackware, Gentoo, RHEL, and Suse)
Posts: 80

Rep: Reputation: 15
Quote:
Originally Posted by Ook
I created a user and made them a member of every group
It would be best to undo that at the earliest opportunity.
 
Old 05-17-2007, 03:54 PM   #8
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
http://slackwiki.org/Windows_Partitions
 
Old 05-17-2007, 10:06 PM   #9
folkenfanel
Member
 
Registered: Sep 2004
Location: formerly Fanelia and Zaibach
Distribution: Slackware-current with KDE 4.8.5
Posts: 303

Rep: Reputation: 36
rworkman has a point

about umask (read that article). I use Windows mainly for gaming. (this means PristonTale) I almost never use MSIE. I don't have many programs installed - only what I still can not run with Wine-Cedega (I am also a CrossOver tester).

Since I am still completing some big downloads here, I haven't used Windows here for weeks. Using plainly umask there -could- be a security risk.
 
Old 05-23-2007, 11:30 PM   #10
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 339

Original Poster
Rep: Reputation: 27
Quote:
Originally Posted by folkenfanel
.....
/dev/hda1 /fat-c vfat auto,rw,umask=000 1 0

.....
I have /fat-c, it's where I've always mounted my fat partition. If I include unmask=000, I get:

FAT: Unrecognized mount option "unmask=000"

If I remove the unmask=000, it mounts the partition - but read only for non-root users. This is the exact line I use:

/dev/hda1 /fat-c vfat auto,rw,unmask=000 1 0

And it gives the above error and does not mount the partition. It does, however, recognize fmask and dmask, just not unmask. Go figure?

Last edited by Ook; 05-23-2007 at 11:49 PM.
 
Old 05-24-2007, 02:31 AM   #11
Tux-Slack
Member
 
Registered: Nov 2006
Location: Slovenia
Distribution: Slackware 13.37
Posts: 511

Rep: Reputation: 36
It's umask not unmask
I solved this in another way
I created a group win with GID 103
added myself to that group
and edited fstab like this:
Code:
/dev/hda1        /win         ntfs-3g     defaults,gid=103,dmask=1227,fmask=1117         1   2
Ok it's for a NTFS partition.
But you should do the same, add gid=103 to fstab.
ignore the dmask and fmask in my fstab as you won't need it
 
Old 05-24-2007, 09:28 AM   #12
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
All of this is detailed in the SlackWiki page I linked... :/
 
Old 05-25-2007, 08:49 AM   #13
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 339

Original Poster
Rep: Reputation: 27
Quote:
Originally Posted by rworkman
All of this is detailed in the SlackWiki page I linked... :/
I know, I read it, good stuff. My problem was using UNMASK instead of UMASK LOL. My bad
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't access fat partition with normal user account gilebo Linux - Newbie 4 04-27-2006 11:42 AM
slackware 10.. root user only gets read only access gtan Slackware 2 09-25-2004 07:51 AM
non-root user cannot access Windows partition curmudgeon42 Linux - General 3 08-13-2004 04:33 PM
Write access on FAT partition by ordinary user Linner Fedora 6 06-17-2004 04:42 AM
fstab: giving a user acct read-only access to specific partition doorbits Linux - General 4 05-18-2004 02:11 PM


All times are GMT -5. The time now is 09:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration