LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-10-2008, 04:39 PM   #1
Romanus81
Member
 
Registered: Feb 2008
Posts: 201

Rep: Reputation: 31
No write or read access to anything I mount


Is there a skill I'm missing here?
sudo mount /dev/sda1 /mnt/windows
cd /mnt windows
-bash: cd: /mnt/windows: Permission denied
And it's like that for everything: samba shares, fstab mounts, regular mounts, am I supposed to uncomment something in some file somewhere?
 
Old 04-10-2008, 04:50 PM   #2
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 70
Try putting the user or users option in fstab.

Alternatively, you can specify mode and umask (which have different effects depending on the type of partition).
 
Old 04-10-2008, 05:02 PM   #3
jimmy512
Member
 
Registered: Oct 2006
Location: London
Distribution: Arch
Posts: 183

Rep: Reputation: 31
Make sure you have read permissions on the folders which you are trying to read. I found that I had this problem with a folder which I was mounting too. The sudo will give you temporary root permissions for that command only, so when you run the cd command, the root permissions will be lost. Try running sudo cd /mnt/windows too. If this doesn't work, you will have to use chmod to change the read and write permissions on the folder you are mounting to.

If the disk is permanently in place, it may be easier to mount the disk with an entry in your fstab, for example:
Code:
/dev/sda1 /mnt/windows ntfs user,noauto,noatime 0 0
Then you would only need to type "mount /mnt/windows".

The user flag will allow a normal user to mount the disk, and the noauto will stop the disk being mounted at boot time, which may be useful if you dont use the disk all the time, as it reduces the risk of you accidentally deleting something. If it gives errors about the filesystem type, change ntfs to auto, it has no problems detecting my ntfs disk.

For more info, try "man fstab" at your terminal.
 
Old 04-10-2008, 07:23 PM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Another approach, is to use a little program called pmount which let's you mount anything as user. However, it's not included in default Slackware distribution but you can get it here: http://slackbuilds.org/repository/12.0/system/pmount/
If it's not a removable device, you've to specify it in /etc/pmount.allow

Adding user as suggested above should work.
 
Old 04-10-2008, 11:34 PM   #5
gankoji
Member
 
Registered: Nov 2007
Location: Southern California
Distribution: Slackware-13.0 x86_64, Slackware 12.2, slackware64-current
Posts: 225

Rep: Reputation: 35
also, you could be running into problems in that you're mounting an ntfs filesystem. This shouldn't affect reading, but if you find that you can't write anything to that FS then look up linux-ntfs at linux-ntfs.sourceforge.net/ . That will let you write files to that filesystem since I don't think that the kernel can handle that (at least on the older 2.6 versions).
 
Old 04-11-2008, 04:51 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,040
Blog Entries: 52

Rep: Reputation: Disabled
Get the SlackBuilds for fuse and ntfs-3g.
 
Old 04-12-2008, 05:48 PM   #7
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,263

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
I agree with brianL about fuse and ntfs-3g -- they are currently more feature-complete and more reliable than ntfsprogs etc., as far as I can tell (though I may be wrong). Ubuntu uses it as default to read NTFS drives, and I've never had a problem (or any corruption) using the current versions in Ubuntu or Slackware.
 
Old 04-13-2008, 07:19 AM   #8
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
brianL, T3slider + gbonvehi +ivman

if it is ntfs, go for ntfs-3g, +pmount,ivman will help you to auto mount.

regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't mount HD in read/write!! unilynx Debian 2 09-20-2007 09:07 PM
Mount ISO with read/write access the-yikes Slackware 3 08-06-2007 08:26 PM
How do I mount read/write? M$ISBS Linux - Hardware 4 11-07-2006 04:20 PM
Mount ISO Read/Write Johnsernickle Linux - Software 4 06-03-2005 03:19 PM
read write access phoenix_wolf Linux - Newbie 2 12-05-2004 09:35 AM


All times are GMT -5. The time now is 04:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration