LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   No write or read access to anything I mount (http://www.linuxquestions.org/questions/slackware-14/no-write-or-read-access-to-anything-i-mount-634483/)

Romanus81 04-10-2008 04:39 PM

No write or read access to anything I mount
 
Is there a skill I'm missing here?
sudo mount /dev/sda1 /mnt/windows
cd /mnt windows
-bash: cd: /mnt/windows: Permission denied
And it's like that for everything: samba shares, fstab mounts, regular mounts, am I supposed to uncomment something in some file somewhere?

osor 04-10-2008 04:50 PM

Try putting the user or users option in fstab.

Alternatively, you can specify mode and umask (which have different effects depending on the type of partition).

jimmy512 04-10-2008 05:02 PM

Make sure you have read permissions on the folders which you are trying to read. I found that I had this problem with a folder which I was mounting too. The sudo will give you temporary root permissions for that command only, so when you run the cd command, the root permissions will be lost. Try running sudo cd /mnt/windows too. If this doesn't work, you will have to use chmod to change the read and write permissions on the folder you are mounting to.

If the disk is permanently in place, it may be easier to mount the disk with an entry in your fstab, for example:
Code:

/dev/sda1 /mnt/windows ntfs user,noauto,noatime 0 0
Then you would only need to type "mount /mnt/windows".

The user flag will allow a normal user to mount the disk, and the noauto will stop the disk being mounted at boot time, which may be useful if you dont use the disk all the time, as it reduces the risk of you accidentally deleting something. If it gives errors about the filesystem type, change ntfs to auto, it has no problems detecting my ntfs disk.

For more info, try "man fstab" at your terminal.

gbonvehi 04-10-2008 07:23 PM

Another approach, is to use a little program called pmount which let's you mount anything as user. However, it's not included in default Slackware distribution but you can get it here: http://slackbuilds.org/repository/12.0/system/pmount/
If it's not a removable device, you've to specify it in /etc/pmount.allow

Adding user as suggested above should work.

gankoji 04-10-2008 11:34 PM

also, you could be running into problems in that you're mounting an ntfs filesystem. This shouldn't affect reading, but if you find that you can't write anything to that FS then look up linux-ntfs at linux-ntfs.sourceforge.net/ . That will let you write files to that filesystem since I don't think that the kernel can handle that (at least on the older 2.6 versions).

brianL 04-11-2008 04:51 AM

Get the SlackBuilds for fuse and ntfs-3g.

T3slider 04-12-2008 05:48 PM

I agree with brianL about fuse and ntfs-3g -- they are currently more feature-complete and more reliable than ntfsprogs etc., as far as I can tell (though I may be wrong). Ubuntu uses it as default to read NTFS drives, and I've never had a problem (or any corruption) using the current versions in Ubuntu or Slackware.

rkrishna 04-13-2008 07:19 AM

brianL, T3slider + gbonvehi +ivman

if it is ntfs, go for ntfs-3g, +pmount,ivman will help you to auto mount.

regards


All times are GMT -5. The time now is 07:29 PM.