LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-16-2011, 05:11 PM   #1
Lucifer4o
Member
 
Registered: Mar 2010
Distribution: Slackware Current
Posts: 50

Rep: Reputation: 15
No Video after update to current ...


Hi guys! I'm in a bit of a pickle here:

After upgrading to current, I lost my video ... On boot I see the console until missage like this:

Quote:
Feb 17 00:49:14 shadow kernel: [ 32.286223] [drm] radeon: ib pool ready.
And than ... boom! No more video ... no more nothing ...

Last edited by Lucifer4o; 02-16-2011 at 05:12 PM.
 
Old 02-16-2011, 05:22 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,527

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Have you checked the ChangeLog?
Quote:
This new driver requires KMS, which is set by default in the new kernel.
Otherwise, create /etc/modprobe.d/radeon.conf with this content:
options radeon modeset=1
Also, the kernel should be booted with vga=normal.
Problems have been observed when trying to use KMS after starting a VESA
framebuffer console. Sorry about the penguins.
 
Old 02-16-2011, 05:32 PM   #3
Lucifer4o
Member
 
Registered: Mar 2010
Distribution: Slackware Current
Posts: 50

Original Poster
Rep: Reputation: 15
OK. I setted vga=normal, but the problem persists ... I now boot with the modprobe modification.

This time I have video ...
 
Old 02-16-2011, 05:53 PM   #4
Lucifer4o
Member
 
Registered: Mar 2010
Distribution: Slackware Current
Posts: 50

Original Poster
Rep: Reputation: 15
Nope ... no luck here ...
 
Old 02-16-2011, 06:22 PM   #5
Lucifer4o
Member
 
Registered: Mar 2010
Distribution: Slackware Current
Posts: 50

Original Poster
Rep: Reputation: 15
Ok .. I tried installing FGLRX, Reverting to old ati drivers, reverting to mesa in pasture ... none of the combination gave any efect ...
 
Old 02-16-2011, 08:10 PM   #6
hemp4fuel
Member
 
Registered: Jun 2003
Location: Topeka, KS
Distribution: Slackware
Posts: 192

Rep: Reputation: 45
OK... what ati card?
 
Old 02-17-2011, 03:31 AM   #7
Lucifer4o
Member
 
Registered: Mar 2010
Distribution: Slackware Current
Posts: 50

Original Poster
Rep: Reputation: 15
Ati Radeon 3450 HD
 
Old 02-17-2011, 04:19 AM   #8
Lucifer4o
Member
 
Registered: Mar 2010
Distribution: Slackware Current
Posts: 50

Original Poster
Rep: Reputation: 15
OK! I'm going to buy an External HDD, download all my info and reinstall back to 32bit ... I hope this will give me and game abillity ... like SC2
 
Old 02-17-2011, 05:48 AM   #9
dolphin77
Member
 
Registered: May 2009
Posts: 200

Rep: Reputation: 54
Quote:
Originally Posted by Lucifer4o View Post
OK. I setted vga=normal, but the problem persists ... I now boot with the modprobe modification.

This time I have video ...
Did you run lilo after you changed lilo.conf?! Your card should work with opensource driver "out of the box" with the latest -current. Well maybe with a little bit of tuning.
 
Old 02-17-2011, 07:03 AM   #10
Lucifer4o
Member
 
Registered: Mar 2010
Distribution: Slackware Current
Posts: 50

Original Poster
Rep: Reputation: 15
It apears I'm dumb ... verry dumb! Thank you for the lilo hint! ... Weeel at least I bought My self 1TB external HDD ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
x crashes after update to -current max_arbit Slackware 3 12-19-2010 12:00 PM
Painless update from 11 to current? ivanatora Slackware 3 01-10-2008 03:02 PM
Update Video Drivers for Voodoo 3 video card ki4cmo Linux - Software 5 01-02-2007 06:22 PM
thursday's (09/02/06) current update KMcD Slackware 3 02-11-2006 06:01 PM
When Ever I Update to Current FXRS Slackware 5 04-19-2004 02:13 AM


All times are GMT -5. The time now is 01:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration