LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   No UTF-8 in console mode. (http://www.linuxquestions.org/questions/slackware-14/no-utf-8-in-console-mode-604626/)

Linux.tar.gz 12-05-2007 04:15 AM

No UTF-8 in console mode.
 
I recently switched from iso-8859-15 to UTF-8.
I have no (annoying) trouble under X.

Here's my /etc/profile.d/lang.sh

export LANG=fr_FR.UTF-8
export LC_COLLATE=fr_FR

When i'm in pure console mode, characters with accents are changed to A or AC or some other uppercase.

iiv 12-05-2007 07:17 AM

You forgot to set up a fr-unicode font? I set up local for ru_RU.UTF-8. rc.font:
Code:

/usr/bin/unicode_start cyr-sun16
so for French it should be similar, additionally you should enable a keymap for your language in rc.keymap

Linux.tar.gz 12-06-2007 05:15 AM

Wow ! I never though there was some kind of daemon for fonts !

Thank you, i will dig it.


All times are GMT -5. The time now is 10:43 PM.