LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-25-2008, 09:43 AM   #1
pauledwards03
Member
 
Registered: Dec 2006
Distribution: Slackware 12.1
Posts: 94

Rep: Reputation: 15
no usb automounting with new kernel


So I decided to try my hand at making a custom kernel, by taking out nearly everything I thought I did not need. So far everything works except for automounting of my usb stick. I used to use KDE and it worked with KDE with the default slackware 12.1 kernel. I switched to fluxbox and got a new kernel and stripped it, now I cannot access my USB stick in any way. lsscsi reports nothing. hal udev and dbus are all running. I loaded into KDE with the root account just to check and sure enough, no USB stick. I am thinking that I missed something in the kernel configuration. This is kernel 2.6.26.5. Can anyone tell me what options to look for in the kernel config about this? Thanks.

I also cannot mount it manually. special device /dev/sda does not exist

BTW USB in general works, I have a USB mouse and it works fine. also dmesg shows this when I remove and plug in the device:

Code:
usb 1-1: new full speed USB device using uhci_hcd and address 4
usb 1-1: configuration #1 chosen from 1 choice
usb 1-1: USB disconnect, address 4
usb 1-1: new full speed USB device using uhci_hcd and address 5
usb 1-1: configuration #1 chosen from 1 choice
usb 1-1: USB disconnect, address 5
usb 1-1: new full speed USB device using uhci_hcd and address 6
usb 1-1: configuration #1 chosen from 1 choice
 
Old 09-25-2008, 10:16 AM   #2
pauledwards03
Member
 
Registered: Dec 2006
Distribution: Slackware 12.1
Posts: 94

Original Poster
Rep: Reputation: 15
definitely a kernel issue, just booted with original slackware kernel and I saw "loading usb filesystem driver" and loaded kde with root and i was able to mount the stick. I have the two kernel .configs side-by-side and making adjustments
 
Old 09-25-2008, 10:20 AM   #3
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
Maybe CONFIG_BLK_DEV_SD is not set ?
-> Device Drivers -> SCSI device support
 
Old 09-25-2008, 11:25 AM   #4
pauledwards03
Member
 
Registered: Dec 2006
Distribution: Slackware 12.1
Posts: 94

Original Poster
Rep: Reputation: 15
Indeed. I enabled that and it works. Thanks a lot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
automounting usb pen edgjerp Linux - Hardware 2 04-24-2008 05:45 AM
please help with automounting usb on etch mmoalem Linux - Hardware 7 03-12-2007 04:02 PM
Automounting a USB Harddrive rflook Debian 1 02-26-2007 06:40 AM
how does usb automounting work? m_yates Ubuntu 1 12-24-2005 09:35 PM
usb automounting wi_slacker Slackware 6 05-05-2004 12:30 AM


All times are GMT -5. The time now is 03:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration