LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-22-2006, 08:04 AM   #1
rhermsen
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 41

Rep: Reputation: 16
No text console after upgrade to 11.0 in init4


I upgraded my system from 10.2 to 11.0.
Sometime after going through all .new config files I lost to posibility to switch to a text constole using Ctl-Alt-F6. My system is running in init 4.

Non of the Ctl-Alt-Fx seems to be working.

According inittab tty6 should be available in init4:

# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux


In init 3 I can switch between tty1 to tty6 with Alt-F1-6.

Hopefully someone can help me to get my text console back.
 
Old 10-22-2006, 08:41 AM   #2
introuble
Member
 
Registered: Apr 2004
Distribution: Debian -unstable
Posts: 700

Rep: Reputation: 31
What happens if you go in init 3, start X via startx [or whatever] and try CTRL+ALT+F1 [example]?
 
Old 10-22-2006, 09:17 AM   #3
rhermsen
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 41

Original Poster
Rep: Reputation: 16
Thanks for your reply.
Also if I startx from init 3 I cannot switch with Ctl-Alt-Fx.
 
Old 10-22-2006, 10:39 AM   #4
slackware_newbie
Member
 
Registered: Sep 2006
Posts: 52

Rep: Reputation: 15
why don't you just add runlevel 4 to you inittab like I did:

Code:
# These are the standard console login getties in multiuser mode:
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:12345:respawn:/sbin/agetty 38400 tty2 linux
c3:12345:respawn:/sbin/agetty 38400 tty3 linux
c4:12345:respawn:/sbin/agetty 38400 tty4 linux
c5:12345:respawn:/sbin/agetty 38400 tty5 linux
mb:12345:respawn:/usr/bin/nice -n 19 /home/mb/moneybee/MoneyBeeLinux > /dev/tty6 < /dev/tty6
#c6:12345:respawn:/sbin/agetty 38400 tty6 linux
 
Old 10-22-2006, 10:57 AM   #5
rhermsen
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 41

Original Poster
Rep: Reputation: 16
I changed the inittab to include init 4 for tty 1 to 6. That will give me 6 text consoles if I get it to work again.

But this seems an issue with Xorg or so.
diff /etc/X11/xorg.conf /home/backup/xorg.conf
Shows no differences.
 
Old 10-22-2006, 11:27 AM   #6
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
It's probably an issue with the keyboard driver (some things changed between 6.8 and 6.9).
Please post the relevant section of your /etc/X11/xorg.conf.
 
Old 10-22-2006, 01:23 PM   #7
rhermsen
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 41

Original Poster
Rep: Reputation: 16
I must say that I didn't understoot the remark "You'll probably also need to edit your /etc/X11/xorg.conf to change the name of the keyboard driver from "Keyboard" to "kbd". I don't know why this changed, but it did."
in UPGRADE.TXT. My xorg.conf is exact the same as before:

Code:
Section "InputDevice"

# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.
#    Option     "Protocol"      "Xqueue"
#    Option     "Xleds"      "1 2 3"
#    Option "LeftAlt"     "Meta"
#    Option "RightAlt"    "ModeShift"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#    Option "XkbModel"    "pc105"
# If you have a US Microsoft Natural keyboard, you can use:
#    Option "XkbModel"    "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#    Option "XkbLayout"   "de"
# or:
#    Option "XkbLayout"   "de"
#    Option "XkbVariant"  "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#    Option "XkbOptions"  "ctrl:swapcaps"
# These are the default XKB settings for Xorg
#    Option "XkbRules"    "xorg"
#    Option "XkbModel"    "pc105"
#    Option "XkbLayout"   "us"
#    Option "XkbVariant"  ""
#    Option "XkbOptions"  ""
#    Option "XkbDisable"
    Identifier     "Keyboard1"
    Driver         "kbd"
    Option         "AutoRepeat" "500 30"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us_intl"
EndSection
 
Old 10-22-2006, 01:35 PM   #8
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
try to change "XkbLayout" "us_intl" to "XkbLayout" "us"
 
Old 10-22-2006, 02:08 PM   #9
rhermsen
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 41

Original Poster
Rep: Reputation: 16
Thanks uselpa,
changing "XkbLayout" "us_intl" to "XkbLayout" "us" did indeed solve this issue.

Thanks a lot!
 
Old 10-22-2006, 02:16 PM   #10
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
The version of X packaged with Slackware 11 does not like certain XkbLayout and XkbCompat directives in xorg.conf. I had the same problem of losing the ability to toggle among virtual screens. I wish somebody would explain why this happens.
 
Old 10-22-2006, 02:30 PM   #11
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
AFAIK it's not a Slackware packaging issue but rather a change due to Xorg 6.9. I have never found a complete documentation but there's a lot of posts you can find via Google, regarding Linux and BSDs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
copying text from console spx2 Linux - Newbie 11 12-18-2005 05:48 AM
Kernel 2.6.12 upgrade and console text size Dr. Psy Slackware 8 06-23-2005 02:52 AM
How do I see all text in console? fannymites Linux - General 2 04-15-2005 06:01 PM
Console text gamehack Slackware 6 09-25-2004 04:00 AM
Console text garbled cap'n leaky Slackware 6 09-06-2003 08:18 PM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration