LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   No text console after upgrade to 11.0 in init4 (http://www.linuxquestions.org/questions/slackware-14/no-text-console-after-upgrade-to-11-0-in-init4-494590/)

rhermsen 10-22-2006 09:04 AM

No text console after upgrade to 11.0 in init4
 
I upgraded my system from 10.2 to 11.0.
Sometime after going through all .new config files I lost to posibility to switch to a text constole using Ctl-Alt-F6. My system is running in init 4.

Non of the Ctl-Alt-Fx seems to be working.

According inittab tty6 should be available in init4:

# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux


In init 3 I can switch between tty1 to tty6 with Alt-F1-6.

Hopefully someone can help me to get my text console back.

introuble 10-22-2006 09:41 AM

What happens if you go in init 3, start X via startx [or whatever] and try CTRL+ALT+F1 [example]?

rhermsen 10-22-2006 10:17 AM

Thanks for your reply.
Also if I startx from init 3 I cannot switch with Ctl-Alt-Fx.

slackware_newbie 10-22-2006 11:39 AM

why don't you just add runlevel 4 to you inittab like I did:

Code:

# These are the standard console login getties in multiuser mode:
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:12345:respawn:/sbin/agetty 38400 tty2 linux
c3:12345:respawn:/sbin/agetty 38400 tty3 linux
c4:12345:respawn:/sbin/agetty 38400 tty4 linux
c5:12345:respawn:/sbin/agetty 38400 tty5 linux
mb:12345:respawn:/usr/bin/nice -n 19 /home/mb/moneybee/MoneyBeeLinux > /dev/tty6 < /dev/tty6
#c6:12345:respawn:/sbin/agetty 38400 tty6 linux


rhermsen 10-22-2006 11:57 AM

I changed the inittab to include init 4 for tty 1 to 6. That will give me 6 text consoles if I get it to work again.

But this seems an issue with Xorg or so.
diff /etc/X11/xorg.conf /home/backup/xorg.conf
Shows no differences.

uselpa 10-22-2006 12:27 PM

It's probably an issue with the keyboard driver (some things changed between 6.8 and 6.9).
Please post the relevant section of your /etc/X11/xorg.conf.

rhermsen 10-22-2006 02:23 PM

I must say that I didn't understoot the remark "You'll probably also need to edit your /etc/X11/xorg.conf to change the name of the keyboard driver from "Keyboard" to "kbd". I don't know why this changed, but it did."
in UPGRADE.TXT. My xorg.conf is exact the same as before:

Code:

Section "InputDevice"

# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.
#    Option    "Protocol"      "Xqueue"
#    Option    "Xleds"      "1 2 3"
#    Option "LeftAlt"    "Meta"
#    Option "RightAlt"    "ModeShift"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#    Option "XkbModel"    "pc105"
# If you have a US Microsoft Natural keyboard, you can use:
#    Option "XkbModel"    "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#    Option "XkbLayout"  "de"
# or:
#    Option "XkbLayout"  "de"
#    Option "XkbVariant"  "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#    Option "XkbOptions"  "ctrl:swapcaps"
# These are the default XKB settings for Xorg
#    Option "XkbRules"    "xorg"
#    Option "XkbModel"    "pc105"
#    Option "XkbLayout"  "us"
#    Option "XkbVariant"  ""
#    Option "XkbOptions"  ""
#    Option "XkbDisable"
    Identifier    "Keyboard1"
    Driver        "kbd"
    Option        "AutoRepeat" "500 30"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "us_intl"
EndSection


uselpa 10-22-2006 02:35 PM

try to change "XkbLayout" "us_intl" to "XkbLayout" "us"

rhermsen 10-22-2006 03:08 PM

Thanks uselpa,
changing "XkbLayout" "us_intl" to "XkbLayout" "us" did indeed solve this issue.

Thanks a lot!

Woodsman 10-22-2006 03:16 PM

The version of X packaged with Slackware 11 does not like certain XkbLayout and XkbCompat directives in xorg.conf. I had the same problem of losing the ability to toggle among virtual screens. I wish somebody would explain why this happens.

uselpa 10-22-2006 03:30 PM

AFAIK it's not a Slackware packaging issue but rather a change due to Xorg 6.9. I have never found a complete documentation but there's a lot of posts you can find via Google, regarding Linux and BSDs.


All times are GMT -5. The time now is 02:18 PM.