LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   No spooler printing? (http://www.linuxquestions.org/questions/slackware-14/no-spooler-printing-4175466704/)

waddles 06-20-2013 03:54 AM

No spooler printing?
 
I have acquired an Epson XP-200 printer/scanner and have 2 questions thereto related.
1) I see from the Epson web site it has support for CUPS, LPD, LPRng, PPR, PDO, and no spooler. PPR & PDO are of no interest to me. CUPS apparently intercedes so that either LPD or LPRng can be used, I think.
How do I install my printer/scanner so that there is "no spooler". Here I presume that to mean that CUPS is not used and that somehow the file specified by Slackware's native LPRng simply prints the file directly. Is that correct and if not please explain "no spooler". Also, would CUPS be used with "no spooler"?
2) It was explained to me that Slackware's lack of LSB is related to its lack of an RPM package manager, but that one could use rpm2tgz to extract a package then use installpkg to install the software. Now that seems a whole lot simpler to do than futzing about with .tgz files and waltzing them about.
Epson has .rpm files and .tgz files. The latter are for NON-LSB distros. Now if my info is correct could I install the binaries (.rpm) via the rpm2tgz/installpkg route even though Slackware is NON-LSB and the .rpm file from Epson (designed for LSB distros) is of a different size (kind of expected) from the .tgz file and expect everything to work or just suffer thru the .tgz files they provide?

ljb643 06-20-2013 09:03 PM

I almost replied to your other message on your printer, but I have a different Epson printer (a wide-format photo, not an all-in-one). I do use the drivers from Epson with Slackware, so perhaps what I have to say will help.

Is there a reason not to use CUPS? I can't think of any. Even if it is just you and your PC and your printer, you should use it. CUPS is easy enough to set up and requires little maintenance.

ESC/P is the "legacy" Epson printer control language. ESC/P-R is the "new generation" Epson printer control language. If both drivers are listed for your printer, then your printer will support either, but probably with different features available.

In my case, I tried both drivers with my printer. In fact I have both installed now (with different printer names, which works fine with CUPS). While both seemed OK for Libreoffice, the ESC/P-R driver would not properly scale photos from Gimp. I did not extensively test it, as photo paper and ink cost too much to waste, and the ESC/P driver works well enough for me, so I use that one. In fact, for my printer, the ESC/P driver has more options.

Use the .tar.gz or .tgz packages if available - less work than RPM.

In order get the driver to work on my Slackware system, I had to make this symlink:
Code:

# ln -s  ld-linux.so.2 /lib/ld-lsb.so.3
In general this is a bad thing to do - you are 'tricking' programs into thinking your system is "LSB complaint" which it might not be, but the Epson package won't work without this link, and seems to work just fine with the link. This was true for the ESC/P driver; I'm not sure if I needed this for the ESC/P-R driver too but it doesn't hurt.

One last word: CUPS is a nasty thing to trouble-shoot. When it works, it works great, but when it doesn't work you may find yourself wading through tons of useless debug messages only to find "printer failed" with no reason. Good luck.

Hope all this helps.

waddles 06-21-2013 02:48 AM

Yes that helps and think Epson could be well advised to incorporate your difference between ESC/P vs ESC/P-R in its web site info.

One last thing I am still searching about is the "no spool" concept. Maybe someone can comment on how to do it. I would like to obviate use of CUPS.

A VERY BIG affirmation to your comment on trouble shooting CUPS.
I had finally gotten CUPS and an HP Deskjet 1000 to work after many months (me stubborn) but then for undetermined reason(s) it started to have "backend" problems which I could only correct by removing printers and rebuilding them.

Didier Spaier 06-21-2013 12:45 PM

I happen to get a "backend failed" message sometimes.
It happens for instance if I start a print job print before plugging in the USB cable of my my printer

Usually resuming the printer from the localhost:631 => printers menu solves that.

Anyway, as already did ljb643 I recommend to use CUPS. Consider that most people do that so they can help you. It would probably be more difficult to find help if need be going another way.

edorig 06-21-2013 01:21 PM

Quote:

Originally Posted by waddles (Post 4975211)
How do I install my printer/scanner so that there is "no spooler". Here I presume that to mean that CUPS is not used and that somehow the file specified by Slackware's native LPRng simply prints the file directly. Is that correct and if not please explain "no spooler". Also, would CUPS be used with "no spooler"?

No spooler simply means that you print your documents by typing
Quote:

cat file.txt > /dev/lp0
.
This sends the content of the file directly to the printer. There are multiple inconvenients in doing this.
  1. You may have to make /dev/lp0 world writable so that all users can print.
  2. You can only print ASCII files, you must apply some filter (gs) if you want to print PostScript files.
  3. You must wait for one job to complete before sending the next one
  4. The printer is unusable in a network
If you are the sole user of a single PC, this can be a workable solution. See https://wiki.linuxfoundation.org/en/...rDocumentation.
If you have more than one user or
if you want to share the printer in a local network you must use a spooler.

CUPS is presently the most used spooler, so it should be the default choice. If it is too complicated to use, you should try a BSD LPD program (LPRng) and write an /etc/printcap file.

ljb643 06-21-2013 07:55 PM

Quote:

No spooler simply means that you print your documents by typing ...
This sends the content of the file directly to the printer. There are multiple inconvenients in doing this.
...
I don't think the O.P. will get that Epson working without CUPS, and surely not with cat>/dev/lp0. The Epson driver includes a CUPS filter that converts from CUPS raster format to Epson language (ESC/P or ESC/P-R). You need this to print, and that filter program is dependent on CUPS.

Quote:

I happen to get a "backend failed" message sometimes.
It happens for instance if I start a print job print before plugging in the USB cable of my my printer
I have mine connected to a little network print-server, and print over the network, so I don't get this. But you might want to check the CUPS printer setting under Policies, Error Policy for the printer. I think the default is Stop Printer, and you might find one of the other settings less trouble.

Quote:

think Epson could be well advised to incorporate your difference between ESC/P vs ESC/P-R in its web site info.
That's where I got it from, although it is hard to find. http://global.epson.com/innovation/u...ing/index.html

waddles 06-22-2013 12:15 AM

The 4 conditions EDORIG laid out are exactly what I want. I wrote a cluggy shell script to print to the HP 1000, when it was only printing the first page of a multi-page document then over printing successive pages.
If CUPS gives me heartache again I will try to script something so that I can format ascii to postscript (where I have had some efforts).

FWIW the backend errors went away on the HP after I removed the CUPS printers then re-entered them (post the earlier problem I had with it). Had no USB cable probs here. After weeks of printing, had unanalyzable problems on 2 out of 3 of the printers, so I bought this new printer; had enough of HP.

I intend to re-install the CUPS package before I start installing the EPSON. Intend to take ljb643's advice regarding .tar file install. Thanks all of you

Didier Spaier 06-22-2013 02:51 AM

Quote:

Originally Posted by ljb643 (Post 4976347)
But you might want to check the CUPS printer setting under Policies, Error Policy for the printer. I think the default is Stop Printer, and you might find one of the other settings less trouble.

I'll try this, thanks.


All times are GMT -5. The time now is 01:26 PM.