LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-07-2006, 06:01 AM   #1
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
No sound with Ogg Vorbis or CDs in new Slack 11.0 installation


I've installed Slack 11.0 with the default 2.4.33.3 kernel. I ran alsamixer and unmuted everything. When I try to play an Ogg Vorbis file, there's no output at all. The same thing happens when I try to play an audio CD. I reinstalled the libvorbis, libogg and libtheora packages, just to see if it would help. Unfortunately, that did nothing. The only sound I can hear is console bleeping :/. I'm not getting any error messages - ogg123 plays the file and KsCD plays CDs, just there's no sound. Hmm, it doesn't seem limited to Ogg Vorbis or CDs - I'm having the same problem with WMAs (and probably MP3s as well, but I haven't got any to test).

In case it matters, here's the lspci for my sound device:

00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)

It's in a Toshiba Satellite Pro A10 laptop.

I didn't have any problems with 10.2 :/.

Any ideas?

Thanks .

Last edited by Nylex; 10-07-2006 at 07:28 AM.
 
Old 10-07-2006, 08:27 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
It seems to be OK if I turn off the "Headphone Jack Sense" item in AlsaMixer. I'm currently in runlevel 3 when I was in the shell, I ran AlsaMixer and disabled the aforementioned item.. sound then worked. I ran "alsactl store" just to be sure. When I ran startx, it seemed I had to run AlsaMixer and go through that whole process. Odd :/. At least I have sound now .
 
Old 10-07-2006, 11:24 AM   #3
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Hmm, on further inspection, it appears there is still a problem. If I reboot my machine, then I have to run AlsaMixer again and turn off the "Headphone Jack Sense" setting. Why isn't it permanent?
 
Old 10-07-2006, 11:57 AM   #4
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 472

Rep: Reputation: 87
I'd bet storing of alsa mixer settings is permanent (in /etc/asound.state) but probably is not restored at system startup by /etc/rc.d/rc.alsa because ALSA kernel modules are not yet loaded or they miss in /etc/modprobe.conf. Similar record like
Code:
alias snd-card-0 <your-sound-card-module-name>
may do the job. See rc.alsa startup script for more.
 
Old 10-07-2006, 12:19 PM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Thanks for the suggestion, dunric. I'll try that later on .
 
Old 10-07-2006, 01:03 PM   #6
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Also, to store alsa settings, issue "alsactl store" after changing them.
 
Old 10-07-2006, 01:05 PM   #7
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by XavierP
Also, to store alsa settings, issue "alsactl store" after changing them.
I know, I did that (see post #2) .
 
Old 10-07-2006, 01:11 PM   #8
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Quote:
Originally Posted by Nylex
I know, I did that (see post #2) .
Oops - missed that one
 
Old 10-07-2006, 02:34 PM   #9
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by dunric
Similar record like
Code:
alias snd-card-0 <your-sound-card-module-name>
may do the job. See rc.alsa startup script for more.
Unfortunately, this did nothing to help . I can't see anything useful in rc.alsa :/.

Edit: Yes, it looks like it's ok in /etc/asound.state:

Code:
control.26 {
              comment.access 'read write'
              comment.type BOOLEAN
              comment.count 1
              iface MIXER
              name 'Headphone Jack Sense'
              value false
}

Any other suggestions?

Last edited by Nylex; 10-07-2006 at 02:49 PM.
 
Old 10-07-2006, 03:22 PM   #10
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 472

Rep: Reputation: 87
Quote:
Originally Posted by Nylex
Unfortunately, this did nothing to help . I can't see anything useful in rc.alsa :/.
I'm sorry it didn't helped to you.
Concerning rc.alsa it parses modules configuration if Alsa modules are not yet loaded and loads them by sound-card pattern.
Code:
# If there are ALSA modules defined in /etc/modules.conf, but
  # ALSA is not yet loaded, then load the modules now:
  DRIVERS=`modprobe -c | grep -E "^[[:space:]]*alias[[:space:]]+snd-card-[[:digi
t:]]" | awk '{ print $3 }'`
  if [ ! "$DRIVERS" = "" ]; then
    echo "Loading ALSA kernel modules."
    for module in $DRIVERS; do
      modprobe $module
    done
  fi
Only after that is possible to set mixer settings.

I'd try to store settings by alsactl store then make some changes and call alsactl restore and check if it did restored previous values. If alsactl restore works I'd focus on timely module loading so it'll also work at system startup.

EDIT: Heh, I've now noticed you are using 2.4 kernel so alias for sound-card-0 should be placed in /etc/modules.conf instead.

Last edited by dunric; 10-07-2006 at 03:34 PM.
 
Old 10-08-2006, 12:23 AM   #11
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Running "alsactl restore" seems to work.

Also, the alias is already in /etc/modules.conf:

alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

I don't know what's changed between 10.2 and 11.0 to cause this (perhaps the kernel version itself?) :/.
 
Old 10-08-2006, 08:38 AM   #12
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Edit:

I did a kind of test. I decided to put the "/usr/sbin/alsactl restore" line before the "echo "Loading ALSA mixer settings:..."" line in the load_alsa_mixer() function. This worked fine if my default runlevel was 3, but when I changed it back to 4 I still have the problem. It seems to be X causing the problem, because if I do a "startx" from runlevel 3, then the problem comes back.

Edit: Maybe not X itself, but KDE. I don't know where to look though.

Grr.

Last edited by Nylex; 10-08-2006 at 09:19 AM.
 
Old 10-09-2006, 12:22 AM   #13
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Anyone? If I could get hints about where to look in X or KDE, that'd be great. I don't understand why X or KDE should cause this problem, though.
 
Old 10-09-2006, 12:47 AM   #14
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Try using KMix to set the volume settings, KDE stores it's own mixer settings by default.
 
Old 10-09-2006, 01:11 AM   #15
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
I wish I'd thought of that! Thank you, that did the trick . KMix seems to modify my /etc/asound.state, rather than just reading from it so turning off the headphone thing in there worked. Should I tell Pat about this, or it it just me that's having this problem?

Thanks again to everyone who tried to help (even XP ).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Opening Ogg Vorbis v. Ogg Theora in GNOME sdexp Linux - Newbie 1 08-26-2006 02:45 AM
Trying to install Ogg Vorbis Ian D Linux - General 1 08-30-2005 05:03 PM
Ripping Ogg Vorbis rezuke Linux - General 6 11-30-2003 02:59 PM
Ogg Vorbis anonE9 General 5 03-16-2003 10:23 AM
Ogg Vorbis figadiablo Slackware 4 10-15-2002 12:14 PM


All times are GMT -5. The time now is 03:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration