LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   no sound with HDA intel on ICH7 chip (AD198x) (http://www.linuxquestions.org/questions/slackware-14/no-sound-with-hda-intel-on-ich7-chip-ad198x-849908/)

nass 12-13-2010 06:25 AM

no sound with HDA intel on ICH7 chip (AD198x)
 
Hello everyone,
I seem to have problems with sound on a ICH7 chip. the motherboard is an ASUS P5LD2-SE

The kernel is custom, but SND_HDA_* is included. and generally the sound device is identified properly.

here is some relevant output of aplay -l and -L, lsmod and relevant part of lspci -vv

Quote:

root@halki:/temp/root/support# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
root@halki:/temp/root/support#
Quote:

root@halki:/temp/root/support# aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=Intel
HDA Intel, AD198x Analog
Default Audio Device
front:CARD=Intel,DEV=0
HDA Intel, AD198x Analog
Front speakers
surround40:CARD=Intel,DEV=0
HDA Intel, AD198x Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
HDA Intel, AD198x Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
HDA Intel, AD198x Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
HDA Intel, AD198x Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
HDA Intel, AD198x Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
HDA Intel, AD198x Digital
IEC958 (S/PDIF) Digital Audio Output
root@halki:/temp/root/support#
(what is this 'null' in the very beginning?)

Quote:

root@halki:/temp/root/support# lsmod
Module Size Used by
snd_seq_dummy 1542 0
snd_seq_oss 25215 0
snd_seq_midi_event 6489 1 snd_seq_oss
snd_seq 46482 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 6118 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 33128 0
snd_mixer_oss 13072 1 snd_pcm_oss
pcmcia 33219 0
nvidia 10208950 38
snd_hda_codec_analog 73623 1
snd_hda_intel 22658 2
snd_hda_codec 88538 2 snd_hda_codec_analog,snd_hda_intel
snd_hwdep 5904 1 snd_hda_codec
snd_pcm 73964 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer 18984 2 snd_seq,snd_pcm
snd 60705 15 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_analog,snd_hda_intel,snd_ hda_codec,snd_hwdep,snd_pcm,snd_timer
parport_pc 30773 0
soundcore 6785 1 snd
parport 33099 1 parport_pc
r8169 33230 0
ipg 14588 0
floppy 55609 0
snd_page_alloc 7636 2 snd_hda_intel,snd_pcm
Quote:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
Subsystem: ASUSTeK Computer Inc. Device 817f
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 16 bytes
Interrupt: pin A routed to IRQ 41
Region 0: Memory at ddcf8000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
Address: 00000000fee0300c Data: 4179
Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
ExtTag- RBE- FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
MaxPayload 128 bytes, MaxReadReq 128 bytes
DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
ClockPM- Surprise- LLActRep- BwNot-
LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
Capabilities: [100] Virtual Channel <?>
Capabilities: [130] Root Complex Link <?>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel
I read this relevant thread:
http://www.linuxquestions.org/questi...nvidia-849400/

but my GPU doesn't have an HDMI output (and no sound module either). Note that I did see a similar msg
Quote:

"No state is present for card NVidia
Unknown hardware: "HDA-Intel" "Nvidia GPU 0a HDMI/DP" "HDA:10de00a,10de0101,00100100" "0x19da" "0x6132"
Hardware is initialized using a guess method
No state is present for card NVidia"
to this one (of course it didn't include any nvidia references) but after running alsaconf, alsamixer, alsactl store once the msg vanished.:)

this thread didn't help either
http://www.linuxquestions.org/questi...t-work-848030/
as I'm running slackware64 13.1 on this pc and there are no newer alsa* package versions for me to install than the ones I already have.

Any clues where I can take it from here?
thank you for your help.

allend 12-13-2010 08:23 AM

Try creating a file /etc/modprobe.d/snd-hda-intel.conf containing this line
Quote:

options snd-hda-intel index=0 model=3stack position_fix=0 single_cmd=0
Googling "alsa asus p5ld2-se AD198x" showed these:
http://ubuntuforums.org/archive/index.php/t-370900.html
http://www.linuxquestions.org/questi...ubuntu-517120/

nass 12-13-2010 09:21 AM

nope no luck

I wonder if there is a buffer mismatch and the playback buffer ends up reading from a different location..
because I really dont have any error msg popping up anywhere. mpg321 will play an mp3 no problem. (as in play but I won't listen to it)
and,no, i haven't plugged the speakers at the wrong jack :)


All times are GMT -5. The time now is 02:41 PM.