LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-06-2010, 11:52 AM   #1
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
No sound with Frozen Bubble, but only for one user account...


Hi all,

I've got a strange problem: when I run Frozen Bubble from my user account, I get no sound, but the same game has sound with my wife's account and the root account.

Any suggestions on how I can troubleshoot this problem?

EDITED TO ADD: My user account has sound for DVDs through Kaffeine, Mplayer, etc. And the system sounds are working just find.

Regards,

Last edited by Lufbery; 02-06-2010 at 11:55 AM.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 02-06-2010, 12:30 PM   #2
Hangaber
Member
 
Registered: Sep 2004
Location: USA
Distribution: Slackware, Debian
Posts: 93

Rep: Reputation: 25
Check the groups belonging to yourself and your wife.
Code:
~$ groups yerwifesname
yerwifesname : users lp audio video cdrom plugdev power
Compare it with your groups.
If there's no difference, check the preferred audio device in kde (system settings, multimedia).

I assume if you've got frozen bubbles working, that means you installed those SDL packages. Did you use the builds from slackbuilds? Are you on slack 13 or 12.2, etc?

When I launch frozen-bubbles, the console reports;
Quote:
[SDL Init] [Graphics..........] [Sound Init] Ready.
Any errors with your console here?
 
Old 02-06-2010, 01:23 PM   #3
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Quote:
Originally Posted by Hangaber View Post
Check the groups belonging to yourself and your wife.
Code:
~$ groups yerwifesname
yerwifesname : users lp audio video cdrom plugdev power
Compare it with your groups.
Here's what I've got:

Code:
drew : users bin disk wheel man audio video cdrom games slocate ftp haldaemon plugdev power console

robin : users disk wheel man audio video cdrom games slocate haldaemon plugdev console

root : root bin daemon sys adm disk wheel floppy audio video cdrom tape plugdev
Quote:
If there's no difference, check the preferred audio device in kde (system settings, multimedia).
I'll look at that next.

Quote:
I assume if you've got frozen bubbles working, that means you installed those SDL packages. Did you use the builds from slackbuilds? Are you on slack 13 or 12.2, etc?
Oh yes, I used the build for Frozen Bubble and from Slackbuilds.org and

Quote:
Any errors with your console here?
Yeah, I get this:

Code:
[SDL Init] [Graphics..........] Ready.
Hmm.
 
Old 02-06-2010, 01:25 PM   #4
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Oh, for what it's worth, when I su to root and launch FB from a terminal, I get sound.
 
Old 02-06-2010, 01:38 PM   #5
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
I solved the problem by renaming the ~/.frozen-bubble/rc file to rc_safe, forcing FB to regenerate it.
 
2 members found this post helpful.
Old 09-15-2011, 05:44 PM   #6
toto2
LQ Newbie
 
Registered: Sep 2011
Posts: 1

Rep: Reputation: Disabled
sound can be toggled by pressing F12. try that first !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
frozen-bubble .... wdave58 Linux - Software 16 10-29-2008 03:10 AM
frozen bubble: sound problem ... SDL_mixer laurentwahl Linux - Games 2 11-06-2005 12:47 PM
frozen bubble acidjuice Slackware 7 03-02-2005 04:39 PM
Frozen Bubble Phorem Linux - Games 2 02-05-2004 01:30 PM
help getting frozen bubble sound to work/ perl people wr3ck3d Linux - Software 1 12-13-2003 08:59 PM


All times are GMT -5. The time now is 04:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration