LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-16-2010, 11:42 AM   #16
Jorek
Member
 
Registered: Sep 2005
Distribution: Slackware 13.1
Posts: 65

Rep: Reputation: 16

This .asoundrc did the trick! =)
Code:
pcm.dsp0 {
    type plug
    slave.pcm "dmix"
    # A hint is required for listing the device in some GUIs, e.g. Phonon configuration.
    hint {
         show on
         description "My dmix dsp0"
    }
}
# mixer0 can stay unchanged, because
# it isn't used anyway, I guess ;)
ctl.mixer0 {
    type hw
    card 0
}
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 10-29-2010, 03:42 AM   #17
bogzab
Member
 
Registered: Mar 2006
Location: Dyserth, Wales
Distribution: Slackware 13.37, Slackware 14.0
Posts: 260

Rep: Reputation: 31
Wink

Just to add another success story. I had the same problem as OP - both flash plugin and the "play" command failed to produce any sound whereas all other apps (media players, other non-flash streams) seemed to work fine.

In my case this was not caused by an new multimedia card, but upgrades to firefox or the flash plugin - not sure which caused the problem, but almost certainly one of these.

Creating the ~/.asoundrc as suggested by EternalNewbie fixed the problems.
 
Old 03-20-2011, 03:02 AM   #18
sgrayban
Member
 
Registered: Nov 2004
Location: Spokane, WA
Distribution: Debian 6.0
Posts: 369

Rep: Reputation: 30
If you aren't going to use the HDMI output on the Nvidia GT 210 video card the fix is very easy... at least it is for debian but this should work for any distro.

In debian edit /etc/modprobe.d/alsa-base-blacklist.conf and add this line..

blacklist snd_hda_intel

If you don't have the above file you should have /etc/modprobe.d/blacklist.conf and add the same line from above.
 
Old 05-03-2011, 03:09 AM   #19
sevs
Member
 
Registered: Jul 2008
Location: Ukraine, Kharkov
Distribution: debian, knoppix, mandriva, asplinux, altlinux
Posts: 108

Rep: Reputation: 19
Hi. I've got the same problem.
Editing of ~/.asoundrc gives me nothing.
But after 'lsof | grep /dev/snd' I have following output:
Quote:
mixer_app 2442 sergy 21u CHR 116,7 0t0 3529 /dev/snd/controlC0
mixer_app 2442 sergy 24u CHR 116,7 0t0 3529 /dev/snd/controlC0
pulseaudi 2443 sergy mem CHR 116,4 3524 /dev/snd/pcmC0D0p
pulseaudi 2443 sergy 20u CHR 116,7 0t0 3529 /dev/snd/controlC0
pulseaudi 2443 sergy 21u CHR 116,4 0t0 3524 /dev/snd/pcmC0D0p
pulseaudi 2443 sergy 22u CHR 116,7 0t0 3529 /dev/snd/controlC0
pulseaudi 2443 sergy 29u CHR 116,7 0t0 3529 /dev/snd/controlC0
As I can see pulseadio makes the problem.
But I've did an experiment: 'cat /vmlinuz > /dev/dsp'
And the output is:
Quote:
Device or resource busy
while 'lsof | grep /dev/dsp' gives an empty output.

Maybe there is a way to tell applications to use pulseaudio instead of alsa, or some solution?

UPD: OS is Debian Squeeze 6.0.1a.

Thanks in advance.
Sorry for bad English.
 
Old 05-03-2011, 07:49 PM   #20
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,251

Rep: Reputation: 630Reputation: 630Reputation: 630Reputation: 630Reputation: 630Reputation: 630
Quote:
Originally Posted by sevs View Post
Hi. I've got the same problem.
Editing of ~/.asoundrc gives me nothing.
But after 'lsof | grep /dev/snd' I have following output:


As I can see pulseadio makes the problem.
But I've did an experiment: 'cat /vmlinuz > /dev/dsp'
And the output is:
while 'lsof | grep /dev/dsp' gives an empty output.

Maybe there is a way to tell applications to use pulseaudio instead of alsa, or some solution?

UPD: OS is Debian Squeeze 6.0.1a.

Thanks in advance.
Sorry for bad English.
It should be noted that this is the Slackware forum, and that Slackware does not, by default, ship with pulseaudio. However, you may try the following in your ~/.asoundrc:
Code:
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
 
1 members found this post helpful.
Old 08-04-2011, 11:19 AM   #21
pinterd
LQ Newbie
 
Registered: Aug 2011
Posts: 2

Rep: Reputation: Disabled
What lead me to this forum is the error message:
Quote:
ALSA lib pcm_dmix.c:1018snd_pcm_dmix_open) unable to open slave
The fact that this was made at any occurrence the sound card had to be reached, there was no sound at all, that is, until i forced alsa to restart with:
Quote:
# alsa force-reload
I've tried everything from purging alsa to adding ~/.asoundrc with different parameters until finally found what was causing trouble.
What i did is i went through the installed pkg-list and looked at the description and i found that roaraudio made changes to my settings. So after purging it, alsa was reborn.

Thought i'd share it here in case somebody's still having problem after reading all above. I found pretty good clues here on where to look and figured what measures to take.

Thanks everyone!
 
1 members found this post helpful.
Old 08-31-2011, 09:17 PM   #22
caduqued
Member
 
Registered: Apr 2008
Location: Coventry, United Kingdom
Distribution: Slackware64, Slackware64 13.37, linuxslackware
Posts: 81

Rep: Reputation: 19
Just to say thanks

Got same problem.

used solution with asoundrc

everything again back to normal...

You guys rock... hehehe
 
Old 11-26-2012, 05:30 AM   #23
asenov_18@abv.bg
LQ Newbie
 
Registered: Nov 2012
Posts: 1

Rep: Reputation: Disabled
Provide fix that works for me

Thanks for proposed fixes.
I'm running OpenSUSE 12.2 x64 and I've tried many configurations inside .asoundrc file, but only one works for me. Inside .asoundrc:
Code:
pcm.pulse {
type pulse
}

ctl.pulse {
type pulse
}

pcm.!default {
type pulse
}

ctl.!default {
type pulse
}
Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Flash Player gets multi-touch, graphics acceleration LXer Syndicated Linux News 0 11-18-2009 08:11 PM
What happened to Flash Player 9 sound after installing a video capture card? davegutz Linux - Desktop 5 02-09-2007 05:14 PM
Flash Player, Firefox: sound in blackbox but not KDE DaneM Slackware 11 11-21-2006 01:41 PM
Please help (can't get sound working with flash player and firefox in Mandriva 2006!) LaptopLinux Mandriva 1 12-07-2005 12:58 AM
poor sound in FLASH player 7 with Firefox 1.5 polemon Linux - Software 0 12-04-2005 05:42 AM


All times are GMT -5. The time now is 03:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration