LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-20-2013, 11:35 PM   #1
Lilgamesh
Member
 
Registered: Mar 2013
Posts: 33

Rep: Reputation: Disabled
No sound - The Audio device intel HDA ... did not work falling back to default.


The following warning shows up in notification and no sound from speakers or headphone.

The Audio device intel HDA ... did not work falling back to default.

lspci -k shows snd_hda_intel has been loaded.

Code:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
	Subsystem: Lenovo ThinkPad T61
	Kernel driver in use: snd_hda_intel
Please help.
 
Old 03-21-2013, 12:46 AM   #2
Lilgamesh
Member
 
Registered: Mar 2013
Posts: 33

Original Poster
Rep: Reputation: Disabled
Never mind. Problem solved.

added configuration file in modprob.d

sill did not work

added user to audio group (I think it is not required). Bu its is not working without? Any ideas. May be I am wrong.
 
Old 03-21-2013, 02:22 AM   #3
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Hello,
Quote:
Originally Posted by Lilgamesh View Post
Never mind. Problem solved.

added configuration file in modprob.d

sill did not work

added user to audio group (I think it is not required). Bu its is not working without? Any ideas. May be I am wrong.
As far as I know a user should be in the audio-group by default if you've created the user with useradd (which is a Slackware-tool) instead of adduser (which is the default Unix-tool).

You could also try to change the udev-rule for the device.

Markus
 
2 members found this post helpful.
Old 03-21-2013, 03:51 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,408

Rep: Reputation: 834Reputation: 834Reputation: 834Reputation: 834Reputation: 834Reputation: 834Reputation: 834
Seeing this http://wiki.blue-it.org/Thinkpad_T61#Sound
'options snd-hda-intel model=thinkpad'
would be worth a try.
 
1 members found this post helpful.
Old 03-21-2013, 12:25 PM   #5
Lilgamesh
Member
 
Registered: Mar 2013
Posts: 33

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by markush View Post
Hello,

As far as I know a user should be in the audio-group by default if you've created the user with useradd (which is a Slackware-tool) instead of adduser (which is the default Unix-tool).

You could also try to change the udev-rule for the device.

Markus
I do not remember what I used when I created. Thanks a lot

---------- Post added 03-21-13 at 01:26 PM ----------

Quote:
Originally Posted by allend View Post
Seeing this http://wiki.blue-it.org/Thinkpad_T61#Sound
'options snd-hda-intel model=thinkpad'
would be worth a try.
will try. thanks a lot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No audio, falling back to default. Slackware14 erik2282 Slackware 4 02-20-2013 09:30 PM
Confused audio channel output on hda-intel based device netsurf Linux - Hardware 1 10-18-2010 06:09 AM
integrated hda audio modem bluetooth , (intel hda audio does not work) reggae linux Linux - Laptop and Netbook 1 07-05-2006 10:13 PM
integrated hda audio modem bluetooth , (intel hda audio does not work) reggae linux Linux - Laptop and Netbook 2 07-05-2006 03:38 PM


All times are GMT -5. The time now is 08:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration