LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-08-2009, 02:03 PM   #1
WetFroggy
Member
 
Registered: Jul 2008
Posts: 49

Rep: Reputation: 0
Question NO Sound : Slackware64 13.0; Alsa 1.0.18; Audigy 2 (SB0240); NO X-server


Version changes and sound, seems to be my bane. I have had similar issues with every slackware version since 3.0 (oddly enough, the sound card has been the only component that has not changed since then). Upgrade (or clean install) renders sound not there. The card exists, the system sees it, the drivers supposedly are correct, alsamixer even with all playback on @ 100% - nothing. Not until I fiddle with sound for several hours, does it magically start working, and I never figure out HOW I got it to actually work.

No users (root or otherwise) hear sound.

I've hit my wits end, this is a stock install from the dvd, no extras. use alsaconf, select the card choice, it creates in

/etc/modprobe.d/sound

Code:
alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-emu10k1
What I used to use, (in 12.2) was :

Code:
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-emu10k1

# module options should go here
#	Creative Card wo/Digital out + LiveDrive	[0x3fc3/0x1fc3]
options snd-emu10k1 id="first" extin="0x3fc3" extout="0x1fc3"

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-emu10k1

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
This issue I am sure, has nothing to do with an x-server, as when its not even running, "aplay /usr/share/sounds/k3b_success1.wav" does something, I just can't hear it.

cat /proc/asound/cards

Code:
 0 [Audigy2        ]: Audigy2 - SB Audigy 2 [SB0240]
                      SB Audigy 2 [SB0240] (rev.4, serial:0x10071102) at 0xec00,
lspci -v

Code:
01:09.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
	Subsystem: Creative Labs SB0240 Audigy 2 Platinum 6.1
	Flags: bus master, medium devsel, latency 32, IRQ 17
	I/O ports at ec00 [size=64]
	Capabilities: [dc] Power Management version 2
	Kernel driver in use: EMU10K1_Audigy
	Kernel modules: snd-emu10k1
cat /proc/asound/devices
Code:
0: [ 0]   : control
  1:        : sequencer
  4: [ 0- 0]: hardware dependent
  8: [ 0- 0]: raw midi
  9: [ 0- 1]: raw midi
 16: [ 0- 0]: digital audio playback
 18: [ 0- 2]: digital audio playback
 19: [ 0- 3]: digital audio playback
 20: [ 0- 4]: digital audio playback
 24: [ 0- 0]: digital audio capture
 25: [ 0- 1]: digital audio capture
 26: [ 0- 2]: digital audio capture
 28: [ 0- 4]: digital audio capture
 33:        : timer
cat /proc/asound/pcm
Code:
00-00: emu10k1 : ADC Capture/Standard PCM Playback : playback 32 : capture 1
00-01: emu10k1 mic : Mic Capture : capture 1
00-02: emu10k1 efx : Multichannel Capture/PT Playback : playback 8 : capture 1
00-03: emu10k1 : Multichannel Playback : playback 1
00-04: p16v : p16v : playback 1 : capture 1
New note :
Sound was functioning in 12.2 (eventually, had to use the longer "/etc/modprobe.d/sound" file above, to stop a crosstalk issue - I don't really understand why either), previously it had been mixer problems (who knew, muted sound...), or permissions for the user. Currently, though, its even root that isn't able to hear sound, and root seems to be automatically part of the correct group.

Last edited by WetFroggy; 09-09-2009 at 07:15 AM. Reason: Added required peices of information
 
Old 09-08-2009, 06:26 PM   #2
WetFroggy
Member
 
Registered: Jul 2008
Posts: 49

Original Poster
Rep: Reputation: 0
I'll clean install slackware32 13.0, tomorrow, and see if the problem goes away, if it does, it might narrow down things a touch.
 
Old 09-08-2009, 06:48 PM   #3
agentdcooper
Member
 
Registered: Aug 2005
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
how are yr speakers hooked up? the audigy 2's have multiple options for cable connections....

I have an audigy 2 ZS platnium pro, I can tell you what I am using, and maybe this'll help you? not only does mine come with the PCI card that looks nearly identical to yours (google found this) - I have an external breakout box with several connectors... from my PCI card, there is a soundblaster proprietary cable that connects => external breakout box -> then from the "SPDIF out" coax port on the back of the external breakout box => via SPDIF coax => "SPDIF in" coax port on the back of my external sony STR-DE597 stereo.

I also have multiple analog cables that have 2x RCA connectors on one end, and a single head-phone connector on the other plugged into each port on the back of the SoundBlaster Audigy 2 ZS PCI card itself, into the analog ports themselves. I could output sound via analog if I cared too, but I mainly use this option as backup... my primary audio output is the SPDIF port.

I don't know if this is how you have yrs connected? anyway... I installed slackware13.0 x86_64 from scratch (I have used slackware since version 12.0.0 with this very same audigy 2 ZS p.p. card, and it has been simple to use, so far), I only had to change VERY little to get things working ;;

I left ALL configfiles alone (oh, you need to put yr user into the audio group in /etc/group), didn't touch a thing! in the past I have used a /etc/modprobe.d/sound file like you, but I do not have such a file on slackware64 13.0.

in KDE 4.2 -> start -> computer -> system settings -> multimedia, all device preferences under audio output are set as follows ::
  1. SB Audigy 2 ZS [SB0360] (rev.4, serial:0x20011102)(p16v)
  2. SB Audigy 2 ZS [SB0360] (rev.4, serial:0x20011102)(Multichannel Capture/PT Playback)
  3. SB Audigy 2 ZS [SB0360] ADC Capture/Standard PCM Playback (IEC958 (S/PDIF) Digital Audio Output)
  4. SB Audigy 2 ZS [SB0360] (rev.4, serial:0x20011102)(ADC Capture/Standard PCM Playback)
  5. all the others....

all I have to do to get sound in firefox, I just MUTE the IEC958 Optical Raw Item in alsamixer! ha, that seriously makes sound work (I've found this to be similar with backtrack 4.x and other distros too)...

here's what everything else on my side looks like ::

Code:
# cat /proc/asound/cards
0 [Audigy2        ]: Audigy2 - SB Audigy 2 ZS [SB0360]
                      SB Audigy 2 ZS [SB0360] (rev.4, serial:0x20011102) at 0x9f00, irq 17
Code:
# lspci -v
09:07.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
        Subsystem: Creative Labs Device 2001                         
        Flags: bus master, medium devsel, latency 32, IRQ 17         
        I/O ports at 9f00 [size=64]                                  
        Capabilities: [dc] Power Management version 2                
        Kernel driver in use: EMU10K1_Audigy                         
        Kernel modules: snd-emu10k1
Code:
# cat /proc/asound/devices
  0: [ 0]   : control
  1:        : sequencer
  4: [ 0- 0]: hardware dependent
  8: [ 0- 0]: raw midi
  9: [ 0- 1]: raw midi
 16: [ 0- 0]: digital audio playback
 18: [ 0- 2]: digital audio playback
 19: [ 0- 3]: digital audio playback
 20: [ 0- 4]: digital audio playback
 24: [ 0- 0]: digital audio capture
 25: [ 0- 1]: digital audio capture
 26: [ 0- 2]: digital audio capture
 28: [ 0- 4]: digital audio capture
 33:        : timer
Code:
> cat /proc/asound/pcm
00-00: emu10k1 : ADC Capture/Standard PCM Playback : playback 32 : capture 1
00-01: emu10k1 mic : Mic Capture : capture 1
00-02: emu10k1 efx : Multichannel Capture/PT Playback : playback 8 : capture 1
00-03: emu10k1 : Multichannel Playback : playback 1
00-04: p16v : p16v : playback 1 : capture 1
mplayer works perfect, any movie recorded in 5.1+ channel audio (dolby digital) work flawlessly (mplayer command lines) ::
Code:
mplayer -vo xv -ao alsa:device=spdif movie.avi
mplayer -vo xv -ao alsa:device=spdif -ac hwac3 -alang en dvd://1   [DVDs]
mplayer -ao alsa:device=spdif -ac hwac3 -srate 48000 somemovie.avi
mplayer -vo xv -ao alsa:device=spdif -ac hwac3 cd1.bin
my fav GUI video player = smplayer, so I have it's Audio preferences set as follows -- so anytime I goto play capable videos my reciever's Dolby Digital blue banner lights up. if the video doesn't support dolby digital, it sends the signal out still via SPDIF, and my reciever plays it on all 6.1 channels ::
  • output driver: User defined... alsa:device=spdif
  • AC3/DTS pass-through S/PDIF (enabled)
  • channels by default: 6 (5.1 surround)
  • high speed playback without altering pitch: Auto
  • change volume on every file: (enabled)
  • change volume just before playing: Auto
  • default volume: 40
  • EVERYTHING else is set DISABLED in the Audio preferences tab

best of luck!

Last edited by agentdcooper; 09-08-2009 at 07:17 PM. Reason: add user to audio group + mplayer & smplayer info
 
Old 09-09-2009, 07:27 AM   #4
WetFroggy
Member
 
Registered: Jul 2008
Posts: 49

Original Poster
Rep: Reputation: 0
Speakers are using the ... corresponding color coded jacks (red, pink, green) and mic jack. As far as physical connections, nothing has changed since 12.2.

A thought did occur to me this morning, though, could it be my audio card is actually too old to operate with a 64bit OS? I'm not a hardware person so I can't answer that except via trail/error - which will occur shortly as I test with a clean install of slackware32.

All new pieces of information have been edited to original post.
 
Old 09-09-2009, 09:00 AM   #5
WetFroggy
Member
 
Registered: Jul 2008
Posts: 49

Original Poster
Rep: Reputation: 0
Unhappy Test : Same as above, with slackware32 13.0

Similar results, no sound.

Similar, with the following exception,
During boot, as the message spam goes by, at this point :

Code:
kernel: EMU10K1_Audigy 0000:01:09.0: PCI INT A -> Link[APC2] -> GSI 17 (level, low) -> IRQ 17
kernel: Installing spdif_bug patch: SB Audigy 2 [SB0240]
The speakers click to life, hum, then a few moments later, when "/etc/rc.d/rc.alsa" is called, they click off, and go silent.

I use alsamixer, initially, but this is the only way to display the settings in text, AFAIK.
amixer :
Code:
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined cvolume cswitch cswitch-joined
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 31
  Mono: Playback 70 [70%] [-12.00dB]
  Front Left: Capture 23 [74%] [-12.00dB] [on]
  Front Right: Capture 23 [74%] [-12.00dB] [on]
Simple mixer control 'Tone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'Bass',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 40
  Front Left: 20 [50%]
  Front Right: 20 [50%]
Simple mixer control 'Treble',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 40
  Front Left: 20 [50%]
  Front Right: 20 [50%]
Simple mixer control '3D Control Sigmatel - Depth',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Capture channels: Mono
  Limits: 0 - 3
  Mono: 0 [0%]
Simple mixer control 'PCM',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 100
  Front Left: Capture 100 [100%] [0.00dB]
  Front Right: Capture 100 [100%] [0.00dB]
Simple mixer control 'PCM Center',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 100 [100%] [0.00dB]
Simple mixer control 'PCM Front',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Mono:
  Front Left: Playback 100 [100%] [0.00dB]
  Front Right: Playback 100 [100%] [0.00dB]
Simple mixer control 'PCM LFE',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 100 [100%] [0.00dB]
Simple mixer control 'PCM Side',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Mono:
  Front Left: Playback 100 [100%] [0.00dB]
  Front Right: Playback 100 [100%] [0.00dB]
Simple mixer control 'PCM Surround',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Mono:
  Front Left: Playback 100 [100%] [0.00dB]
  Front Right: Playback 100 [100%] [0.00dB]
Simple mixer control 'Front',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Mono:
  Front Left: Playback 70 [70%] [-12.00dB]
  Front Right: Playback 70 [70%] [-12.00dB]
Simple mixer control 'Surround',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Mono:
  Front Left: Playback 0 [0%] [-99999.99dB]
  Front Right: Playback 0 [0%] [-99999.99dB]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 0 [0%] [-99999.99dB]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 0 [0%] [-99999.99dB]
Simple mixer control 'Side',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Mono:
  Front Left: Playback 0 [0%] [-99999.99dB]
  Front Right: Playback 0 [0%] [-99999.99dB]
Simple mixer control 'Synth',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 100 [100%] [0.00dB] Capture 0 [0%] [-99999.99dB]
  Front Right: Playback 100 [100%] [0.00dB] Capture 0 [0%] [-99999.99dB]
Simple mixer control 'Wave',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Mono:
  Front Left: Playback 100 [100%] [0.00dB]
  Front Right: Playback 100 [100%] [0.00dB]
Simple mixer control 'Line',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 0 [0%] [-34.50dB] [off]
  Front Right: Capture 0 [0%] [-34.50dB] [off]
Simple mixer control 'CD',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 0 [0%] [-34.50dB] [off]
  Front Right: Capture 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 31
  Mono: Capture 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Mic Select',0
  Capabilities: enum
  Items: 'Mic1' 'Mic2'
  Item0: 'Mic1'
Simple mixer control 'Video',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 0 [0%] [-34.50dB] [off]
  Front Right: Capture 0 [0%] [-34.50dB] [off]
Simple mixer control 'Phone',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 31
  Mono: Capture 0 [0%] [-34.50dB] [off]
Simple mixer control 'IEC958 Optical',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] [-99999.99dB] Capture 0 [0%] [-99999.99dB]
  Front Right: Playback 0 [0%] [-99999.99dB] Capture 0 [0%] [-99999.99dB]
Simple mixer control 'IEC958 Optical Raw',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [off]
  Front Right: Playback [off]
Simple mixer control 'PC Speaker',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 15
  Mono: Capture 0 [0%] [-45.00dB] [off]
Simple mixer control 'Aux',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 0 [0%] [-34.50dB] [off]
  Front Right: Capture 0 [0%] [-34.50dB] [off]
Simple mixer control 'Aux2',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] [-99999.99dB] Capture 0 [0%] [-99999.99dB]
  Front Right: Playback 0 [0%] [-99999.99dB] Capture 0 [0%] [-99999.99dB]
Simple mixer control 'Mono Output Select',0
  Capabilities: enum
  Items: 'Mix' 'Mic'
  Item0: 'Mix'
Simple mixer control 'AMic',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Mono:
  Front Left: Playback 0 [0%] [-99999.99dB]
  Front Right: Playback 0 [0%] [-99999.99dB]
Simple mixer control 'Analog Capture Boost',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Analog Mix',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] [-99999.99dB] Capture 72 [72%] [-11.20dB]
  Front Right: Playback 0 [0%] [-99999.99dB] Capture 72 [72%] [-11.20dB]
Simple mixer control 'Audigy Analog/Digital Output Jack',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Audigy CD',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] [-99999.99dB] Capture 0 [0%] [-99999.99dB]
  Front Right: Playback 0 [0%] [-99999.99dB] Capture 0 [0%] [-99999.99dB]
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'HD Analog Center/LFE',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 207 [81%] [0.00dB]
  Front Right: Playback 207 [81%] [0.00dB]
Simple mixer control 'HD Analog Front',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 207 [81%] [0.00dB]
  Front Right: Playback 207 [81%] [0.00dB]
Simple mixer control 'HD Analog Rear',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 207 [81%] [0.00dB]
  Front Right: Playback 207 [81%] [0.00dB]
Simple mixer control 'HD Analog Side',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 207 [81%] [0.00dB]
  Front Right: Playback 207 [81%] [0.00dB]
Simple mixer control 'HD SPDIF Center/LFE',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 207 [81%] [0.00dB]
  Front Right: Playback 207 [81%] [0.00dB]
Simple mixer control 'HD SPDIF Front',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 207 [81%] [0.00dB]
  Front Right: Playback 207 [81%] [0.00dB]
Simple mixer control 'HD SPDIF Rear',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 207 [81%] [0.00dB]
  Front Right: Playback 207 [81%] [0.00dB]
Simple mixer control 'HD SPDIF Side',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 207 [81%] [0.00dB]
  Front Right: Playback 207 [81%] [0.00dB]
Simple mixer control 'HD channel Capture',0
  Capabilities: enum
  Items: '0' '1' '2' '3'
  Item0: '0'
Simple mixer control 'HD source Capture',0
  Capabilities: enum
  Items: 'SPDIF' 'I2S' 'SRC48' 'SRCMulti_SPDIF' 'SRCMulti_I2S' 'CDIF' 'FX' 'AC97'
  Item0: 'SPDIF'
Simple mixer control 'Sigmatel 4-Speaker Stereo',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Sigmatel Surround Phase Inversion Playback ',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Where have I messed up?

I'll fall back to 12.2 next, and see if it'll work.
 
Old 09-09-2009, 11:12 AM   #6
WetFroggy
Member
 
Registered: Jul 2008
Posts: 49

Original Poster
Rep: Reputation: 0
Lightbulb

With 12.2, it works again (not flawlessly).

Command line test :
Code:
aplay -Dhw:0,0 /boot/vmlinuz
I imagine this is my fault, the flawed attempt seems to be when I tried with kde. Sound wasn't there, was lucky in that root had the old .kde folder backed up. First, tried with the folder kde4 used - no sound. Second, deleted the '.kde' that the was in use with kde4 so the system recreated - no sound. Third, used the backed up folder from root (adjusted permissions as needed) - sound returned!

The backed up .kde folder did the trick (question, what file within ~/.kde actually controls sound?)

Further test, created an unwashed user for the system to test with, the system's ~./kde folder seems flawed, until I copied, renamed & applied permissions to the backedup root's '.kde' folder there were other errors with what the system wanted to initially use (again, probably my fault).

Tested with xfce, sound functioning normally.

Tested with no x-server, sound functioning normally.

(Using the 12.2 '/etc/modprobe.d/sound' custom file noted in original post).

Now then, I'll move back to a clean install of slackware64, see if it works again.

Last edited by WetFroggy; 09-09-2009 at 11:17 AM. Reason: paragraph coherency
 
Old 09-09-2009, 12:10 PM   #7
WetFroggy
Member
 
Registered: Jul 2008
Posts: 49

Original Poster
Rep: Reputation: 0
Unhappy Confused

And now, back on slackware64, 13.0, sound has decided to function again!

I don't understand this. Why does linux's sound system hate me?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
alsa+audigy ls=no sound verbose Linux - Hardware 6 09-13-2006 07:03 PM
Audigy 2 [SB0240] / Alsa 1.0.10 / No Sound drr104 Linux - Hardware 1 02-16-2006 02:53 PM
SuSE 10: No sound with SB Audigy 2 ZS and ALSA pschoenb Linux - Hardware 4 11-09-2005 05:55 PM
sb audigy 2 ge no sound b4 or after alsa-conf gonus Linux - Hardware 0 01-22-2005 08:55 PM
Suse9.1/ALSA/Audigy/No Sound/I run alsaconf after reboot(s) to get sound FastFeet Linux - Hardware 23 07-12-2004 05:01 PM


All times are GMT -5. The time now is 11:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration