LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-10-2014, 07:27 PM   #1
max!
LQ Newbie
 
Registered: Mar 2014
Posts: 5

Rep: Reputation: Disabled
No sound in slackware 14.1


I recently installed slackware 14.1 and I cannot get audio to work. I have gone into mixer and turned everything on (also how do I default volumes to 100% on load?) but the closest I come to sound is static on my speakers when I raise Line Boost and Mic Boost. alsactl init returns
----------------------
Found hardware: "HDA Intel" "Intel Haswell HDMI" "HDA:80862807,80860101,00100000" "0x1462" "0x7816"
Hardware is initialized using a generic method
---------------------

I am thinking it may be as simple as changing the default audio output to rear aux instead of hdmi, but I am not sure how to do that.

Any help would be greatly appreciated, as it sucks to have to restart my computer and boot into windows just to listen to music.
 
Old 03-10-2014, 08:18 PM   #2
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,494

Rep: Reputation: 437Reputation: 437Reputation: 437Reputation: 437Reputation: 437
What is the output of (as root)
Code:
lspci
and (as any user)
Code:
aplay -L
?
 
Old 03-10-2014, 08:36 PM   #3
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0
Posts: 3,201
Blog Entries: 15

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
You probably need to create an asound.conf file in /etc, and possibly an .asoundrc profile for your user accounts.

/etc/asound.conf should look something like:

Code:
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
And the .asoundrc profile in your user account folder(s) should look like:

Code:
pcm.hda-intel {
   type hw
   card 0
}

ctl.hda-intel {
   type hw
   card 0
}
 
Old 03-11-2014, 02:09 AM   #4
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 381

Rep: Reputation: 30
Quote:
Originally Posted by ReaperX7 View Post
And the .asoundrc profile in your user account folder(s) should look like:

Code:
pcm.hda-intel {
   type hw
   card 0
}

ctl.hda-intel {
   type hw
   card 0
}
after that step, when i struggle with my sound issueas, i cannot run alsamixer anymore.....
as so, i think, better way is not make that .asoundrc, and instead of that make default via asound.conf like that:


alias sound-slot-0 snd-card-emu10k1
options snd slots=snd-card-emu10k1,snd-usb-audio


( it is for soundblaster live!. you must use your own sound modules name)


http://www.linuxquestions.org/questi...ce-4175497387/
 
Old 03-11-2014, 02:57 AM   #5
max!
LQ Newbie
 
Registered: Mar 2014
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Richard Cranium View Post
What is the output of (as root)
Code:
lspci
and (as any user)
Code:
aplay -L
?
00:00.0 Host bridge: Intel Corporation Haswell DRAM Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Haswell HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation Lynx Point USB xHCI Host Controller (rev 05)
00:16.0 Communication controller: Intel Corporation Lynx Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Lynx Point USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation Lynx Point High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation Lynx Point PCI Express Root Port #1 (rev d5)
00:1c.1 PCI bridge: Intel Corporation Lynx Point PCI Express Root Port #2 (rev d5)
00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d5)
00:1d.0 USB controller: Intel Corporation Lynx Point USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Lynx Point LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation Lynx Point 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation Lynx Point SMBus Controller (rev 05)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
03:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 04)
 
Old 03-17-2014, 06:15 PM   #6
max!
LQ Newbie
 
Registered: Mar 2014
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ReaperX7 View Post
You probably need to create an asound.conf file in /etc, and possibly an .asoundrc profile for your user accounts.

/etc/asound.conf should look something like:

Code:
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
And the .asoundrc profile in your user account folder(s) should look like:

Code:
pcm.hda-intel {
   type hw
   card 0
}

ctl.hda-intel {
   type hw
   card 0
}
I did that and sound is still not working, although when I click "Test" in the kde sound options I hear the test audio.
 
Old 03-17-2014, 08:29 PM   #7
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0
Posts: 3,201
Blog Entries: 15

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
By any chance do your video chip have HDMI capabilities?
 
Old 03-18-2014, 06:05 AM   #8
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,557
Blog Entries: 3

Rep: Reputation: 216Reputation: 216Reputation: 216
may want to check this thread it sounds like what your going through. http://www.linuxquestions.org/questi...ce-4175497387/
 
Old 03-18-2014, 12:47 PM   #9
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 692

Rep: Reputation: 296Reputation: 296Reputation: 296
The Linux sound server situation is still not great but at least has been an easy, workable solution for a few years now. That is until every new video card started shipping with HDMI and furthermore, HDMI as default (whose bright idea was that!??). By far the most common problem in sound these days is that. If you find you have HDMI (aplay -l or lsmod reveal it) and are not actually using it fulltime or at all, you must blacklist it or at the very least change it from default to secondary or tertiary.
 
Old 03-18-2014, 09:25 PM   #10
max!
LQ Newbie
 
Registered: Mar 2014
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ReaperX7 View Post
By any chance do your video chip have HDMI capabilities?
It does. Its just the onboard video on the i5 haswell if that makes a difference.
 
Old 03-18-2014, 09:39 PM   #11
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0
Posts: 3,201
Blog Entries: 15

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Actually it makes a huge difference. Because you have two chipsets that use the Intel HDA audio, trying to define which exact chipset is going to load first, may take some trial and error.

The real question is how to segregate two chipsets using the same driver:

00:1b.0 Audio device: Intel Corporation Lynx Point High Definition Audio Controller (rev 05)

00:03.0 Audio device: Intel Corporation Haswell HD Audio Controller (rev 06)

In fact, you might actually be sending audio out currently through the HDMI without knowing it. More research into how you can set up asound.conf will be required now unfortunately.

Can you please post your aplay -l output please so I can get a better idea of what to show you?

Last edited by ReaperX7; 03-18-2014 at 09:46 PM.
 
Old 03-19-2014, 03:14 AM   #12
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,557
Blog Entries: 3

Rep: Reputation: 216Reputation: 216Reputation: 216
Quote:
That is until every new video card started shipping with HDMI and furthermore, HDMI as default (whose bright idea was that!??).
bios does that. that is the info sent to the kernel. that is why Pat has put snd-hda-intel in the beginners guide. Second we have to remember linux kernel just trys to read the bios or cmos not run it. so the first device on the pci bus get's loaded first. This used to be handle by alsaconfig but that is no longer.
alsa trys to do it all from the boot.

to me it is a alsa problem. just go in tell alsa what device is default. like the old days with alsaconfig. oh alsa took that out mmm.

Last edited by Drakeo; 03-19-2014 at 03:17 AM.
 
Old 03-19-2014, 11:48 AM   #13
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0
Posts: 3,201
Blog Entries: 15

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
This is why .asoundrc is important to have as it sets the default device for audio.
 
Old 03-19-2014, 01:38 PM   #14
max!
LQ Newbie
 
Registered: Mar 2014
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ReaperX7 View Post
Actually it makes a huge difference. Because you have two chipsets that use the Intel HDA audio, trying to define which exact chipset is going to load first, may take some trial and error.

The real question is how to segregate two chipsets using the same driver:

00:1b.0 Audio device: Intel Corporation Lynx Point High Definition Audio Controller (rev 05)

00:03.0 Audio device: Intel Corporation Haswell HD Audio Controller (rev 06)

In fact, you might actually be sending audio out currently through the HDMI without knowing it. More research into how you can set up asound.conf will be required now unfortunately.

Can you please post your aplay -l output please so I can get a better idea of what to show you?
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card detected but not able to hear sound in Slackware 13.1 64 bit shravank87 Slackware - Installation 4 11-17-2010 03:39 PM
Sound problems in Slackware 11 with Sweex sound card RicardoB Linux - Hardware 0 04-30-2007 01:34 PM
Sound Skips After Slackware 11.0 upgrade AC97 sound card using the snd-via82xx driver meetscott Linux - Hardware 3 11-07-2006 11:55 PM
Replaced a Sound Card (ESS) and now no sound under Slackware LeniuNYC Linux - Hardware 1 03-14-2004 05:21 PM


All times are GMT -5. The time now is 05:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration