LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   No sound in slackware 14.1 (http://www.linuxquestions.org/questions/slackware-14/no-sound-in-slackware-14-1-a-4175497740/)

max! 03-10-2014 07:27 PM

No sound in slackware 14.1
 
I recently installed slackware 14.1 and I cannot get audio to work. I have gone into mixer and turned everything on (also how do I default volumes to 100% on load?) but the closest I come to sound is static on my speakers when I raise Line Boost and Mic Boost. alsactl init returns
----------------------
Found hardware: "HDA Intel" "Intel Haswell HDMI" "HDA:80862807,80860101,00100000" "0x1462" "0x7816"
Hardware is initialized using a generic method
---------------------

I am thinking it may be as simple as changing the default audio output to rear aux instead of hdmi, but I am not sure how to do that.

Any help would be greatly appreciated, as it sucks to have to restart my computer and boot into windows just to listen to music.

Richard Cranium 03-10-2014 08:18 PM

What is the output of (as root)
Code:

lspci
and (as any user)
Code:

aplay -L
?

ReaperX7 03-10-2014 08:36 PM

You probably need to create an asound.conf file in /etc, and possibly an .asoundrc profile for your user accounts.

/etc/asound.conf should look something like:

Code:

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

And the .asoundrc profile in your user account folder(s) should look like:

Code:

pcm.hda-intel {
  type hw
  card 0
}

ctl.hda-intel {
  type hw
  card 0
}


WiseDraco 03-11-2014 02:09 AM

Quote:

Originally Posted by ReaperX7 (Post 5132352)
And the .asoundrc profile in your user account folder(s) should look like:

Code:

pcm.hda-intel {
  type hw
  card 0
}

ctl.hda-intel {
  type hw
  card 0
}


after that step, when i struggle with my sound issueas, i cannot run alsamixer anymore.....
as so, i think, better way is not make that .asoundrc, and instead of that make default via asound.conf like that:


alias sound-slot-0 snd-card-emu10k1
options snd slots=snd-card-emu10k1,snd-usb-audio


( it is for soundblaster live!. you must use your own sound modules name)


http://www.linuxquestions.org/questi...ce-4175497387/

max! 03-11-2014 02:57 AM

Quote:

Originally Posted by Richard Cranium (Post 5132337)
What is the output of (as root)
Code:

lspci
and (as any user)
Code:

aplay -L
?

00:00.0 Host bridge: Intel Corporation Haswell DRAM Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Haswell HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation Lynx Point USB xHCI Host Controller (rev 05)
00:16.0 Communication controller: Intel Corporation Lynx Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Lynx Point USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation Lynx Point High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation Lynx Point PCI Express Root Port #1 (rev d5)
00:1c.1 PCI bridge: Intel Corporation Lynx Point PCI Express Root Port #2 (rev d5)
00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d5)
00:1d.0 USB controller: Intel Corporation Lynx Point USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Lynx Point LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation Lynx Point 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation Lynx Point SMBus Controller (rev 05)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
03:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 04)

max! 03-17-2014 06:15 PM

Quote:

Originally Posted by ReaperX7 (Post 5132352)
You probably need to create an asound.conf file in /etc, and possibly an .asoundrc profile for your user accounts.

/etc/asound.conf should look something like:

Code:

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

And the .asoundrc profile in your user account folder(s) should look like:

Code:

pcm.hda-intel {
  type hw
  card 0
}

ctl.hda-intel {
  type hw
  card 0
}


I did that and sound is still not working, although when I click "Test" in the kde sound options I hear the test audio.

ReaperX7 03-17-2014 08:29 PM

By any chance do your video chip have HDMI capabilities?

Drakeo 03-18-2014 06:05 AM

may want to check this thread it sounds like what your going through. http://www.linuxquestions.org/questi...ce-4175497387/

enorbet 03-18-2014 12:47 PM

The Linux sound server situation is still not great but at least has been an easy, workable solution for a few years now. That is until every new video card started shipping with HDMI and furthermore, HDMI as default (whose bright idea was that!??). By far the most common problem in sound these days is that. If you find you have HDMI (aplay -l or lsmod reveal it) and are not actually using it fulltime or at all, you must blacklist it or at the very least change it from default to secondary or tertiary.

max! 03-18-2014 09:25 PM

Quote:

Originally Posted by ReaperX7 (Post 5136428)
By any chance do your video chip have HDMI capabilities?

It does. Its just the onboard video on the i5 haswell if that makes a difference.

ReaperX7 03-18-2014 09:39 PM

Actually it makes a huge difference. Because you have two chipsets that use the Intel HDA audio, trying to define which exact chipset is going to load first, may take some trial and error.

The real question is how to segregate two chipsets using the same driver:

00:1b.0 Audio device: Intel Corporation Lynx Point High Definition Audio Controller (rev 05)

00:03.0 Audio device: Intel Corporation Haswell HD Audio Controller (rev 06)

In fact, you might actually be sending audio out currently through the HDMI without knowing it. More research into how you can set up asound.conf will be required now unfortunately.

Can you please post your aplay -l output please so I can get a better idea of what to show you?

Drakeo 03-19-2014 03:14 AM

Quote:

That is until every new video card started shipping with HDMI and furthermore, HDMI as default (whose bright idea was that!??).
bios does that. that is the info sent to the kernel. that is why Pat has put snd-hda-intel in the beginners guide. Second we have to remember linux kernel just trys to read the bios or cmos not run it. so the first device on the pci bus get's loaded first. This used to be handle by alsaconfig but that is no longer.
alsa trys to do it all from the boot.

to me it is a alsa problem. just go in tell alsa what device is default. like the old days with alsaconfig. oh alsa took that out mmm.

ReaperX7 03-19-2014 11:48 AM

This is why .asoundrc is important to have as it sets the default device for audio.

max! 03-19-2014 01:38 PM

Quote:

Originally Posted by ReaperX7 (Post 5137115)
Actually it makes a huge difference. Because you have two chipsets that use the Intel HDA audio, trying to define which exact chipset is going to load first, may take some trial and error.

The real question is how to segregate two chipsets using the same driver:

00:1b.0 Audio device: Intel Corporation Lynx Point High Definition Audio Controller (rev 05)

00:03.0 Audio device: Intel Corporation Haswell HD Audio Controller (rev 06)

In fact, you might actually be sending audio out currently through the HDMI without knowing it. More research into how you can set up asound.conf will be required now unfortunately.

Can you please post your aplay -l output please so I can get a better idea of what to show you?

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0


All times are GMT -5. The time now is 09:23 PM.