LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-22-2007, 03:32 AM   #1
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
No sound in Pidgin when running it from an icon


I've installed Pidgin 2.0.0 from the provided Slackware package (actually, I had to rebuild said package to include GStreamer support. Other than that, it's identical to the one Pat built). I had to install GStreamer 0.10 and plugins from source as there's no Slackware packages for these. If I set the environment variable GST_PLUGIN_PATH and then run Pidgin from a terminal, everything's great and sound works. However, if I run Pidgin from an icon, the sound doesn't work; the debug window says "sound: Unable to create GStreamer audiosink..". I don't know if this is a problem with how I've built Pidgin, or GStreamer or what :/.

Ideas on a postcard please .

Last edited by Nylex; 05-22-2007 at 11:42 AM.
 
Old 05-22-2007, 03:44 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
I've just built Pidgin from source under Debian and sound works when using an icon. Debian has GStremer's prefix as /usr though, so maybe I should do the same under Slack. Thoughts?
 
Old 05-22-2007, 12:33 PM   #3
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Nope, setting --prefix=/usr for GStreamer makes it worse. If I do so and set GST_PLUGIN_PATH as before, I get the same error message from Pidgin as above.
 
Old 05-22-2007, 02:36 PM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Moved to the Slackware forum as requested.
 
Old 05-22-2007, 02:51 PM   #5
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Try setting the GST_PLUGIN_PATH in your ~/.bash_profile, logout and back in again then try starting Pidgin using the icon.
 
Old 05-22-2007, 02:53 PM   #6
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
It's not a solution really, but you could just create a script to start pidgin with required environment variable. Sorry, can't help more.
 
Old 05-22-2007, 03:56 PM   #7
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Thanks for the suggestions, both of you. I reinstalled GStreamer and plugins with their default prefix (/usr/local), with the intention of trying reddazz's suggestion first. Strangely, Pidgin is now working fine (i.e. the sounds work when I use my panel icon), even without setting GST_PLUGIN_PATH anywhere. I'm not going to complain .

Thanks again .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pidgin --> Unsupported willysr Slackware 62 06-14-2007 11:37 PM
Pidgin 2.0.0 rigelan Slackware 7 05-07-2007 08:03 PM
Gaim is Now Known as Pidgin XavierP Linux - News 1 04-09-2007 07:32 AM
running limewire from fluxbox menu or desktop icon tuneout Linux - Software 2 08-15-2005 08:58 AM
Running wine from desktop icon Roy-Svork Linux - Software 5 06-22-2003 06:37 PM


All times are GMT -5. The time now is 01:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration