LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   No sound in new installed Slackware 14 (http://www.linuxquestions.org/questions/slackware-14/no-sound-in-new-installed-slackware-14-a-4175470008/)

fppegr 07-18-2013 12:16 AM

No sound in new installed Slackware 14
 
KDE shows:
Code:

The audio playback device HDA Intel (ALC883 Analog) does not work.
Falling back to default

I did a little google, and followed a post to change the backend from phonon-gstreamer to phonon-mplayer. Then, if I open Konsole and type 'mplayer some.mp3', sound comes. But, if I launch Amarok or Kplayer or something else, there is no sound.

What maybe is the problem, and how can I fix it?

Thanks

ReaperX7 07-18-2013 01:06 AM

You may wish to download this script:

http://slackware.com/~alien/tools/alsaconf

...make it executable with chmod +x, and then try running it in a terminal to see if it can automatically detect and setup ALSA for your sound card.

If this doesn't work there are other ways to get your audio working.

STDOUBT 07-18-2013 01:47 AM

fppegr,
Happy first post, and welcome!

I don't have Amarok or Kplayer, but you should be able to go into their Preferences (someplace) and change the output plugin to either ALSA or OSS. OSS should work out of the box, and in fact, you're probably seeing "AO: [oss]" when you run mplayer in a terminal.

yars 07-18-2013 04:08 AM

I think you should be a member of 'audio' group. To check it:
Code:

$ id
If it's not so, add to group:
Code:

# usermod -a -G audio your_user

gabrielmagno 07-18-2013 09:26 AM

If you can't make it work with gstreamer or mplayer backends, you can try phonon-vlc.

Get SlackBuild scripts or pre-compiled packages by Alien Bob from here:
http://www.slackware.com/~alien/slackbuilds/phonon-vlc/

Of course you would also have to have VLC installed:
http://www.slackware.com/~alien/slackbuilds/vlc/


All times are GMT -5. The time now is 11:32 AM.