LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   no sound in headphones in hda intel integrated soundcard (http://www.linuxquestions.org/questions/slackware-14/no-sound-in-headphones-in-hda-intel-integrated-soundcard-4175446440/)

WiseDraco 01-20-2013 05:00 AM

no sound in headphones in hda intel integrated soundcard
 
Hello!
Want to share my finding - a times ago i used linux mandriva, and saund in "headphones" front case connector is it - all works. but some time later i installed slackware 13.1, and after that - slack 14.0, and have an absolute silence in headphones. other line out to creative computer speakers work in all cases, but sound on headphones audio out is gone.
In sound mixer ( kmix) is "headphone" bar, it is "enabled" and slider in various position, but no sound in headphones at all.
Today i try to discover again in that direction, and found a
make file /etc/modprobe.d/alsa-base.conf

and in that file put:

options snd-hda-intel model=auto

save it, and restart. and voila - we have sound in headphones!
very happy with that. but at time i writing this i want to check, it is also sound in my speakers -and found it was gone :D i have sound only in headphones. but i discover, need a open kmix -> mixer -> settings -> configure channels and add with mouse drop "speaker" channel. after that can see a "speaker" bar with slider in kmix and sound to external speakers also be have - all work ok.
maybe this can help anyone.

slackware 14.0 x32, intel dg965ss motherboard with HDA intel sound (as in specs Audio: 6-channel (5.1) audio subsystem using SigmaTel STAC9227 audio codec)
lspci:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
dmesg:

snd_hda_intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[ 6.084433] snd_hda_intel 0000:00:1b.0: irq 47 for MSI/MSI-X
[ 6.084457] snd_hda_intel 0000:00:1b.0: setting latency timer to 64
[ 6.262723] e1000e: Intel(R) PRO/1000 Network Driver - 1.5.1-k
[ 6.262799] e1000e: Copyright(c) 1999 - 2011 Intel Corporation.
[ 6.268199] input: HDA Intel Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input5
[ 6.268376] input: HDA Intel Line-out as /devices/pci0000:00/0000:00:1b.0/sound/card0/input6
[ 6.268541] input: HDA Intel Line-out as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
[ 6.268701] input: HDA Intel Line-out as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8
[ 6.268864] input: HDA Intel Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9

goossen 01-20-2013 06:05 AM

Thanks for sharing! Those HDA Intel sound cards are always tricky!

allend 01-20-2013 06:15 AM

I found this, (the link is a translation of a Japanese page). http://translate.google.com.au/trans...ed=0CFwQ7gEwBQ

As I read it, the page author had success getting headphones to work with
Code:

options snd-hda-intel model=ref-no-jd
in /etc//modprobe.d/alsa-base.conf

Quote:

Thanks for sharing! Those HDA Intel sound cards are always tricky!
This may help. http://docs.slackware.com/howtos:har..._snd-hda-intel

allend 01-20-2013 07:21 AM

@WiseDraco - I am wondering whether if you have 'options snd-hda-intel model=auto' and then
Quote:

you delete your /var/lib/alsa/asound.state (and then possibly reconfigure the ALSA defaults as you like them and use "alsactl store" to create a new asound.state)
http://www.linuxquestions.org/questi...5/#post4289480
then the reconfiguration of kmix would be avoided.

WiseDraco 01-20-2013 09:15 AM

Quote:

Originally Posted by allend (Post 4874017)
@WiseDraco - I am wondering whether if you have 'options snd-hda-intel model=auto' and then
http://www.linuxquestions.org/questi...5/#post4289480
then the reconfiguration of kmix would be avoided.

absolutely dont understad, about what you speaking.
look at /var/lib/alsa/asound.state - that file show last modify time as 12 october 2012.
/modprobe.d/alsa-base.conf also is untouched from my last edit, as so i not see a point...

allend 01-20-2013 05:21 PM

The point is that the file /var/lib/alsa/asound.state contains the information that is used to define the sound inputs and outputs. I would like you to try deleting and remaking that file, to see if all your sound functionality is then properly recognised. Your setup and the fix would make a useful addition to the SlackDocs page, so I would like to be sure of providing correct advice.

WiseDraco 01-21-2013 02:34 AM

Quote:

Originally Posted by allend (Post 4874282)
The point is that the file /var/lib/alsa/asound.state contains the information that is used to define the sound inputs and outputs. I would like you to try deleting and remaking that file, to see if all your sound functionality is then properly recognised. Your setup and the fix would make a useful addition to the SlackDocs page, so I would like to be sure of providing correct advice.


Ok. try to do this when today go home from work. i must move /var/lib/alsa/asound.state to another folder, and then restart computer, login to X and see what happens, i understand correctly?

allend 01-21-2013 10:08 AM

I must apologise for this,
Quote:

then the reconfiguration of kmix would be avoided.
as upon rereading, it is confusing. kmix can be configured to show your choice of controls.

What I would like to know is whether it is better to use
Code:

options snd-hda-intel model=auto
or
Code:

options snd-hda-intel model=ref-no-jd
with your hardware to get the headphones to work.

To do this:
Boot the computer with one of those lines in /etc/modprobe.d/alsa-base.conf.
As root, move /var/lib/alsa/asound.state to another folder.
Run 'alsactl store' to generate a new /var/lib/alsa/asound.state file. Optionally, you can run 'alsamixer' before this to select your choice of custom settings.
Check that your sound works (headphones and speakers).

Then repeat using the alternative line in /etc/modprobe.d/alsa-base.conf.

If you see no difference between the two, then I would stick with 'model=auto', which is the default for the snd-hda-intel kernel module. This would be another example of a hardware setup that required that option to be explicitly supplied in order to gain functionality.

WiseDraco 01-21-2013 11:22 AM

Ok, i do that. in "model=auto" mode all works, except "headphones" slider - it not changes anything, as so as mute it not mute sound in headphones.
"speaker" slider mute \ unmute a speakers and change speakers volume. no slider who mute or change hedphones only, can be change hedphones volume via general "master" and "pcm" sliders...


in "mode=ref-ni-jd" kmix "mixer" dialog looks different - it do not have "headphone" position at all. Sound level for "speakers" and "headphones" channels tune via "front" ( change volume or mute speakers) and "surround" sliders ( headphone channel).

also after i try "ref-ni-jd" option, i again delete asound state, change in conf to "auto", and do alsactl store - and see, a newly produce asound.state is larger than my first at "auto" created - 8xxx buytes vs 5xxx. then i restart computer, and before login to X do again alsactl store from root. in that time size is about 5xxx.
when i booting X, i got message

"KDE detected that one or more internal devices were removed.
Do you want KDE to permanently forget about these devices?
This is the list of devices KDE thinks can be removed:
Capture: HDA Intel (STAC92xx Digital)
Output: HDA Intel (STAC92xx Digital)
Output: HDA Intel, STAC92xx Digital (IEC958 (S/PDIF) Digital Audio Output)"

in another sides both settings ( auto & ref-ni-jd) gives similar result.

allend 01-21-2013 05:58 PM

Thankyou very much for your testing.
Which option do you recommend?

Also, please post the output of 'sbin/lspci | grep Audio'.

WiseDraco 01-22-2013 11:46 AM

/sbin/lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

you 're welcome.

I did not seriously test both option one against other, but i prefer =auto, because i use it first, and speakers volume slider correspond right function. But on general, i do not found seriously differences between that two, compare with default slackware setup ( without alsa-base.conf), when i not hear sound in "speakers" out connector...;)

WiseDraco 02-06-2013 04:42 AM

2allend: cannot find, why i can send you a message in this forum, as so, i write there:

approx week ago i bought a sb live! 5.1 ( sb0060) sound card ( recall of my GUS PnP and beautiful midi sounds not let me sleep :D ), and figure out, why i can get it work in slackware 14 x32, especially wavetable synthesis. now, looks like, i get it worked, as so, while i remember all it, i can write small howto - get emu10k card work undert slackware 14.
as i understand from that topic, you make a such that howtos for slack distro?
do you can help me with this?
thank you.

allend 02-06-2013 09:33 AM

As you may have seen, I used the information you supplied to make an amendment to the SlackDocs page for snd-hda-intel. Thankyou for your contribution. It is greatly appreciated!
If you want to make a contribution to SlackDocs by providing a HowTo for your device, then I am all in favour of that.
It seems that English is not your first language, so perhaps it would be better to write your HowTo in your first language, then seek help in having this translated to English by sending an email to the SlackDocs mailing list (see here for further details http://docs.slackware.com/slackdocs:translation_guide). I would be very happy to review any translation, but could not supply any technical detail as I am not familiar with your device.

WiseDraco 02-06-2013 09:57 AM

Always welcome :)
I registered in slaxdocs page, but
Sorry, you don't have enough rights to continue. Perhaps you forgot to login?
when i try start new document start howtos multimedia howto_set_up_sound_blaster_live_5.1

Yes, english is my third language, and i bad in it, but try learning a bit every year, and every time when i wrote in. Without doubt, i can write primarily in latvian or russian, but online translations is very terrible ( i know that, because i used it lot sometimes, and in most cases is easier try to understand original, in not known language, than "translation",really . i think, in my writing is far easier get a point, than translated one ( via translate google and similar services). also i think, i can write small howto in english, if i have noble person (c) R.Aldridge , who review it and make a small correct of this, or point to me at wrong words or unintelligible phrases....
really there is only one question - in that manner someone want a that howto, or not? because, from other side, i not ready spend for that large ammount of time, and money ( if be want a professional translation to english)...?

---------- Post added 02-06-13 at 04:57 PM ----------

Always welcome :)
I registered in slaxdocs page, but
Sorry, you don't have enough rights to continue. Perhaps you forgot to login?
when i try start new document start howtos multimedia howto_set_up_sound_blaster_live_5.1

Yes, english is my third language, and i bad in it, but try learning a bit every year, and every time when i wrote in. Without doubt, i can write primarily in latvian or russian, but online translations is very terrible ( i know that, because i used it lot sometimes, and in most cases is easier try to understand original, in not known language, than "translation",really . i think, in my writing is far easier get a point, than translated one ( via translate google and similar services). also i think, i can write small howto in english, if i have noble person (c) R.Aldridge , who review it and make a small correct of this, or point to me at wrong words or unintelligible phrases....
really there is only one question - in that manner someone want a that howto, or not? because, from other side, i not ready spend for that large ammount of time, and money ( if be want a professional translation to english)...?


All times are GMT -5. The time now is 06:18 PM.