LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-26-2007, 02:04 PM   #1
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
No sound for newly added user...


Hi all,

I hope this is a quick question. I set up a new user account on my Slackware 11 box for my wife. Everything worked fine except that there's no sound when logged into her account and running KDE.

I'm pretty sure I added her to the sound group.

Do I need to run alsamixer for that account?

Any tips on trouble shooting are appreciated.

Thanks,

-Drew
 
Old 06-26-2007, 02:17 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,057
Blog Entries: 1

Rep: Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373
Quote:
Originally Posted by Lufbery
Hi all,

I hope this is a quick question. I set up a new user account on my Slackware 11 box for my wife. Everything worked fine except that there's no sound when logged into her account and running KDE.

I'm pretty sure I added her to the sound group.

Do I need to run alsamixer for that account?

Any tips on trouble shooting are appreciated.

Thanks,

-Drew
Hi,

Did you run 'alsamixer' as root then 'aslactl store'?

What about mixer in the user KDE?
 
Old 06-26-2007, 07:07 PM   #3
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
The group you need is "audio", not sure if this is what you meant or not.
1) Make sure sound works as root. If not run alsaconf.
2) Make sure the user has group "audio"
3) Make sure the sound is not turned down/muted
4) Some sound cards have a digital output switch in the mixer make sure it is set correctly.
 
Old 06-26-2007, 07:26 PM   #4
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Hi guys,

Yes, I meant "audio" for the group. And no, nothing is muted, but that's a good thing to check.

Strangely, I have sound only as my unprivileged user. It doesn't work as root as either. I suspect that I ran alsaconf as me instead of as root (or I did it through su).

I'll try running alsoconf as root and see if that helps.

I'll check back in here with some results soon.

Thanks again,

-Drew
 
Old 06-26-2007, 11:32 PM   #5
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Rep: Reputation: 30
i think there is permissions in /dev/sound too..

mine is like this:
Code:
$ ls -l /dev/sound/
total 0
crw-rw--w- 1 root audio 14, 12 2007-06-26 19:33 adsp
crw-rw--w- 1 root audio 14,  4 2007-06-26 19:33 audio
crw-rw--w- 1 root audio 14,  3 2007-06-26 19:33 dsp
crw-rw--w- 1 root audio 14,  0 2007-06-26 19:33 mixer
crw-rw--w- 1 root audio 14,  1 2007-06-26 19:33 sequencer
crw-rw--w- 1 root audio 14,  8 2007-06-26 19:33 sequencer2
 
Old 06-28-2007, 10:15 PM   #6
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Okay... I don't have a dev/sound/ directory. Hmm

The error I get when I try to test the sound through KDE's sound settings (that shows up in the console) is:

"fifo_audio_out: audio buffer underflow"

This only happens for the root account and my wife's account -- not for my unprivileged user account.

Thanks for any help you can give.

EDIT: A little more research shows that other people are having this problem, and it is related to KDE. I don't know much more beyond that right now.

Regards,

-Drew

Last edited by Lufbery; 06-29-2007 at 08:59 AM.
 
Old 07-02-2007, 01:45 PM   #7
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Rep: Reputation: 30
is it maybe a kernel / udev problem then?

I dunno, do you see anything from 'lsmod | grep snd' ?

What kernel are you using?
 
Old 07-02-2007, 01:51 PM   #8
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Thanks for getting back to me. I've not made any headway on this problem because I was too busy enjoying the nice weather in Pennsylvania this weekend.

I'll post back with the lsmod | grep snd results this evening.

In the meantime, I'm using the default 2.4 Slackware 11 Kernel.

I'm also investigating the tips in this post over at the Human readable blog:

http://humanreadable.nfshost.com/journal/2006-003.htm

Quote:
Eventually I discovered two troubling files: kmixrc and kmixctrlrc. I discovered those two files by modifying the profile and then using the KFind tool to report all files modified in the past one minute. Those two files were listed and I began investigating. On a hunch I deleted the files from my testing user profile and then started KDE with that user account. No sound problems. Those two files were a contributing culprit to all or some of my sound troubles.
So I'm going to check for those two files and see what happens. I'll post my results.
 
Old 07-06-2007, 10:17 PM   #9
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Quote:
Originally Posted by bioe007
I dunno, do you see anything from 'lsmod | grep snd' ?
Here's what I get:

Code:
lsmod | grep snd
snd-seq-oss            23104   0 (unused)
snd-seq-midi-event      3208   0 [snd-seq-oss]
snd-seq                33552   2 [snd-seq-oss snd-seq-midi-event]
snd-seq-device          3716   0 [snd-seq-oss snd-seq]
snd-pcm-oss            28928   0
snd-mixer-oss          11928   0 [snd-pcm-oss]
snd-intel8x0           19188   1
snd-ac97-codec         68160   0 [snd-intel8x0]
snd-pcm                52804   0 [snd-pcm-oss snd-intel8x0 snd-ac97-codec]
snd-timer              13168   0 [snd-seq snd-pcm]
snd                    34304   1 [snd-seq-oss snd-seq-midi-event snd-seq snd-seq-device snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer]
soundcore               3300   6 [snd]
snd-page-alloc          4980   0 [snd-seq-oss snd-seq snd-seq-device snd-mixer-oss snd-intel8x0 snd-pcm snd-timer snd]
Regards,

-Drew

P.S. Getting rid of the the two kmix* files mentioned above did not seem to help (I renamed them instead of deleting them).
 
Old 07-07-2007, 08:51 PM   #10
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Quote:
Originally Posted by onebuck
Hi,
Did you run 'alsamixer' as root then 'aslactl store'?
After all my poking around this did turn out to be the problem. I had muted something with the alsamixer that shouldn't have been. I didn't see it until I looked again today

Thanks for the replies, folks. The problem is solved.

Regards,

-Drew
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how can i mount newly added H.D using SuSe 9.0 elbrens Linux - Software 3 08-14-2007 01:51 PM
Bash: keeping track of newly added files madtinkerer Programming 5 09-13-2006 09:30 AM
X and Firefox don't recognize newly added fonts tom221 Linux - General 2 03-08-2005 04:19 PM
cant send email (using sendmail) to newly added domain user sirjosi Linux - Newbie 0 10-22-2003 01:12 AM
newly added harddrive not showing.... pdmackenzie Linux - Hardware 4 03-02-2003 05:18 PM


All times are GMT -5. The time now is 12:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration