LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-29-2006, 09:02 AM   #1
shame
Member
 
Registered: Apr 2006
Location: England
Distribution: Debian Sidux - openSUSE
Posts: 261

Rep: Reputation: 30
No sound devices found


I cannot get any sound on slackware.
I have all the sound stuff I need as modules in the kernel but when I try to modprobe or load them through rc.modules I get FATAL: Module xx not found. And alsaconf doesn't detect the soundcard.
I don't know if it's related but before started trying to get sound working I installed Freerock Gnome and during the install it asked if I wanted to install udev, which I said yes but it then said it couldn't find the udev package.
I downloaded udev from the freerock website and installed and replaced rc.udev with rc.udev new.
Since it seems to be a problem loading the modules I'm guessing the udev thing isn't related but thought I'd check.

Slackware 10.2 (All packages, other than what freerock installed).
Kernel 2.6.13
 
Old 04-29-2006, 10:19 AM   #2
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
I don't know if the module failing to load is a problem with udev or not, but udev is responsible for listing device files for the hardware thats on your computer. You might want to try the Slackware udev package instead, but I don't think it makes a difference. As far as the module goes, I had a similar problem on my computer. I had all of the sound compiled in my kernel as modules except for the core "sound support" which I had hard coded. Switching this to module was able to solve the problem for me. If you still have problems, please list the output of 'lsmod'

regards,
...drkstr
 
Old 04-29-2006, 10:36 AM   #3
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
Did you install the alsa modules from /testing when you installed the kernel?

You need the alsa modules from /testing if you are using the 2.6 kernel from testing, as the modules you currently have are for kernel 2.4.

EDIT: Also, if this is a kernel you built yourself, post the .config file.
 
Old 04-29-2006, 10:47 AM   #4
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Yes, I forgot to mention that. Good call liquidtenmilion.

regards,
...drkstr
 
Old 04-29-2006, 06:26 PM   #5
shame
Member
 
Registered: Apr 2006
Location: England
Distribution: Debian Sidux - openSUSE
Posts: 261

Original Poster
Rep: Reputation: 30
Many thanks. The only alsa related package I could find in /testing was alsa-driver so I assume that's what you meant. I installed it and ran alsaconf and it found my soundcard ok.
However I still can't get sound working properly.
I've run alsamixer and unmuted everything and sorted out the levels but after doing alsactl store, there is still no sound.
If I right-click on gnome volume control and change the levels then I can play mp3's etc when the window is open but once closed the master level resets to 0.
I've tried chmod 666 on the sound devices and I've also tried adding them to the audio group, along with my user but still no go.
I'm thinking it may still be a permissions problem since I can get sound working with the volume control window open so modules are ok.

<EDIT>
Sound is working ok in kde so it seems it's a gnome problem, or freerock problem specifically.
<EDIT #2>
MP3's etc are are playing in gnome now and so are some app sounds, such as flash in firefox and opera and thunderbird notifications.
The problem seems to with the gnome sound system itself and the volume control settings are still resetting and the volume applet is muted(only in gnome).

Last edited by shame; 04-29-2006 at 06:59 PM.
 
Old 04-29-2006, 08:23 PM   #6
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
It is probably an ESD problem.

Your card does not support hardware mixing, and ESD is blocking the soundcard(And i do not know about freerock gnome, but i think it may supply an esound compiled for OSS support, which will block your soundcard). You can just turn off ESD in Desktop ==> Preferences ==> Sound (give or take, workign from memory) and uncheck both options.

Also, you must be root to run alsactl store, as it saves it to /etc.
 
Old 04-30-2006, 10:54 AM   #7
shame
Member
 
Registered: Apr 2006
Location: England
Distribution: Debian Sidux - openSUSE
Posts: 261

Original Poster
Rep: Reputation: 30
The alsamixer is keeping it's settings and alsactl store is working now. The problem is now only with the gnome mixer and gnome sounds.

Unchecking the options in Preferences>Sound will stop gnome sounds from working altogether right? Which is how things are now.
All sounds are working except for gnome sound events and gnome apps.
I've tried changing the multimedia systems selector to different things and that doesn't make any difference but I'm assuming that is to do with sound in gerneral, not gnome sounds so I dunno what to try next.
I've used gnome on many distros and had no problems with sounds so it's not a sound card problem either.
I did try vector linux some time last year, also with freerock gnome and I never got gnome sounds working on that either if I remember rightly.
 
Old 04-30-2006, 10:55 AM   #8
shame
Member
 
Registered: Apr 2006
Location: England
Distribution: Debian Sidux - openSUSE
Posts: 261

Original Poster
Rep: Reputation: 30
alsamixer is keeping it's settings and alsactl store is working now. The problem is now only with the gnome mixer and gnome sounds.

Unchecking the options in Preferences>Sound will stop gnome sounds from working altogether right? Which is how things are now.
All sounds are working except for gnome sound events and gnome apps.
I've tried changing the multimedia systems selector to different things and that doesn't make any difference but I'm assuming that is to do with sound in gerneral, not gnome sounds so I dunno what to try next.
I've used gnome on many distros and had no problems with sounds so it's not a sound card problem either.
I did try vector linux some time last year, also with freerock gnome and I never got gnome sounds working on that either if I remember rightly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound: No volume control elements and/or devices found edo1017 Linux - Hardware 2 02-18-2006 04:57 PM
Mandrake Move 9.2, no devices found??? silentwhispers Mandriva 1 09-04-2004 03:11 AM
(EE) No devices found barron123 Linux - Newbie 4 03-26-2004 04:04 PM
no valid devices were found on which to create new filesystem mehdi Linux - Software 5 02-18-2004 06:48 AM
no valid devices were found..... joeslazenger Linux - Software 3 08-22-2003 10:44 AM


All times are GMT -5. The time now is 11:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration