LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-23-2010, 01:36 AM   #1
saurabh nigam
Member
 
Registered: Feb 2009
Location: @ /home & @ my blog at http://saurabh-nigam.blogspot.com/
Distribution: Slackware , Fedora , Ubuntu
Posts: 35

Rep: Reputation: 15
Cool No sound after new Sound card


Hi all I recently got a yamaha sound card from a friend because my Intel card was not working so I disabled Intel sound card from BIOS so that I can use only Yamaha card but I hear no sound in Slackware but can hear sound in my Fedora & Windows (i.e.card is working)
Code:
root@wetlab:~# head /proc/asound/cards
 0 [ICH5           ]: ICH4 - Intel ICH5
                      Intel ICH5 with ALC655 at irq 17
 1 [YMF754         ]: YMF754 - Yamaha DS-1E (YMF754)
                      Yamaha DS-1E (YMF754) at 0xfbff8000, irq 22
I believe it is still trying to use Intel card
Help
 
Old 06-23-2010, 02:14 AM   #2
mlpa
Member
 
Registered: May 2008
Location: Aveiro
Distribution: Slackware
Posts: 490

Rep: Reputation: 35
Try run alsaconf, in sudo, to configure the new card.
 
Old 06-23-2010, 02:33 AM   #3
Martinezio
Member
 
Registered: May 2009
Location: Warsaw, Poland
Distribution: Slackware64-current
Posts: 191

Rep: Reputation: 32
You need to blacklist the intel's HD audio module, since this card isn't working for You...

On the second hand - why it doesn't work? Is this hardware problem, or You cannot configure this card under Slackware?
 
Old 07-12-2010, 03:52 AM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I know this is a bit late, but I think I know the solution, I've had to do this because I have 3 sound devices on one system, and it doesn't pick the right default.

1) Run:

Code:
cat /proc/asound/modules
it will give you something like:
Code:
 0 snd_hda_intel
 1 snd_yamaha
 2 snd_sis
2) To set the default sound card edit '/etc/modprobe.d/sound', or you can also put them in '/etc/modprobe.conf' and that should work for distros other than slackware.

Code:
options snd_yamaha index=0
options snd_hda_intel index=1
options snd_sis index=2
That sets the yamaha card as the default (index=0). You'll probably have to run:

Code:
/etc/rc.d/rc.alsa
for changes to take effect, or you can reboot if that doesn't work.

3) Use 'alsamixer' to set the volumes. Note that, running 'alsaconf' will overwrite '/etc/modprobe.d/sound', so don't run it, or add the options to the other file.

Last edited by H_TeXMeX_H; 07-12-2010 at 03:55 AM.
 
1 members found this post helpful.
Old 06-19-2012, 09:45 AM   #5
dangmc
LQ Newbie
 
Registered: Jun 2012
Location: Arizona
Distribution: Ubuntu, Slackware
Posts: 11

Rep: Reputation: Disabled
Quote:
Originally Posted by H_TeXMeX_H View Post
I know this is a bit late, but I think I know the solution, I've had to do this because I have 3 sound devices on one system, and it doesn't pick the right default.

1) Run:

Code:
cat /proc/asound/modules
it will give you something like:
Code:
 0 snd_hda_intel
 1 snd_yamaha
 2 snd_sis
2) To set the default sound card edit '/etc/modprobe.d/sound', or you can also put them in '/etc/modprobe.conf' and that should work for distros other than slackware.

Code:
options snd_yamaha index=0
options snd_hda_intel index=1
options snd_sis index=2
That sets the yamaha card as the default (index=0). You'll probably have to run:

Code:
/etc/rc.d/rc.alsa
for changes to take effect, or you can reboot if that doesn't work.

3) Use 'alsamixer' to set the volumes. Note that, running 'alsaconf' will overwrite '/etc/modprobe.d/sound', so don't run it, or add the options to the other file.
@TexMex: I have a similar problem in my new Slackware 13.37-x86_64 installation; eg. I have 2 sound devices-the default and a usb headset. I think your solution might work for me but I don't have a 'sound' file in /etc/modprobe.d nor do I have 'modprobe.conf' file. when I set alsamixer to the usb driver everything works fine until I try to access a Kde audio or video device, then I get a message offering to remove all my sound drivers. I click 'no', but afterwards I have to reset 'alsamixer' all over again to get my usb headset working again. Any advice will be appreciated, thank you.
:bash-4.2$ cat /proc/asound/modules
0 snd_usb_audio
1 snd_hda_intel
bash-4.2$
:bash-4.2$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Intel [HDA Intel], device 0: VT1828S Analog [VT1828S Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Intel [HDA Intel], device 1: VT1828S Digital [VT1828S Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Intel [HDA Intel], device 2: VT1828S HP [VT1828S HP]
Subdevices: 1/1
Subdevice #0: subdevice #0
bash-4.2$
 
Old 06-19-2012, 05:10 PM   #6
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64
Posts: 133

Rep: Reputation: 19
Quote:
Originally Posted by dangmc View Post
@TexMex: I have a similar problem in my new Slackware 13.37-x86_64 installation; eg. I have 2 sound devices-the default and a usb headset. I think your solution might work for me but I don't have a 'sound' file in /etc/modprobe.d nor do I have 'modprobe.conf' file.
sound.conf should be generated when you run alsaconf as root, look for it under /etc/modprobe.d/
 
Old 06-20-2012, 12:23 PM   #7
dangmc
LQ Newbie
 
Registered: Jun 2012
Location: Arizona
Distribution: Ubuntu, Slackware
Posts: 11

Rep: Reputation: Disabled
@dr.s-thank you for the suggestion. I ran 'alsaconf' as root but no sound.conf found in modprobe.d:

file:///etc/modprobe.d/usb-controller.conf
file:///etc/modprobe.d/psmouse.conf
file:///etc/modprobe.d/isapnp.conf
file:///etc/modprobe.d/bluetooth.conf
file:///etc/modprobe.d/blacklist.conf
This is what I have.
 
Old 06-20-2012, 03:09 PM   #8
dangmc
LQ Newbie
 
Registered: Jun 2012
Location: Arizona
Distribution: Ubuntu, Slackware
Posts: 11

Rep: Reputation: Disabled
I just went through all my multimedia apps; the only only one to play was VLC.
 
Old 06-20-2012, 08:34 PM   #9
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0, CRUX 3.1
Posts: 3,013
Blog Entries: 15

Rep: Reputation: 760Reputation: 760Reputation: 760Reputation: 760Reputation: 760Reputation: 760Reputation: 760
Try running this if alsaconf doesn't work:

Code:
modprobe snd-ymfpci
And create and edit file /etc/modules.conf as such:
Code:
 # ALSA portion
alias snd-card-0 snd-ymfpci

# OSS/Free portion - card #1 (Yamaha PCI)
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
You will also want to edit /etc/rc.d/rc.local to add lines for the module insertion method above if alsaconf doesn't work. It's a quick and dirty method to get it working if the alsa configuration tool doesn't work all the time. Often your card might be considered a "Legacy" device as well, so if it asks to probe for legacy devices, let it.

Run alsamixer and set your audio and then run
Code:
alsactl store
to store and record your default audio levels.

Last edited by ReaperX7; 06-20-2012 at 11:00 PM.
 
Old 06-20-2012, 09:25 PM   #10
dangmc
LQ Newbie
 
Registered: Jun 2012
Location: Arizona
Distribution: Ubuntu, Slackware
Posts: 11

Rep: Reputation: Disabled
@reaperX7: Thank you for your suggestion. This is what happened:

bash-4.2# modprobe ymfpci
FATAL: Module ymfpci not found.
bash-4.2#
After reboot I found most multimedia apps working including Firefox videos. I ran 'alsactl store' and hope things are fixed. Amarok and Juk gave this message: Multimedia system > the audio playback device doesn't work > C-Media-USB device doesn't work > falling back to Intel HD audio VT1828s.
I would also like to know how to troubleshoot this so I will understand what went wrong. What log files should I look in? I also would like to know if I should build the module suggested here:sound.conf should be generated when you run alsaconf as root, look for it under /etc/modprobe.d/
Again thank you for taking the time to help. The responses I've gotten on this forum in just a few days are sure amazing after the time I spent on Ubuntuforums where few of my posts were answered. I realize I made the right choice going with Slack even though I'm going to have a big learning curve.
 
Old 06-20-2012, 11:01 PM   #11
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0, CRUX 3.1
Posts: 3,013
Blog Entries: 15

Rep: Reputation: 760Reputation: 760Reputation: 760Reputation: 760Reputation: 760Reputation: 760Reputation: 760
Sorry about that. I edited it just now. Retry it with snd-ymfpci and it should work.
 
Old 06-21-2012, 01:26 PM   #12
dangmc
LQ Newbie
 
Registered: Jun 2012
Location: Arizona
Distribution: Ubuntu, Slackware
Posts: 11

Rep: Reputation: Disabled
dangmc

I just realized that this is specific to the Yamaha pci card, so I ran: # modprobe snd_usb_audio then # modprobe snd_hda_codec_via. This seems to work ok so far; any suggestions as to 'Juk' and 'Amarok'? I don't really care about amarok but would like to get 'Juk' working. Thanks
I should mention that I already deleted and reinstalled 'amarok' without anything changing.

Last edited by dangmc; 06-21-2012 at 01:28 PM. Reason: additional info
 
Old 06-22-2012, 06:28 AM   #13
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
'alsaconf' is broken I think. It just doesn't work anymore. Just create a file called 'sound.conf' or really 'anything.conf' will work as long as it ends in '.conf'.

The problem is that alsa uses a default sound card for everything. Switching is more difficult. You can check alsamixer and see if the volumes for both cards are unmuted.

Last edited by H_TeXMeX_H; 06-22-2012 at 06:29 AM.
 
Old 06-22-2012, 06:53 PM   #14
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0, CRUX 3.1
Posts: 3,013
Blog Entries: 15

Rep: Reputation: 760Reputation: 760Reputation: 760Reputation: 760Reputation: 760Reputation: 760Reputation: 760
It's not broken, but it doesn't work on some legacy PCI audio cards at times. Often you just have to search the ALSA-Project website and find out how to configure everything outside the normal tools.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound coming from my sound blaster audigy 2 ZS platinum sound card msab Linux - Hardware 9 12-05-2010 05:10 AM
No sound with Diamond Xtreme Sound 5.1 Sound Card - PCI Port Jmccmw Linux - Software 1 07-30-2009 08:43 AM
no sound from sound blaster PCI sound card using mandrake-linux 10.1 box nila56 Linux - Hardware 2 05-29-2006 02:48 PM
Sound card Issues in Suse 9.3 with a ??Conexant?? Sound card in Gateway laptop hackerarchangel Linux - Hardware 3 12-30-2005 11:35 PM
Diabling onboard sound card and enabling pci slot sound card abhatia Linux - Hardware 4 01-12-2004 02:10 AM


All times are GMT -5. The time now is 10:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration