LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-05-2004, 06:43 PM   #1
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Question No server available to handle request - ProFTPd


A little history here: my ISP blocks access to port 80, 21, and others that are unknown. Now, as a little sysadmin practice (I'm about as geeky as they come ), I decided to set up a webserver, FTP server, and eventually a POP3/SMTP server. So, I configured Apache, and got it working with a Port 80 Redirect (courtesy of no-ip.org) and got my proftpd server running on port 21000. As of yesterday, eerything was running flawlessly. Now, proftpd is not accepting connections. When I try to connect using:
Code:
ftp 127.0.0.1 21000
it works without a hitch. I can login, do everything without a problem. Now, if I use my global IP, we'll say www.example.org, it won't work. I get this error message:
Code:
ftp> open scuzzman.homelinux.org 21000
Connected to www.example.org.
500 Sorry, no server available to handle request on www.example.org.
This is my /etc/proftpd.conf file:
Code:
# This is a basic ProFTPD configuration file.
# It establishes a single server and a single anonymous login.
# It assumes that you have a user/group "nobody" and "ftp"
# for normal/anonymous operation.

ServerName                      "www.example.org"
ServerType                      standalone
# ServerType                     inetd
DefaultServer                   off

# Port 21 is the standard FTP port.
Port                            21000
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask                           022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances                    30

# Set the user and group that the server normally runs at.
User                            nobody
Group                           nogroup

# This next option is required for NIS or NIS+ to work properly:
#PersistentPasswd off

SystemLog                       /var/log/proftpd.log
TransferLog                     /var/log/xferlog

# Normally, we want files to be overwriteable.
<Directory /*>
  AllowOverwrite                on
</Directory>
Any ideas on this? As the server yesterday was working without a hitch...
<EDIT>
More info: The port is allowed both locally and globally (enabled access through port 21000 in GuardDog for both Network and Internet
</EDIT>

Last edited by scuzzman; 11-05-2004 at 06:45 PM.
 
Old 11-06-2004, 09:06 AM   #2
flashingcurser
Member
 
Registered: Jan 2003
Distribution: many win/nix/mac
Posts: 259

Rep: Reputation: 31
I take it you have local network and an internet connection? Have one of the computers on the local network connect to the ftp-- that will help determine if its at the dsl/cable modem. If it does connect from a local machine then start looking at your modem/isp. If you cant connect from the local network disconnect from the internet and take down guarddog --- then if you can connect from the local network start looking at your firewall.

I notice you haven't called out a anonymous directory-- for example
Code:
<Anonymous /home/ftp/pub>
User         ftp
Group      ftp

UserAlias     anonymous ftp

MaxClients        10

<Limit WRITE>
DenyALL
</Limit>

</Anonymous>

One thing just to clarify -- how are you trying to connect to the proftpd? Your setup would not allow you to connect through a web browser (firefox, internet explorer, etc....) You would need a real ftp client (command line, leech etc....)


I know this may be a real stupid thing to ask (I only ask because it has happened to me a time or 2)

Have you tried restarting proftpd ?

/etc/rc.d/rc.proftpd restart

Just some quick thoughts


 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ProFTPD - "500 Sorry, no server available to handle request on 192.168.1.103" - what? orange400 Linux - General 15 05-21-2013 03:59 PM
Unable to handle kernel paging request Error EnigmaX Slackware - Installation 9 12-13-2007 12:01 PM
FC2: Unable to handle kernel paging request aless Linux - Software 0 06-28-2005 07:33 AM
Unable to handle kernel paging request at virtual address jah3765 Linux - General 6 01-17-2005 10:48 PM
How to troubleshoot this? Unable to handle kernel paging request black hole sun Linux - Software 1 08-17-2004 01:51 AM


All times are GMT -5. The time now is 11:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration