LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-08-2014, 01:41 PM   #1
rlx
LQ Newbie
 
Registered: Jul 2009
Location: Montréal
Distribution: Slackware customized
Posts: 13

Rep: Reputation: 0
Smile No SCIM input in Terminal or in Emacs but working fine in Firefox / Thunderbird


Hi,

I moved to Slackware64 multilib last year and I still have this problem with SCIM. It must be some parameter I didn't setup right in the config and maybe someone can help me by pointing to some parameters to look for.

The problem is that SCIM no longer reacts to the 'C-;' command when the X focus is on an Emacs or Terminal window. This used to work fine before when I used Slackware32. However I still get Chinese input from Firefox as here 你好.

Here are the modules I installed,

scim-1.4.14-x86_64-2
scim-bridge-0.4.16-x86_64-5
scim-pinyin-0.5.91-x86_64-2
scim-tables-0.5.9-x86_64-3

Of course I have all the fonts installed. I can display Chinese text in both Emacs an on Xterm terminal windows.

When using Firefox the SCIM related windows work as expected. It is just that I can't activate SCIM from Emacs or Xterm terminals.

I use FVWM as a windows manager. I also used FVWM with Slackware32. So no change here.

I typically call emacs as follows,

LC_CTYPE=en_US.UTF-8 LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 XMODIFIERS=@im=SCIM GTK_IM_MODULE=scim-bridge exec /usr/bin/emacs

Now when I type C-; in Emacs I get the following message:

SCIM: file-error: ("make client process failed" "no such file or directory" :name "scim-bridge" :service "/tmp/scim-bridge-0.3.0.socket-1000@localhost:0.1" :buffer " *scim-bridge(:0.1)*" :family local :server nil :noquery t)

even if scim-bridge is in the path.


Thank's for any suggestion.
 
Old 04-08-2014, 04:24 PM   #2
rlx
LQ Newbie
 
Registered: Jul 2009
Location: Montréal
Distribution: Slackware customized
Posts: 13

Original Poster
Rep: Reputation: 0
Solved the Emacs part

I updated to emacs-24.3-x86_64-3.txz and now SCIM works in Emacs.

I still have to solve that problem for xterm. I tried xterm-297-x86_64-1 and I still have no luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Scim input for 32bit program is not working under x86_64 (multilib) kite Slackware 0 05-18-2010 04:01 AM
Japanese input not working in Qt with SCIM-QTIMM AireTamStorm Linux - Software 1 04-30-2006 11:33 AM
gnome-settings-daemon prevents scim working on Emacs realwhz Debian 0 03-02-2006 08:10 AM
Skim/Scim not working in Firefox 1.0.6? koyi Slackware 1 09-23-2005 08:55 AM


All times are GMT -5. The time now is 12:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration