LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-10-2003, 03:34 PM   #1
uglydot
Member
 
Registered: Mar 2003
Distribution: Gentoo
Posts: 232

Rep: Reputation: 30
No more modules after kernel compile w/ ck patch


Just like the topic, I just recompiled my kernel with the ck patch which allows preemptable kernel. I followed this tutorial, and I have done this quite a few times by now. here
Now I boot with no modules, do I simply need to move some files or what?

EDIT:I also still have net and sound, oddly enough...
 
Old 11-10-2003, 03:54 PM   #2
JonW
LQ Newbie
 
Registered: Nov 2003
Location: UK
Distribution: Slackware64 13.37
Posts: 14

Rep: Reputation: 0
Provided you didn't miss the make modules_install step, most of your modules will still be there. ALSA modules won't however. To install these download alsa-driver, extract, and then

./configure
make
make install-modules

Quite how your sound is still working I'm not sure. You didn't compile the sound driver into the kernel?
 
Old 11-10-2003, 03:57 PM   #3
uglydot
Member
 
Registered: Mar 2003
Distribution: Gentoo
Posts: 232

Original Poster
Rep: Reputation: 30
I must have compiled the sound into the kernel or else it wouldn't be there, but I made the make modules_install command while compiling and they aren't here... Hmm.
 
Old 11-10-2003, 04:04 PM   #4
uglydot
Member
 
Registered: Mar 2003
Distribution: Gentoo
Posts: 232

Original Poster
Rep: Reputation: 30
Ok, looks like my kernel has most stuff I need in it, just can't get fglrx in there. Meh, good luck there I guess...

Ok, god it to build...now dmesg shows this error...

[fglrx] Maximum main memory to use for locked dma buffers: 431 MBytes.
[fglrx] module loaded - fglrx 3.2.8 [Sep 21 2003] on minor 0
[fglrx:firegl_unlock] *ERROR* Process 539 using kernel context 0

Last edited by uglydot; 11-10-2003 at 04:50 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no modules after kernel compile glorsplitz Slackware 7 09-20-2005 11:26 AM
no lib/modules/2.6.13 after kernel compile Motown Slackware 2 09-07-2005 08:59 AM
ACPI patch and kernel compile error crisponions Linux - Laptop and Netbook 3 10-29-2003 07:52 PM
modules after re-compile kernel skarim Linux - Software 3 10-15-2003 02:48 AM
Kernel Compile error after applyin bootsplash patch h1tman Slackware 0 10-06-2003 10:05 AM


All times are GMT -5. The time now is 06:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration