LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-14-2011, 01:33 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,251

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
No microphone


Been many years since I had to use an audio microphone with my computer. All I have is an inexpensive microphone/earphone headset. I know the device worked at one time. A few years ago I connected an audio cassette deck to my system and copied the tapes through audacity. Therefore audio in has worked with this system. I think I was using 12.2 at that time.

I'm using Slackware 13.1.

The earphone on the headset still works, but thus far not the microphone. That the earphone works indicates the wire "probably" is okay for the microphone. The separate desktop speakers work fine too.

I found nothing in a forum search.

This is a 3.5 mm jack connector, not USB.

I have an ASUS M2NPV-VM motherboard. According to the user guide, the pink connector on the on-board sound card is the microphone port. I have a case front-side connector too, which I am reasonably sure I used when I copied the audio cassette tapes.

Using arecord and aplay result in silence. Hissing noise only.

Alsamixer has all settings set to maximum except for any named "boost." KMix has the same settings. Setting the "Mic boost" option to maximum does not help.

The output of arecord -l:

**** List of CAPTURE Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: AD198x Analog [AD198x Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0

lspci output:

00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

I'm using the proprietary Nvidia video drivers (195.36.31).

I don't notice anything obvious in the KDE Control Center sound settings or Nvidia settings, but I could be missing something.

I'm sure I'm missing something obvious.

I appreciate any help.

Thanks.
 
Old 09-14-2011, 01:49 PM   #2
Bindestreck
Member
 
Registered: Jul 2011
Location: Sweden
Distribution: Slackware
Posts: 288

Rep: Reputation: 51
Maybe this link will help you, maybe some kernel module is not loaded correctly?

http://forums.gentoo.org/viewtopic-t...4-start-0.html
 
Old 09-14-2011, 05:59 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,251

Original Poster
Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
lsmod | grep snd

Code:
Module                  Size  Used by
snd                    43203  19 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_hda_codec          57091  2 snd_hda_codec_analog,snd_hda_intel
snd_hda_codec_analog    52315  1
snd_hda_intel          19224  6
snd_hwdep               5046  1 snd_hda_codec
snd_mixer_oss          13399  1 snd_pcm_oss
snd_page_alloc          6009  2 snd_hda_intel,snd_pcm
snd_pcm                58024  5 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_pcm_oss            33917  0
snd_seq                42857  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          4543  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_seq_dummy           1107  0
snd_seq_midi_event      4620  1 snd_seq_oss
snd_seq_oss            25580  0
snd_timer              15699  4 snd_seq,snd_pcm
soundcore               4847  1 snd
 
Old 09-14-2011, 06:22 PM   #4
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,231

Rep: Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573
If you press Tab in alsamixer you should be able to get capture settings -- you should probably check to see if setting one or more of the "Capture" devices to full volume allows you to record (along with mic boost, but you already mentioned that).

If that still doesn't work you may need to pass some options...it seems that alsa can only determine the general model of your card (AD198x); several possible chipsets are mentioned in /usr/src/linux/Documentation/sound/alsa/HD-Audio-Models.txt. You may wish to try passing some or all of those model options to snd-hda-intel to see if it's just a problem with model auto-detection.
 
Old 09-14-2011, 06:56 PM   #5
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,251

Original Poster
Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
I successfully tested the microphone on a PII running Windows. That confirms the microphone is working. That same system has 12.2 installed but the microphone won't work there using arecord and aplay. In the PII the sound card is a C-Media 8738 PCI.

Alsamixer capture is set to maximum in both systems.

So no microphone in either system with two different sound cards but the microphone works. I wonder whether I have some obscure option set that disables the microphone.
 
Old 09-14-2011, 10:05 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,251

Original Poster
Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Some progress. I'm unsure what I did exactly. I ran an old live cd and the microphone worked there --- sort of. That is, I could speak into the microphone and hear myself through the desktop speakers. Yet using arecord and aplay did not result in anything I could hear.

I rebooted back into 13.1 and saw the same results. I can tap on the microphone and hear the noise in the desktop speakers. Yet arecord and aplay do nothing. The aplay command does work as I can play other WAV files.

Recording in audacity does nothing either.

The microphone works but I don't know why I see nothing with arecord and audacity. I can live with arecord not working but I want to see audacity record, which is where all of this troubleshooting began.
 
Old 09-15-2011, 10:54 AM   #7
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,251

Original Poster
Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
This is a strange journey. I have the microphone working with audacity, but I had to update audacity from 1.3.12 to 1.3.13.

Using the arecord and aplay commands to test the microphone will not work with the microphone until after I start the desktop. Thereafter I can exit X and the commands still function.

Using ffmpeg to test the microphone behaves in the same manner. That is, the microphone won't work with ffmpeg until after I start the desktop.

Although I am using 13.1 I still have 12.2 partitions on this system. I had to repeat the same corrections there too. I had to update libtheora to update ffmpeg to update audacity. Yet thereafter, once the desktop was running the command line tests and audacity would work with the microphone.

The microphone now works, but I won't tag this thread as solved because I don't know the underlying root causes of this behavior, why the microphone originally failed to function, or why the command line tests fail until after I start the desktop.

For anybody using a low-end microphone, using Mic Boost in the desktop audio mixer makes a difference. I had to fiddle a bit with mixer settings and audacity but even with a low-end microphone I can create decent voice-overs. In the past I have had hissing noise problems using Mic Boost, therefore I need to enable that option only when using a microphone.

I probably should buy a better microphone, but I am not planning many projects needing voice-overs.

FYI: To use ffmpeg to test a microphone:

ffmpeg -f oss -i /dev/dsp -y test.wav
aplay test.wav
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
virtual microphone: FILE ---> MICROPHONE ---> APPLICATION jamal_mohammadi Linux - Hardware 1 02-13-2011 03:10 PM
microphone in vm harsshal Linux - Software 0 05-12-2008 07:21 AM
Can't use microphone RGB_mdk Linux - Hardware 10 05-03-2008 08:11 AM
microphone ravikm Linux - Newbie 2 01-02-2008 09:34 AM
QT and Microphone Henry Linux - General 17 02-04-2003 06:53 PM


All times are GMT -5. The time now is 05:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration