LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-11-2011, 05:02 PM   #1
bogzab
Member
 
Registered: Mar 2006
Location: Dyserth, Wales
Distribution: Slackware 13.37, Slackware 14.0
Posts: 260

Rep: Reputation: 31
No kipi Plugins in Digikam or Gwenview


pkgtool tells me that I have Digikam 1.9 and kipi plugins 1.9 both installed. However when I run digikam no kipi plugins are detected. The tab in the configure Digikam menu for kipi plugin config is empty. Gwenview also shows no plugins.

A few weeks ago these plugins were there and even working. I was experimenting with various "export-to-web-services" plugins. What has happened to these useful extensions?

Anybody ?

Thanks
 
Old 07-11-2011, 07:38 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,493

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
you can try to use pkgtool --reinstall /path/to/kipi-plugins-file.txz
 
Old 07-12-2011, 02:04 AM   #3
bogzab
Member
 
Registered: Mar 2006
Location: Dyserth, Wales
Distribution: Slackware 13.37, Slackware 14.0
Posts: 260

Original Poster
Rep: Reputation: 31
Tried re-installing both digikam and kipi-plugins, but I still have the same outcome - no kipi-plugins available.

The digikam splash screen provides a few progress messages among which is "loading kipi plugins", but nothing seems to result from this.

One clue might be this output which comes from running gwenview at the command line:

Quote:
gwenview(14654)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType "KIPI/Plugin" not
found
This suggests that kipi-plugins should have registered itself as a KDE4 service (presumably during installation of kipi-plugins). There may be something in my KDE4 setup which is preventing this. I will try on a KDE list.
 
Old 07-12-2011, 03:25 AM   #4
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,493

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
How do you build it?
I would suggest to rebuilt it

most of the time, you upgraded KDE, but forgot to rebuilt digikam/kipi plugins against the newest version of KDE
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Gwenview, KDE 4.5.90 and Kipi Plug-ins. cwizardone Slackware 1 01-01-2011 01:03 PM
kipi-plugins 1.3.0 SeRi@lDiE Slackware 3 06-27-2010 10:49 PM
LXer: digiKam and Kipi sprint LXer Syndicated Linux News 0 11-22-2009 07:50 PM
Installing kipi-plugins AND digikam Kirmonkey Linux - Software 4 10-08-2007 02:51 PM
PSD (Photoshop) files won't load in Gwenview of DigiKam Cinematography Linux - Software 1 08-27-2007 04:54 PM


All times are GMT -5. The time now is 06:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration