LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   No keyboard response in slackware. Not even from install CD. (http://www.linuxquestions.org/questions/slackware-14/no-keyboard-response-in-slackware-not-even-from-install-cd-362638/)

halo14 09-12-2005 09:09 AM

No keyboard response in slackware. Not even from install CD.
 
This really isn't a question,since I found the answer to it before I posted this. However, I wanted it to be available if someone searches for the error.

Senario: No keyboard response from Slackware(10.1, or any of the currents, likely 10.2 as well.) Can hit "enter" to boot from the CD, however when at the prompt for keyboard layout, nothing works.

Solution: Disable "Legacy USB Support" in the BIOS.

I'm not really sure what the "Legacy USB Support" is, because I still have fully function USB everything. I use a USB mouse, JumpDrive, etc. with no problems.

This a notebook computer, and the rror may only be related to notebook computers. I remember that FC2 had this same problem when it was released. So I had always had Legacy USB Support disabled, however, I did a BIOS update, and totally forgot about that.

At the time of the BIOS update I was testing openSUSE, so didn't notice anything. When I tried to reinstall Slackware, I had this problem. Was asking for help in ##slackware, and ananke suggested to do "nousb". This worked fine then. After thinking about that for a while, i remembered the problem with FC2 and checked the BIOS. Sure enough, the BIOS update had reset it back to 'enabled'.

All is working well now, but I can only imagine that this is a problem for others as well, with a very simple solution.

:)

cb951303 09-12-2005 12:12 PM

haha thank you very much, I had a friend who couldn't install slack just because of this problem :D

halo14 09-12-2005 01:43 PM

great! glad it helped!

hitest 09-12-2005 10:03 PM

Re: No keyboard response in slackware. Not even from install CD.
 
Quote:

Originally posted by halo14
This really isn't a question,since I found the answer to it before I posted this. However, I wanted it to be available if someone searches for the error.

Senario: No keyboard response from Slackware(10.1, or any of the currents, likely 10.2 as well.) Can hit "enter" to boot from the CD, however when at the prompt for keyboard layout, nothing works.

Solution: Disable "Legacy USB Support" in the BIOS.

I'm not really sure what the "Legacy USB Support" is, because I still have fully function USB everything. I use a USB mouse, JumpDrive, etc. with no problems.

This a notebook computer, and the rror may only be related to notebook computers. I remember that FC2 had this same problem when it was released. So I had always had Legacy USB Support disabled, however, I did a BIOS update, and totally forgot about that.

At the time of the BIOS update I was testing openSUSE, so didn't notice anything. When I tried to reinstall Slackware, I had this problem. Was asking for help in ##slackware, and ananke suggested to do "nousb". This worked fine then. After thinking about that for a while, i remembered the problem with FC2 and checked the BIOS. Sure enough, the BIOS update had reset it back to 'enabled'.

All is working well now, but I can only imagine that this is a problem for others as well, with a very simple solution.

:)

Cool, thanks for the tip, I'm saving this for future reference. My Slackware box has a standard US keyboard, but, in the future I may come across this on another computer, you never know.:D


All times are GMT -5. The time now is 11:25 PM.