LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   no kernel modules found for 2.6.29.6-smp (http://www.linuxquestions.org/questions/slackware-14/no-kernel-modules-found-for-2-6-29-6-smp-751677/)

aBiNg 09-01-2009 12:53 AM

no kernel modules found for 2.6.29.6-smp
 
OK, i'v been installed slackware 13.0, and boot from kernel-huge-smp without any problems. As you know, kernel-generic-smp is better for daily use. So i installed 'kernel-generic-smp' and 'kernel-modules-smp', then run the command 'mkinitrd -c -k 2.6.29.6 -f ext4'(ext4 for / partition), at last edited /etc/lilo.conf as /boot/README.initrd say and run 'lilo -v', nothing wrong occured. But after rebooting, tty said 'no kernel modules found for 2.6.29.6-smp ...' and 'sh:' recovery command line prompt.

Is there anything different between ext4 and ext3 when mkinitrd-ing? Or what steps i missed in the process?

Any help will be appreciated.

BTW, tty becomes darkgray after exiting X. This problem not only exists under slackware 13.0. I am also seeking for suggestions.:-)

tramni1980 09-01-2009 02:45 AM

Quote:

Originally Posted by aBiNg (Post 3664898)
OK, i'v been installed slackware 13.0, and boot from kernel-huge-smp without any problems. As you know, kernel-generic-smp is better for daily use. So i installed 'kernel-generic-smp' and 'kernel-modules-smp', then run the command 'mkinitrd -c -k 2.6.29.6 -f ext4'(ext4 for / partition), at last edited /etc/lilo.conf as /boot/README.initrd say and run 'lilo -v', nothing wrong occured. But after rebooting, tty said 'no kernel modules found for 2.6.29.6-smp ...' and 'sh:' recovery command line prompt.

Is there anything different between ext4 and ext3 when mkinitrd-ing? Or what steps i missed in the process?

Any help will be appreciated.

BTW, tty becomes darkgray after exiting X. This problem not only exists under slackware 13.0. I am also seeking for suggestions.:-)

I think the kernel name in the above command should be 2.6.29.6-smp instead of just 2.6.29.6,i.e.
Code:

mkinitrd -c -k 2.6.29.6-smp -f ext4
You could also try the mkinitrd command generator script mentioned in the Changes and Hints to get the appropriate initrd command for your system.

gegechris99 09-01-2009 03:18 AM

Hello,

Please read the README.initrd for how to create the initrd.gz image.

The correct syntax would be:

Code:

mkinitrd -c -k 2.6.29.6-smp -m ext4 -f ext4 -r /dev/hda1
Please replace /dev/hda1 with the partition where your root "/" directory is located.

aBiNg 09-01-2009 04:24 AM

Solved. Thank you, guys!
Sorry for my carelessness. The '-m' option(what i missed) is very important, at least for ext4.

The darkgray tty problem may be triggered from xorg 1.5 to xorg 1.6 or vise versa. Any ideas?

atreios48 12-19-2011 10:36 AM

atreios48
 
[mod_edit]Foreign language content removed, please re-post in English[/mod_edit]


All times are GMT -5. The time now is 07:10 PM.