LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   No internet, network in Slackware 14 (http://www.linuxquestions.org/questions/slackware-14/no-internet-network-in-slackware-14-a-4175435476/)

firekage 11-03-2012 01:50 PM

No internet, network in Slackware 14
 
Hello.

I would like to ask for your help. I don't know why but my Slackware won't connect to internet. I thing that it is related to ip addres not being obtained.

I have two network card, realtek and ics with sundance driver. Wire is plugged to ics nic. In lsmod i see that both drivers are loaded:

Code:

Module                  Size  Used by
snd_seq_dummy          1119  0
snd_seq_oss            24956  0
snd_seq_midi_event      4568  1 snd_seq_oss
snd_seq                41599  5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device          4276  3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss            33254  0
snd_mixer_oss          12984  1 snd_pcm_oss
appletalk              22190  0
ipv6                  238549  30
lp                      7119  0
fuse                  58282  17
tda9887                8405  1
tda8290                11241  0
tea5767                5516  0
ir_lirc_codec          3431  0
lirc_dev                7667  1 ir_lirc_codec
snd_hda_codec_via      34367  1
ir_mce_kbd_decoder      2746  0
tuner                  14637  2
ir_sony_decoder        1255  0
ir_jvc_decoder          1349  0
adt7475                13558  0
ir_rc6_decoder          1637  0
hwmon_vid              2304  1 adt7475
ir_rc5_decoder          1285  0
snd_hda_intel          19503  2
snd_hda_codec          70505  2 snd_hda_intel,snd_hda_codec_via
snd_hwdep              4802  1 snd_hda_codec
nouveau              661269  3
usbhid                31118  0
mxm_wmi                1093  1 nouveau
video                  9938  1 nouveau
ttm                    45384  1 nouveau
drm_kms_helper        22825  1 nouveau
snd_ctxfi              78501  2
snd_pcm                59013  4 snd_ctxfi,snd_hda_codec,snd_hda_intel,snd_pcm_oss
drm                  151850  5 drm_kms_helper,ttm,nouveau
hid                    65824  1 usbhid
sp5100_tco              3912  0
ppdev                  4710  0
snd_page_alloc          5925  3 snd_pcm,snd_ctxfi,snd_hda_intel
snd_timer              14798  2 snd_pcm,snd_seq
parport_pc            16755  1
parport                26159  3 parport_pc,ppdev,lp
ir_nec_decoder          1413  0
i2c_piix4              7236  0
processor              23020  0
cx8800                24649  0
cx88xx                67473  1 cx8800
btcx_risc              2895  2 cx88xx,cx8800
tveeprom              10673  1 cx88xx
videobuf_dma_sg        7291  2 cx88xx,cx8800
videobuf_core          13700  3 videobuf_dma_sg,cx88xx,cx8800
v4l2_common            4494  3 cx88xx,cx8800,tuner
videodev              66999  4 v4l2_common,cx88xx,cx8800,tuner
rc_core                10912  8 cx88xx,ir_nec_decoder,ir_rc5_decoder,ir_rc6_decoder,ir_jvc_decoder,ir_sony_decoder,ir_mce_kbd_decoder,ir_lirc_codec
i2c_algo_bit            4543  2 cx88xx,nouveau
i2c_core              16454  15 i2c_algo_bit,videodev,v4l2_common,tveeprom,cx88xx,cx8800,i2c_piix4,drm,drm_kms_helper,nouveau,adt7475,tuner,tea5767,tda8290,tda9887
sundance              18412  0
r8169                  42347  0
thermal_sys            12122  2 processor,video
mii                    3335  2 r8169,sundance
wmi                    7255  1 mxm_wmi
k10temp                2131  0
snd                    43657  20 snd_timer,snd_pcm,snd_ctxfi,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_via,snd_mixer_oss,snd_pcm_oss,snd_seq_device,snd_seq,snd_seq_oss
soundcore              4570  1 snd
ati_agp                4737  0
agpgart                22087  3 ati_agp,drm,ttm
button                  3665  1 nouveau
evdev                  7314  5
asus_atk0110            8880  0
hwmon                  1033  5 asus_atk0110,k10temp,thermal_sys,nouveau,adt7475
loop                  14650  0

also, my ifconfig looks like this:

Code:

eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 90:e6:  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 43  base 0x4000 

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::4a5b  prefixlen 64  scopeid 0x20<link>
        ether 48:5b:39:bf:0b:55  txqueuelen 1000  (Ethernet)
        RX packets 30  bytes 1800 (1.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 6  bytes 468 (468.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 21  base 0xe880 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 409  bytes 30383 (29.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 409  bytes 30383 (29.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

There is no network, no internet acces. Driver is loaded, there is no ip, also in KDE i can't add connection:

1:
http://imageshack.us/f/405/s14net1.png/
2
:
http://imageshack.us/f/844/s14net2.png/

(as you can see, network agent - in polish it is konfiguracja pośrednika sieciowego - doesen't work, and i can't start it from here. In network panel, (first pic) also there is nothing, can't add anything.

Can you help me? I remember having something similar with 13.37, but i could install wicd, it works, here i can't install even wicd from DVD because i have do a slackpkg update, and i can't do it without internet acces, which could not be established.

Could you help me to solve my problem with connecting/setting wired network to internet acces?

Thanks.

business_kid 11-03-2012 03:24 PM

eth1 appears to have an ipv6 address, but no ipv4 one (line 2 in the ifconfig output). It looks like you haven't filled anything in /etc/rc.d/rc.inet1.conf. It has 4 sections like this one:
Quote:

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""
Section [0] refers to eth0, section [1] to eth1. You can put in fixed ip, netmask, & hostname if you have a fixed IP. Otherwise just set USE_DHCP[0]="yes" if you want to connect eth0 to the router.

firekage 11-03-2012 07:06 PM

Quote:

Originally Posted by business_kid (Post 4821544)
eth1 appears to have an ipv6 address, but no ipv4 one (line 2 in the ifconfig output). It looks like you haven't filled anything in /etc/rc.d/rc.inet1.conf. It has 4 sections like this one:


Section [0] refers to eth0, section [1] to eth1. You can put in fixed ip, netmask, & hostname if you have a fixed IP. Otherwise just set USE_DHCP[0]="yes" if you want to connect eth0 to the router.

Yes, i haven't done it and, in matter of fact, i don't want to edit this by a terminal. I want to know why, on a fresh installation, when there are "gui" tools, from KDE, internet connection doesen't work, and in fact, there is not even possible to set this by this tools. In KDE there is network section where i should be able to edit settings - but i can't...Also, i don't understand why i can't install wicd without doing slackpg update, when on 13.37 also i haven't uncommented mirrors in /etc/slackpg but could install it without problem.

In other words : there are network tools that doesen't allow to set up network. How to set up without terminal, without editing rc.inet1.conf with tools that i shown on a screen 1.

Alien Bob 11-03-2012 07:32 PM

If you want to use NetworkManager's KDE applet, have you first made the NM init script executable? Check /etc/rc.d/rc.networkmanager , Slackware does not install it executable by default.

Eric

allend 11-03-2012 07:33 PM

You are attempting to use the knetworkmanager, which does not work with Slackware. (The KDE developers do not support the Slackware network configuration setup). The GUI tool to use in KDE is the Network Management task bar widget (aka plasmoid) for configuring NetworkManager.

For further details on network configuration see http://docs.slackware.com/slackware:...e_your_network

firekage 11-04-2012 05:54 AM

Quote:

Originally Posted by Alien Bob (Post 4821658)
If you want to use NetworkManager's KDE applet, have you first made the NM init script executable? Check /etc/rc.d/rc.networkmanager , Slackware does not install it executable by default.

Eric

Thank you for a reply.

Still, it haven't solved my problem yet. I see that applet works, shows me 2 wired connections but even when manually add this to network gui setup:

http://imageshack.us/f/811/s14net3.png/

This picture shows two wired connection, but applet informs that cable is unplugged which is not true.

There is no internet. I thing that ip addres is not being obtained even when i set up network manually. Don't know why it doesen't work. It works if i edit manually rc.inet1.conf by mcedit in terminal and type the same thing that i typed in applet.

I would like to do it with the "applet way" because i want to know that it works.

---------- Post added 11-04-12 at 11:55 AM ----------

Quote:

Originally Posted by allend (Post 4821659)
You are attempting to use the knetworkmanager, which does not work with Slackware. (The KDE developers do not support the Slackware network configuration setup). The GUI tool to use in KDE is the Network Management task bar widget (aka plasmoid) for configuring NetworkManager.

For further details on network configuration see http://docs.slackware.com/slackware:...e_your_network

Thanks. It still doesen't work using applet.

jjthomas 11-04-2012 07:06 AM

Quote:

Originally Posted by firekage (Post 4821644)
I want to know why, on a fresh installation, when there are "gui" tools, from KDE, internet connection doesen't work, and in fact, there is not even possible to set this by this tools.

You should have been offered the opportunity to setup your network during the installation. Also, if you run pkgtool; Select Setup and then select netconfig, you should be able to run the basic network setup script.

I setup my server that way with a static IP address. I set up my laptop with a DHCP address and then
Code:

chmod +x /etc/rc.d/rc.networkmanager
From there I am able to connect to my wireless networks, after I put in my SSID and network key, of course.

Oh and the network applet works, as well.

-JJ

firekage 11-04-2012 07:15 AM

Quote:

Originally Posted by jjthomas (Post 4821847)
You should have been offered the opportunity to setup your network during the installation. Also, if you run pkgtool; Select Setup and then select netconfig, you should be able to run the basic network setup script.

I setup my server that way with a static IP address. I set up my laptop with a DHCP address and then
Code:

chmod +x /etc/rc.d/rc.networkmanager
From there I am able to connect to my wireless networks, after I put in my SSID and network key, of course.

Oh and the network applet works, as well.

-JJ

If i understand correctly, running netconfig will do the same thing i would do if i would like to edit manually, in terminal, rc.inet1.conf which i don't want to do. I want to do it by gui - one tool for the job. There is applet in kde, i want to use it, not a terminal. I started applet by chmod +x /etc/rc.d/rc.networkmanager, it shows my two wired nic, i entered ip addres and...network doesen't work.

Alien Bob 11-04-2012 07:28 AM

I can't read the polish stuff in that screenshot but you have configured eth2 manually, apparently.
What's the output of:
Code:

ifconfig -a
Code:

route -n
Code:

cat /etc/resolv.conf
Code:

ping 8.8.4.4
Eric

firekage 11-04-2012 08:07 AM

ifconfig -a

Code:

eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 90:e6  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 43  base 0x4000 

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::  prefixlen 64  scopeid 0x20<link>
        ether 48:5b  txqueuelen 1000  (Ethernet)
        RX packets 9  bytes 540 (540.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3  bytes 258 (258.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 21  base 0xe880 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 308  bytes 19224 (18.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 308  bytes 19224 (18.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

route -n

Code:

root@darkstar:/home/firekage# route -n
Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
127.0.0.0      0.0.0.0        255.0.0.0      U    0      0        0 lo
root@darkstar:/home/firekage#


resolv.conf
Code:

root@darkstar:/home/firekage# cat /etc/resolv.conf
# Generated by dhcpcd
# /etc/resolv.conf.head can replace this line
# /etc/resolv.conf.tail can replace this line
root@darkstar:/home/firekage#

ping:
Code:

root@darkstar:/home/firekage# ping 8.8.4.4
connect: Network is unreachable
root@darkstar:/home/firekage#


I could do the "easy" way, and edit rc.inet1.conf but i want to learn and know why it doesen't work from the applet and KDE tools.

allend 11-04-2012 11:30 AM

Your screenshot shows that your two interfaces are being recognised but they do not show an active connection (the region under Connections is blank).
Quote:

This picture shows two wired connection, but applet informs that cable is unplugged which is not true.
Please check whether you have active link lights on your NICs. Faulty cables and plugs do happen.

PS - I have just tested manual configuration via the KDE applet on my machine with a single wired interface and all worked as expected.

firekage 11-04-2012 01:05 PM

Quote:

Originally Posted by allend (Post 4821984)
Your screenshot shows that your two interfaces are being recognised but they do not show an active connection (the region under Connections is blank).

Please check whether you have active link lights on your NICs. Faulty cables and plugs do happen.

PS - I have just tested manual configuration via the KDE applet on my machine with a single wired interface and all worked as expected.

It is not related to this. I have (with Slackware 14) eight, or seven different Linuxes installed and only on 14 i don't have internet connection using applet/kde tools. I switch, for an example, to Ubuntu and the internet is, i have it. I would like to know what to do, how to do it trough kde applet.

Cable is plugged, i have lights blinking on it.

onebuck 11-04-2012 02:35 PM

Member Response
 
Hi,
Quote:

Originally Posted by firekage (Post 4822038)
It is not related to this. I have (with Slackware 14) eight, or seven different Linuxes installed and only on 14 i don't have internet connection using applet/kde tools. I switch, for an example, to Ubuntu and the internet is, i have it. I would like to know what to do, how to do it trough kde applet.

Cable is plugged, i have lights blinking on it.

So you changed using 'chmod a+x /etc/rc.d/rc.networkmanager' but did you start the daemon as root;
Code:

~# /etc/rc.d/rc.networkmanager start
Starting NetworkManager daemon:  /usr/sbin/NetworkManager

Arguments pass to rc.networkmanager;
Code:

~# /etc/rc.d/rc.networkmanager start
~# /etc/rc.d/rc.networkmanager stop
~# /etc/rc.d/rc.networkmanager status
~# /etc/rc.d/rc.networkmanager restart

Try a 'restart'.

bogzab 11-05-2012 07:56 AM

Quote:

resolv.conf

Code:

root@darkstar:/home/firekage# cat /etc/resolv.conf
# Generated by dhcpcd
# /etc/resolv.conf.head can replace this line
# /etc/resolv.conf.tail can replace this line
root@darkstar:/home/firekage#


The above listing suggests that resolv.conf has got no nameserver address(es). I think I have usually provided one or two IP addresses here which my ISP tells me I should use.

bones78 11-05-2012 12:30 PM

I had a similar problem when I did a new install 14. The kde applet appears to show connections with the onboard ethernet. Which I don't use as it is faulty....So I disabled it in the bios. When I did netconfig it picked up my pci card. Internet connects fine...it just doesn't show an ethernet connection in the kde applet...it says network manager is not running.


All times are GMT -5. The time now is 11:08 PM.