LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-18-2008, 05:32 PM   #1
Raccoon1400
Member
 
Registered: Apr 2008
Distribution: Arch
Posts: 37

Rep: Reputation: 15
No internet in Virtual Box


I had VBox OSE running in ubuntu.
Then I switched to archlinux, and took my slackware .vdi file with me, and installed the official VBox, and created a VM with that .vdi.
Now I have no internet. The same thing happened to the gentoo install.

Is there anything I can do? VBox settings appear the same as before, and netcfg did nothing.

Do I have to reinstall in the VM?

Last edited by Raccoon1400; 06-19-2008 at 11:43 AM.
 
Old 06-20-2008, 02:28 AM   #2
daniel-kun
LQ Newbie
 
Registered: Feb 2008
Posts: 9

Rep: Reputation: 0
What's the output of ifconfig (run as root)?
Try running
Code:
ifconfig eth0 up
Maybe re-installing the guest additions helps, too.
 
Old 06-20-2008, 10:57 AM   #3
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,173

Rep: Reputation: 47
Is vboxnet running? Occasionally this happens to me after upgrading VBox. In /etc/rc.d (on the host) there should be rc.vboxdrv and rc.vboxnet. Make sure vboxnet is running by executing as root:
Code:
/etc/rc.d/rc.vboxnet start
Also, in the vm settings, is the emulated network adapter the same as in your previous install? I think in the latest version there are more options for the emulated nic.
 
Old 06-20-2008, 05:33 PM   #4
Raccoon1400
Member
 
Registered: Apr 2008
Distribution: Arch
Posts: 37

Original Poster
Rep: Reputation: 15
ifconfig gets
eth0: ERROR while getting interface flags: no such device

loading rc.vboxnet does nothing either.

NOTE: OSs installed in VBox after I switched to archlinux work fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Migrating a VirtualBox .vdi Image to CoLinux MetalSubstance Linux - Software 2 02-25-2008 08:03 AM
Virtual Box. Removing a shared folder inside virtual xp. glore2002 Linux - Software 2 05-20-2007 12:12 PM
howto get my linux box to use the internet connection of my windows box? rahmmandel Linux - Networking 8 01-05-2007 06:11 PM
XP Box won't connect to internet thru RH9 Box (firewall/dhcpd), it can only ping fire Rhapsodic Linux - Networking 4 07-10-2004 04:02 PM
Connecting Linux box to Internet through Windowx XP box over LAN pcd007 Linux - Networking 1 03-14-2004 10:02 AM


All times are GMT -5. The time now is 08:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration