LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   no icon display for evince (http://www.linuxquestions.org/questions/slackware-14/no-icon-display-for-evince-4175486865/)

qunying 12-04-2013 02:43 PM

no icon display for evince
 
Hi,

Using the slackbuild for the evince package on Slackware64 14.1, after install and run, there is icon display, only a document with red-cross icons show up. Google around does not seem come up with a good solutions, I have try a few of them, nothing work.

Do you have a similar problem and how do you solve it?

glorsplitz 12-04-2013 08:14 PM

I sometimes find icons from outside software /usr/share/apps/(program)/icons/hicolor....

Do slocate evince see what turns up in above locations.

qunying 12-05-2013 02:02 AM

I know it install some icons under /usr/share/evince/icons/hicolor ... it suppose to pick them up automatically, but not. Not sure how to let it to search for its own directory.

kikinovak 12-05-2013 02:15 AM

Take a peek in /usr/share/applications. Open evince.desktop with a text editor (as root). Check out if there is a line like this:

Code:

NoDisplay=true
Delete this line, then run:

Code:

# update-desktop-database
Now go find Evince in your Applications menu.

Cheers,

Niki

qunying 12-05-2013 01:21 PM

Unfortunately, Niki's method does not work for me.

There is no entry for "NoDisplay" in /usr/share/applications/evince.desktop
There is an entry for it in evince-previewer.desktop, but removing it has no effect.

qunying 12-05-2013 01:31 PM

I found the problem. There is no theme setting for gtk3.

I have the following set in ~/.config/gtk-3.0/settings.ini
It then works fine. You could comment out the line for gtk-theme-name if you don't want to use the oxygen-gtk theme.
Quote:

[Settings]
gtk-key-theme-name = Emacs
gtk-fallback-icon-theme = gnome
gtk-theme-name = oxygen-gtk
P.S. I am running under i3, not any of the desktop environment, that may be the cause of theme is not set properly.


All times are GMT -5. The time now is 12:54 PM.