LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-10-2006, 04:12 PM   #1
deggial
Member
 
Registered: Mar 2006
Location: currently in Warsaw, Poland
Distribution: Slackware 10.2 & XP
Posts: 62

Rep: Reputation: 15
no fonts under non-root user


hi!

i've reinstalled slack today, configured it and after that created user account.
i need cyrillic for my everyday work so i configured it under root (and it works... under root). when i log in as user all the changes are present in configuration files (xorg.conf), but i can't see webpages in cyrillic (i talk here only about webpages - i can't check anywhere else). everything looks like the changes haven't been made.

thanks in advance
 
Old 04-10-2006, 04:18 PM   #2
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
How did you configure the font? Did you add it to the fonts served by xfs? I think xfs is part of the main X server these days.

Peace...
 
Old 04-10-2006, 04:40 PM   #3
deggial
Member
 
Registered: Mar 2006
Location: currently in Warsaw, Poland
Distribution: Slackware 10.2 & XP
Posts: 62

Original Poster
Rep: Reputation: 15
i copied mustdie fonts to /usr/X11R6/lib/X11/fonts/TTF
added: "XkbLayout" "us,ru"
"XkbVariant" ",winkeys"
"XkbOptions" "grp:alt_shift_toggle, grp_led:scroll" (it had to change language switching to alt+shift, i guess, but it didn't work)
to xorg.conf

deleted fonts.cache-1 in /usr/X11R6/lib/X11/fonts/TTF and /usr/X11R6/lib/X11/fonts/Type1
and ran /usr/X11R6/bin/fc-cache

plus REBOOT

P.S. under root everything works perfectly (without including language change)

Last edited by deggial; 04-10-2006 at 04:42 PM.
 
Old 04-10-2006, 05:19 PM   #4
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Looks like you got the font installed ok. Bizarre.

Do you have your system set to bot into runlevel 4 or 5 (a X runlevel) or do you start X manually vai startx?

Peace...
 
Old 04-10-2006, 05:27 PM   #5
deggial
Member
 
Registered: Mar 2006
Location: currently in Warsaw, Poland
Distribution: Slackware 10.2 & XP
Posts: 62

Original Poster
Rep: Reputation: 15
i always boot into 3 level, and only then i startx

P.S. do you have any ideas how to switch languages by alt shift (the method i presented above doesn't work)
 
Old 04-10-2006, 06:00 PM   #6
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Quote:
Originally Posted by deggial
i always boot into 3 level, and only then i startx
Ok. When you run "startx" as a regular user, X starts but you don't get all your fonts.

What happens if you login as a regular user, su to root and issue "init 4" (I believe runlevel 4 is still the runlevel for X in Slack)?

Quote:
P.S. do you have any ideas how to switch languages by alt shift (the method i presented above doesn't work)
Sorry, I don't switch languages.

Peace...
 
Old 04-10-2006, 11:31 PM   #7
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Firstly, do you have X11-fonts-cyrillic installed? They should be necessary for you.
Check permissions of TTF folder and its contents.
"XkbVariant" ",winkeys" - what's that for? Try commenting them out and check if it helps.
BTW, your language could be changed by issuing setxkbmap lng.
 
Old 04-11-2006, 08:13 AM   #8
deggial
Member
 
Registered: Mar 2006
Location: currently in Warsaw, Poland
Distribution: Slackware 10.2 & XP
Posts: 62

Original Poster
Rep: Reputation: 15
thanks!

i had to change file permissions in order to be able to see all my fonts under user...

"XkbVariant" ",winkeys" - this option i found in one HOWTO dedicated fonts installation and it is part of it.

setxkbmap lng - how do you use it? what is it? i don't have it in xorg.conf
 
Old 04-11-2006, 10:30 AM   #9
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
That's a program. When you run it in console, it changes language. Example, & setxkbmap lt - now my language becomes Lithuanian (I can write in it). I asked about xkbvariant because I am not sure whether it doesn't affect xkbotptions work. It may be why alt+shift do not work.

Last edited by Alien_Hominid; 04-11-2006 at 10:31 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fonts ok as root, but bad as user BroX Debian 11 11-01-2004 03:30 AM
Firefox fonts look awful for user, great for root. Raoul_Duke_M Slackware 8 10-01-2004 05:55 PM
IntelliMouse thumb buttons work as root, broken as non-root user, wheel works always digital vortex Linux - Hardware 7 03-02-2004 04:14 PM
9.2 strange fonts for user root daffyduke Mandriva 2 02-02-2004 06:37 PM
truetype fonts fail to display in any user but root... Thikasabrik Linux - Software 2 09-05-2003 11:14 AM


All times are GMT -5. The time now is 12:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration