LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-23-2006, 04:53 AM   #1
AntZero
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware-current
Posts: 14

Rep: Reputation: 0
No font antialiasing after update to GTK+ 2.10.4


Hello,

i just compiled gtk+ 2.10.4 and all dependencies (pango 1.14.4, atk 1.12.1, glib2 2.12.3 and cairo 1.2.4) by myself for Slackware-current. All works fine and my main target to compile gimp 2.3.11 with printer support is succeeded.

But now i have no font antialiasing in my gtk2 applications GDK_USE_XFT is set to 1 but nothing helps.

Maybe i have forgotten something?
 
Old 09-23-2006, 06:07 AM   #2
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 929

Rep: Reputation: 96
It appears that Gtk 2.10.4 has just been released. Why don't you wait a bit and follow the mail list at gtk.org; maybe there's a bug.
 
Old 09-23-2006, 07:10 AM   #3
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 462

Rep: Reputation: 77
Global fontconfig setting may help.
Make sure following code is in /etc/fonts/local.conf and then update fonts cache with fc-cache -fv.
Code:
<match target="font">
  <edit name="antialias" mode="assign">
    <bool>true</bool>
  </edit>
</match>
 
Old 09-23-2006, 07:44 AM   #4
AntZero
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware-current
Posts: 14

Original Poster
Rep: Reputation: 0
Ok, i have created a /etc/fonts/local.conf file and put

Code:
<match target="font">
  <edit name="antialias" mode="assign">
    <bool>true</bool>
  </edit>
</match>
in it then fc-cache -fv but nothing happens just no antialiasing.

I have tried the gtk2.10 packages from dropline gnome but there are no antialiasing, too.
 
Old 09-23-2006, 08:21 AM   #5
AntZero
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware-current
Posts: 14

Original Poster
Rep: Reputation: 0
Ok,something strange is going on. In my home dir there is a .fonts.conf file with

Code:
<?xml version="1.0"?><!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font" >
  <edit mode="assign" name="rgba" >
   <const>rgb</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hinting" >
   <bool>true</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hintstyle" >
   <const>hintmedium</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="antialias" >
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>
It means that antialiasing should work, or?
 
Old 09-23-2006, 02:03 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Just a wild guess, but have you (re)installed the FreeType 2.1.9 package that has the ByteCode Interpreter enabled? IIRC, Alien Bob has such a package at his wiki. You also should be able to find the same at linuxpackages.net.

I do not know why PV does not compile FreeType that way. Yeah, I know, there is the potential of patent infringement, but many distro vendors package FreeType with the ByteCode Interpreter enabled and nobody yet has been sued. And this has been going on for years. Basic common law dictates that by allowing this practice to continue for many years that the patent holder (Apple?) is estopped from suing because they have let the practice continue for so many years. That is, the doctrine of estoppel says that the patent holder's own actions prevent them from suing. Just as important, there never was any consensus opinion that enabling that option was indeed a patent infringement, but only speculation.

The fonts display is dramatically improved by using FreeType with the ByteCode Interpreter enabled. Dramatically. When I first started using GNU/Linux I considered abandoning the idea until I discovered this little trick. The font display was noticeably inferior with or without anti-aliasing. This one little change was significant enough to motivate me to stick with GNU/Linux. The first thing I do when I update any X11 packages is immediately reinstall FreeType 2.1.9 with the ByteCode Interpreter enabled.

Regarding the .fonts.conf file in your home directory, you can delete that file if your preferences are the same as those of the global files found in /etc/fonts. I use KDE, but all I have to do is open the KDE control center page for font configuration and KDE generates a local file even if I make no changes. Annoying. I'll guess that GNOME does the same.
 
Old 09-24-2006, 06:02 AM   #7
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 462

Rep: Reputation: 77
Quote:
Originally Posted by AntZero
...
in it then fc-cache -fv but nothing happens just no antialiasing.
...
What do you mean by nothing has happened ? When you run it in console or terminal it should display list of font directories it rebuilds caches for. Do you get some error output ?

Last edited by dunric; 09-24-2006 at 06:04 AM.
 
Old 09-24-2006, 02:32 PM   #8
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
Quote:
Originally Posted by AntZero
Ok,something strange is going on. In my home dir there is a .fonts.conf file
This file is created by the KDE font/antialiasing applet in the KDE Control Center. Unfortunately, its presence breaks the preferences applet in Gnome that performs the same function. Create a directory and move this file (.fonts.conf) inside of it. Then restart Gnome. This should allow you to set the antialiasing properties in Gnome again using preferences-fonts in the Gnome menu.

I use a modified freetype and do not use antialiasing in KDE. When I go to Gnome, I cannot make the fonts antialiased, nor can I change the hinting settings (not that I want to), unless this file (.fonts.conf) is deleted, renamed or moved.

Yet another way Gnome and KDE do not play nice together.

HTH
 
Old 09-26-2006, 03:43 AM   #9
AntZero
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware-current
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by dunric
What do you mean by nothing has happened ? When you run it in console or terminal it should display list of font directories it rebuilds caches for. Do you get some error output ?
I mean that after all no antialiasing is there The fc-cache -fv command works fine and print out a list auf directories and font counts.

Now i have reinstalled the FreeType2 package with the bytecode interpreter enabled. The fonts are looking much better now but no antialiasing ...

I moved the .fonts-conf file from my home dir to /etc/fonts as local.conf. It seams to work a little bit. Now, if it set the antialiasing option in local.conf to true there is antialiasing in Firefox (current Slackware package) but not in applications compiled by myself.

Maybe a linked problem? I have searched my system but i have only one GTK2 and FreeType2 installed. Can it be, that my "home build" applications are linked to some other stuff?
 
Old 09-27-2006, 12:56 AM   #10
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
While surfing for something else I came across this discusison:

http://www.kde-look.org/content/show.php?content=9714

You did not mention as much, but if you are using GTK apps in KDE 3.5.4 then the you might want to try this "toggle" trick to reset KDE to use antialiasing.
 
Old 09-27-2006, 01:29 AM   #11
AntZero
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware-current
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Woodsman
While surfing for something else I came across this discusison:

http://www.kde-look.org/content/show.php?content=9714

You did not mention as much, but if you are using GTK apps in KDE 3.5.4 then the you might want to try this "toggle" trick to reset KDE to use antialiasing.
Oh my god, this it it! Now i have font antialiasing in gtk apps again. Many thanks for this suggestion.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK 1.x Font shooters Linux - General 1 01-05-2006 07:51 PM
gtk font gong Slackware 0 06-10-2005 05:41 PM
font antialiasing gone after installing a new theme venkatrao Linux - General 1 05-07-2005 01:07 AM
Font rendering ugly without antialiasing spidernik84 Fedora 1 03-18-2004 09:37 PM
Mozilla Font Antialiasing? Crickit Linux - Software 3 04-10-2003 05:35 AM


All times are GMT -5. The time now is 10:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration