LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-31-2004, 12:55 PM   #1
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Rep: Reputation: 30
no /dev/sda or sda1


After compiling a new kernel, the device for my mp3 player is no longer being made (/dev/sda1). I ran into this problem before, but fixed it some how by recompiling several times with different options.

What are all of the options that need to be built in or modules for having this device being made?

Thanks.

-RoaCh
 
Old 12-31-2004, 02:02 PM   #2
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
you have to include your motherboard's SCSI drivers in your kernel (or as a module)
 
Old 01-01-2005, 03:31 AM   #3
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
Is this under device drivers?

Also, I believe I've done this. Is there anything else?
 
Old 01-01-2005, 05:35 AM   #4
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 532

Rep: Reputation: 30
Just a though...
What happens when you plug in that drive.
If you're are using 2.6 series kernel with hotplug/udev enabled device nodes are created only for devices thet are actually connected to the system.
If that is the case, the device node should be created as you plug in the drive.
Hope this helps
Ciao
 
Old 01-21-2006, 10:09 PM   #5
cferron
Member
 
Registered: Jan 2006
Location: Trois-Rivières, Québec, Canada
Distribution: Slackware, Ubuntu
Posts: 74

Rep: Reputation: 15
Question Same problem here, but with compact flash card reader

First post here... I have similar issue with my compact flash reader (Lexar USB 2.0. Sometimes /dev/sda would be present, sometimes it would not, making it unpossible to copy file from a card. I found out that this happens when mounting and unmounting frequently a card. What would solve the issue "sometimes":

1) Remove the card and retry mount /dev/sda then mount /dev/sda1 /mnt (for example)

2) If 1 did not work, disconnect reader, reconnect it in the same USB port.

3) If 2 did not work, disconnect reader from it's USB port and reconnect it in a different port, retry the mount procedure.

4) If none above, restart the system I hate to do this in Linux!

Any idea of what's happening? What output or error message could I send you?

Many thanks!

Claude
 
Old 01-22-2006, 11:42 PM   #6
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
Quote:
mp3 player is no longer being made (/dev/sda1).
do a dmesg before mounting(4 the first time)and c the name of the device.
while mounting it to some dir eg. /mnt/usb,
specify the file system eg. mount -t vfat /dev/sda1 /mnt/usb

hope ur /etc/rc.d/rc.hotplug is running and
add an entry to ur fstab for ur device(there were earlier threads for the same issue)for mounting and unmouting too many times and thus to resolve restarting ur machine

Last edited by rkrishna; 01-22-2006 at 11:43 PM.
 
Old 01-23-2006, 12:53 AM   #7
cferron
Member
 
Registered: Jan 2006
Location: Trois-Rivières, Québec, Canada
Distribution: Slackware, Ubuntu
Posts: 74

Rep: Reputation: 15
Quote:
Originally Posted by rkrishna
specify the file system eg. mount -t vfat /dev/sda1 /mnt/usb
What file system is a Nikon or Canon Compact Flash?


Quote:
add an entry to ur fstab for ur device
What would be the entry to add?


Thanks for the help, I'll start reading thread associate with this issue...

Regards,

Claude
 
Old 01-23-2006, 01:49 AM   #8
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
try dmesg to determine the device.
/dev/sda1 /mnt/USB vfat defaults,users,noauto 0 0
in fstab
most probably vfat..
mount -t vfat /dev/sda1 /mnt/usb---> for vfat

Check /proc/bus/usb/devices to see if the computer even sees the camera (i havent tried this this is from memory)
 
Old 01-23-2006, 02:51 PM   #9
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Rep: Reputation: Disabled
You need, scsi_mod, sd_mod, and usb_storage.
If it doesn't get created (but it shows lines likethese ):
sda: sda1
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
usb-storage: device scan complete

do mknod /dev/sda1 b 8 1 as root.
 
Old 01-23-2006, 02:56 PM   #10
cferron
Member
 
Registered: Jan 2006
Location: Trois-Rivières, Québec, Canada
Distribution: Slackware, Ubuntu
Posts: 74

Rep: Reputation: 15
Other things...

When I do a DMESG it find out the reader on /dev/sda... this is all good,

But I get those weird this also:

FAT: bogus number of reserved sectors
VFS: Can't find a valid FAT filesystem on dev sda.
FAT: bogus number of reserved sectors
VFS: Can't find a valid FAT filesystem on dev sda.
SCSI device sda: 503808 512-byte hdwr sectors (258 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
SCSI device sda: 503808 512-byte hdwr sectors (258 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
sda: sda1
FAT: bogus number of reserved sectors
VFS: Can't find a valid FAT filesystem on dev sda.
FAT: bogus number of reserved sectors
VFS: Can't find a valid FAT filesystem on dev sda.

Another issue that I have is that I get the following error:
modprobe: FATAL Module sd_mod not found. at boot.

These are the current modules loaded:
Module Size Used by
usb_storage 31872 0
eeprom 8712 0
w83781d 34560 0
i2c_i801 9232 0
i2c_sensor 4096 2 eeprom,w83781d
i2c_isa 3200 0
i2c_core 25088 5 eeprom,w83781d,i2c_i801,i2c_sensor,i2c_isa
uhci_hcd 33936 0
ehci_hcd 30852 0
ohci_hcd 22788 0

Also in my fstab, could I use this if I have a multiple card reader?
/dev/sda1 /mnt/USB vfat defaults,users,noauto 0 0
/dev/sdb1 /mnt/USB vfat defaults,users,noauto 0 0
/dev/sdc1 /mnt/USB vfat defaults,users,noauto 0 0
/dev/sdd1 /mnt/USB vfat defaults,users,noauto 0 0

I know I mount everything in the same directory, but I only plan to put 1 card at the time in the reader. I mount everything in the same dir also for programming purpose...makes my life easier.


Is it correct to say that when you type the mount command, it look in the fstab file to look where to mount the device? If not, What is the use of the fstab?


Thanks

Claude Ferron
 
Old 01-24-2006, 02:37 PM   #11
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Rep: Reputation: Disabled
"FATAL Module sd_mod not found" either means it's not in the kernel (as a module) or that it's in the kernel and that means it can't be loaded separately. You can check if you have it by doing

cat /usr/src/linux/.config | grep CONFIG_BLK_DEV_SD

If not, compile it as a module.
If it is set to y (=y), then you can edit /etc/modules.conf, and comment out the line which has sd_mod in it.

It is correct to say, what you said about mount

About the error, don't mount /dev/sda (as you can't), but /dev/sda1. sda1 is the usable partition.
 
Old 01-24-2006, 03:14 PM   #12
cferron
Member
 
Registered: Jan 2006
Location: Trois-Rivières, Québec, Canada
Distribution: Slackware, Ubuntu
Posts: 74

Rep: Reputation: 15
Quote:
Originally Posted by pdw_hu
You can check if you have it by doing

cat /usr/src/linux/.config | grep CONFIG_BLK_DEV_SD

If not, compile it as a module.

The command issued above create this:
CONFIG_BLK_DEV_SD=y

So I don't have to compile it as a module... And the /etc/modules.conf file does not contain anything related to SD_MOD.

Sometimes I get the error, sometimes not, another file I could look in instead of modules.conf?
Error is: modprobe:FATAL: Module sd_mod not found. (happens when I connect card reader to the USB port)

Quote:
About the error, don't mount /dev/sda (as you can't), but /dev/sda1. sda1 is the usable partition.
If I don't issue the command mount /dev/sda /mnt before I get the following error:
mount: special device /dev/sda1 does not exist

But once the above is issued I get:
mount: you must specify the filesystem type
and then /dev/sda1 appear in /dev

my fstab has no entry in regards to /dev/sda so far.... Is this related to this error?

Thanks

Claude

Last edited by cferron; 01-24-2006 at 03:55 PM.
 
Old 01-24-2006, 04:21 PM   #13
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Rep: Reputation: Disabled
CONFIG_BLK_DEV_SD=y this means it's in the kernel, so you shouldn't worry about it and it should be working.

Well sorry my bad, it was supposed to be /etc/rc.d/rc.modules, not modules.conf. Sorry about that.
Look there for the sd_mod line (something like /usr/sbin/modprobe sd_mod) comment it out and then your system shouldn't try to load it as a module.

It seems a bit mixed up, all those sda creation thingies you wrote. So i'll just write down how i do it. (i don't use hotplug, which would automatically load these as needed)
You need sd_mod, scsi_mod and usb_storage loaded. You have sd_mod and usb_storage, and i think you also have scsi_mod (which is scsi support) in the kernel (you can check by the same command i wrote just replace the end with CONFIG_SCSI).

Now after these are loaded, plug in the device, and you should see it get detected. (i honestly don't know about that VFS error, but you should google on it, if it appears again).
You can create a /dev/sda1 device with mknod /dev/sda1 b 8 1, and after that you should be able to mount it with:
mount -t vfat /dev/sda1 /mnt/USB (or wherever you want). It 'should' work really

In my fstab i've: /dev/sda1 /mnt/pendrive vfat noauto,users,rw 0 0
for the pendrive which is needed for you to be able to mount it with just: mount /mnt/pendrive (or /mnt/USB in your case)
Hope it works, let me know if it doesn't.
 
Old 01-24-2006, 05:25 PM   #14
cferron
Member
 
Registered: Jan 2006
Location: Trois-Rivières, Québec, Canada
Distribution: Slackware, Ubuntu
Posts: 74

Rep: Reputation: 15
Quote:
Originally Posted by pdw_hu
supposed to be /etc/rc.d/rc.modules, not modules.conf.
It is also quoted there... maybe it has something to do with hotplug. I really need hotplug on my system. Should I put everything needed to make this card reader work as modules then, this way I would get rid of those errors?


Quote:
Originally Posted by pdw_hu
You can create a /dev/sda1 device with mknod /dev/sda1 b 8 1, and after that you should be able to mount it with:
mount -t vfat /dev/sda1 /mnt/USB
Could I also mknod others like:
mknod /dev/sdb1 b 8 1
mknod /dev/sdc1 b 8 1
mknod /dev/sdd1 b 8 1

Will I have to mknod at every boot?

and add all those entry to my fstab:
/dev/sda1 /mnt vfat noauto,users,rw 0 0
/dev/sdb1 /mnt2 vfat noauto,users,rw 0 0
/dev/sdc1 /mnt3 vfat noauto,users,rw 0 0
/dev/sdd1 /mnt4 vfat noauto,users,rw 0 0

just in case I have to connect a multi-card reader in the system?

I'm trying to get as much infos as I can before proceeding with the changes.

Thanks for your time!

Claude Ferron
 
Old 01-25-2006, 01:39 AM   #15
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Rep: Reputation: Disabled
Yes you can, but to make those permanent you have to put the mknod commands in /etc/rc.d/rc.local.

Actually, hotplug is supposed to do this for you, so i don't know whats going on with it on your box

You could try that using everything as a module. (i can't really give a you a technical solution, cause i honestly don't know how to get rid of it, if not in the aforementioned way).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
forcing the order of /dev/sda /dev/sdb etc.. jdaniel Linux - Software 5 05-23-2006 07:41 AM
Grub Dual Boot /dev/sda1 /dev/hda1 jono268 Debian 4 01-14-2005 04:54 AM
/dev/sda and /dev/sda1 disappeared using sii3112A striderstrahan Linux - Software 0 09-16-2004 05:00 AM
Sandisk USB card Reader not linking /dev/sg0 to /dev/sda acidraven Linux - Hardware 1 06-19-2004 03:56 PM
USB Compact flash card reader hotplug creates /dev/sda but no /dev/sda1 -Mandrake 9.1 bibinono Linux - Hardware 2 08-11-2003 09:37 AM


All times are GMT -5. The time now is 07:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration