LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-08-2007, 10:00 AM   #1
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Rep: Reputation: 30
No CD in Slackware 11


Hello,

I put in a CD to listen to. I started KsCD and nothing. I tried to manually mount the drive and it told me that it couldn't read the superblock. Being that this is a new computer, it probably doesn't have the analog cable attached, but I would think that it should at least recognize the CD, even if there would be no sound.
 
Old 03-08-2007, 10:14 AM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Sounds like the system is trying to read the wrong filesystem from the CD drive.
In your fstab, are you mounting the CD player as the correct device, and as UDF and/or ISO9660?
The analog cable as you guessed, has nothing to do with it mounting or not.
 
Old 03-08-2007, 11:00 AM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,818

Rep: Reputation: 726Reputation: 726Reputation: 726Reputation: 726Reputation: 726Reputation: 726Reputation: 726
Audio CDs do not contain a valid filesystem and therefore can not be mounted.

Be sure direct digital playback is selected in KsCD settings menu.
Also check the audio mixer settings to verify CD audio is on and volume is not at the lowest level

Last edited by michaelk; 03-08-2007 at 11:01 AM.
 
Old 03-08-2007, 01:25 PM   #4
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Original Poster
Rep: Reputation: 30
Hello,

I checked the KsCD configuration and switched over to direct digital playback - so I should have sound. I changed the fstab line from owner to user. But I still couldn't get the CD to be recoginzed. KsCD says that it cannot read /dev/cdrom, access denied check permissions. I looked at /dev/cdrom and the owner is root and group is cdrom. It was a link so I couldn't change permissions and the dev it linked to /dev/cdrom0 was also a link. It linked to /dev/hdc. I changed the permission of others from forbidden to read - and presto! the CD player works, with sound.

Thanks for all your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
About Slackware 9.1 boot disk?? ftp://ftp.kpn.be/pub/linux/slackware/slackware-9.1-is AL3OMDAH Slackware 4 04-18-2007 09:54 AM


All times are GMT -5. The time now is 12:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration