LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-08-2006, 11:17 PM   #1
mrzack
Member
 
Registered: Jun 2006
Location: Pennsylvania
Distribution: Slackware 12, Ubuntu 7.10, OpenSuse 10.3, Fedora 7, Backtrack 3 (beta)
Posts: 31

Rep: Reputation: 15
No Audio in Slackware 11


I just did a fresh install of Slackware 11. I have everything configured the way I had it on 10.2, but I'm having a problem with my audio. The chipset for the on board audio is detected by ALSA, and I have changed my user permissions for the audio. But still no luck. I took a screenshot because I noticed something that says Master [Off]. Could this have something to do with it?
 
Old 11-08-2006, 11:21 PM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Yeah, you need to unmute things that are off. Press M to do this.
 
Old 11-09-2006, 06:03 AM   #3
mrzack
Member
 
Registered: Jun 2006
Location: Pennsylvania
Distribution: Slackware 12, Ubuntu 7.10, OpenSuse 10.3, Fedora 7, Backtrack 3 (beta)
Posts: 31

Original Poster
Rep: Reputation: 15
It worked. Thanks a lot. I've never had to use that before.
 
Old 11-09-2006, 10:50 AM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You'll want to save your settings after you change them. Do this with "alsactl store" as root.
 
Old 11-09-2006, 10:07 PM   #5
Spinlock
Member
 
Registered: Jan 2006
Location: Missouri
Distribution: Slackware -current, Slackware64 -current, Slackware 12.2
Posts: 135

Rep: Reputation: 15
Also, KMix likes to mute things as well. I spent almost a week trying to make my sound behave... finally, it turned out that KMix was muting the External Amplifier I kept unmuting with alsamixer. This, in turn, caused the stock artsd to crash with SIGSEGV11, and a custom-compiled artsd to crash with SIGABRT6. Unmuting one stinking setting fixed the problem permanently.
 
Old 11-09-2006, 10:56 PM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Oh yes, I also had that problem!
 
Old 11-10-2006, 12:18 AM   #7
mrzack
Member
 
Registered: Jun 2006
Location: Pennsylvania
Distribution: Slackware 12, Ubuntu 7.10, OpenSuse 10.3, Fedora 7, Backtrack 3 (beta)
Posts: 31

Original Poster
Rep: Reputation: 15
I'd just ran in to that earlier today, too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about Audio in Slackware. jstephens84 Slackware 4 07-12-2006 07:30 AM
Cannot listen to audio in slackware..Help!!! lenson Linux - Newbie 9 08-21-2005 03:00 AM
Audio CD Doesn't Play - Slackware mijenks Slackware 9 07-22-2004 11:44 PM
Real Audio for Slackware JockVSJock Slackware 4 01-27-2004 11:27 PM
Audio in Slackware XPediTioN Slackware 6 07-08-2003 12:36 AM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration