LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-18-2013, 01:15 AM   #1
erik2282
Member
 
Registered: May 2011
Location: Texas
Distribution: Debian 7, CentOS 6
Posts: 119

Rep: Reputation: 20
No audio, falling back to default. Slackware14


sound error.pngsound error2.png

After installing Nvidia video driver, all sound stopped working. Attached is an image of the error message I get.

New-ish to Slackware and Linux in general. What can I try to fix the issue?

http://docs.slackware.com/howtos:har..._snd-hda-intel
I've tried this, but after rebooting it is still the same.

Thank you,
Erik
 
Old 02-18-2013, 08:50 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
It looks like you have a system with multiple audio outputs.
There appears to be an onboard HDA Intel chipset with an ALC889 codec that is offering analog, digital and HDMI outputs as well as an HDMI output on your nVidia.
Perhaps this SlackDocs page can help. Also look at the discussion tab.
http://docs.slackware.com/howtos:har...s_on_slackware
 
Old 02-18-2013, 10:06 AM   #3
erik2282
Member
 
Registered: May 2011
Location: Texas
Distribution: Debian 7, CentOS 6
Posts: 119

Original Poster
Rep: Reputation: 20
Outputs that I got.

~# cat /proc/asound/card*/codec* | grep Codec
Codec: Nvidia GPU 15 HDMI/DP
Codec: Nvidia GPU 15 HDMI/DP
Codec: Nvidia GPU 15 HDMI/DP
Codec: Nvidia GPU 15 HDMI/DP

:~# lsmod | grep snd
snd_seq_dummy 1455 0
snd_seq_oss 29048 0
snd_seq_midi_event 5620 1 snd_seq_oss
snd_seq 51265 5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device 5228 3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss 39183 0
snd_mixer_oss 15404 1 snd_pcm_oss
snd_hda_codec_hdmi 24057 4
snd_hda_intel 23267 0
snd_hda_codec 81925 2 snd_hda_intel,snd_hda_codec_hdmi
snd_hwdep 6324 1 snd_hda_codec
snd_pcm 72864 4 snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi,snd_pcm_oss
snd_page_alloc 7081 2 snd_pcm,snd_hda_intel
snd_timer 18798 2 snd_pcm,snd_seq
snd 57796 11 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi,snd_mixer_oss,snd_pcm_oss ,snd_seq_device,snd_seq,snd_seq_oss
soundcore 5474 1 snd

~# cat /proc/asound/card*/codec* | grep Codec
Codec: Nvidia GPU 15 HDMI/DP
Codec: Nvidia GPU 15 HDMI/DP
Codec: Nvidia GPU 15 HDMI/DP
Codec: Nvidia GPU 15 HDMI/DP

:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

:~# alsamixer
───────────────────────── AlsaMixer v1.0.26 ───────────────────────────┐
│ Card: HDA NVidia F1: Help │
│ Chip: Nvidia GPU 15 HDMI/DP F2: System information │
│ View: F3: Playback F4: Capture F5:[All] F6: Select sound card │
│ Item: S/PDIF [Off] Esc: Exit │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ ┌───── Sound Card ──────┐ │
│ │- (default) │ │
│ │0 HDA NVidia │ │
│ ┌──│ enter device name...│──┐ │
│ │MM└───────────────────────┘MM│ │
│ └──┘ └──┘ └──┘ └──┘ │
│ < S/PDIF >S/PDIF 1 S/PDIF 2 S/PDIF 3 │
│ │
│ │

................
Made the asound.conf file in /etc but it didnt seem to do anything.
Ideas?
 
Old 02-18-2013, 10:42 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Try, as root
Code:
echo "blacklist snd-hda-codec-hdmi" >> /etc/modprobe.d/blacklist.conf
and rebooting.
Hopefully this will allow your other device to be seen by the kernel. You may need to do this http://www.linuxquestions.org/questi...5/#post4289480 if your other device appears.

Last edited by allend; 02-18-2013 at 10:45 AM.
 
Old 02-20-2013, 10:30 PM   #5
erik2282
Member
 
Registered: May 2011
Location: Texas
Distribution: Debian 7, CentOS 6
Posts: 119

Original Poster
Rep: Reputation: 20
sorry, i feel silly. I had the sound disabled in the BIOS. ..Check the fuse they said..ha!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
perl: warning: Falling back to the standard locale ("C"). walterbyrd Debian 11 05-14-2009 09:50 AM
lmms - No audio-driver working - falling back to dummy-audio-driver GuySkarpz Linux - Software 3 01-20-2009 04:58 PM
NFS tcp not available, falling back to UDP; RPC failure ron7000 Linux - Networking 4 12-18-2008 12:20 PM
mount server reported tcp not available, falling back to udp feizz@yahoo.com Linux - Networking 0 09-23-2007 11:38 PM
problem falling back to console systelm Linux - Newbie 2 04-17-2006 04:46 AM


All times are GMT -5. The time now is 08:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration