LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-23-2005, 02:46 PM   #1
lowpro2k3
Member
 
Registered: Oct 2003
Location: Canada
Distribution: Slackware
Posts: 340

Rep: Reputation: 30
No access to NTFS mounts for regular user account


I can only browse my NTFS mounts as root, I'm trying to switch over to doing just about everything as a regular user right now. As this user, I can't browse my NTFS mounts. When they become mounted, the permissions are 'dr-x------ root root'. I've tried messing around with my /etc/fstab file and modifying these lines:

Code:
/dev/hda1        /mnt/c-drive     ntfs        ro               1   0
/dev/hdb1        /mnt/g-drive     ntfs        ro               1   0
to this
Code:
/dev/hda1        /mnt/c-drive     ntfs        user,ro               1   0
/dev/hdb1        /mnt/g-drive     ntfs        user,ro               1   0
They are both mounted on boot, and I want regular users to have read-only access to them.

edit: I should also mention that 'chmod 755 /mnt/g-drive' fails because its a read-only filesystem. When I unmount the filesystem, the empty /mnt/g-drive directory defaults to 755 permissions. When I remount, it goes back to 500 permissions.

I just tried using a program I found in my KDE->System menu, 'xfce fstab mount manager'. It tries to do the same thing, run a chmod command. This fails because the file system is read-only.

Last edited by lowpro2k3; 10-23-2005 at 03:16 PM.
 
Old 10-23-2005, 02:50 PM   #2
mago
Member
 
Registered: Apr 2004
Location: Costa Rica
Distribution: slack current with 2.6.16.18 (still off the hook)
Posts: 283

Rep: Reputation: 33
try users,ro instead
 
Old 10-23-2005, 02:57 PM   #3
lowpro2k3
Member
 
Registered: Oct 2003
Location: Canada
Distribution: Slackware
Posts: 340

Original Poster
Rep: Reputation: 30
OK, I made the changes, unmounted and re-mounted the partitions, is this all I should have to do? Because I changed 'user' to 'users', umounted and remounted the partitions and they still switch to the permissions I described above.

I was going to try 'users' since I read it in mount(8), but it seems basically the same except it allows regular users to umount a partition as well. I don't really want/need this functionality. I guess I'll try rebooting and post results just to be safe (keeping the changes I made).

EDIT: I tried making the changes above, rebooting -> nothing changed. I still cannot browse the mount points as a regular user.

Last edited by lowpro2k3; 10-23-2005 at 03:16 PM.
 
Old 10-23-2005, 04:52 PM   #4
grautu
Member
 
Registered: Jul 2005
Posts: 139

Rep: Reputation: 15
Code:
/dev/hda1        /mnt/c-drive     ntfs        ro,umask=0               1   0
 
Old 10-23-2005, 05:03 PM   #5
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,256

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
This is from my fstab:

/dev/hda2 /mnt/nt_c1 ntfs noauto,user,ro,exec,umask=0222 0 0

/dev/hda7 /mnt/nt_e ntfs ro,exec,umask=0222 0 0

In the first line I use noauto because I don't always need access to that partition. I use the user option so that any user login account on my box can mount the partition later if needed. You can ignore those options if you want the partition accessible all the time and the second line shows how I mount an ntfs partition that I usually always need access to.

I hope this helps.
 
Old 10-23-2005, 05:21 PM   #6
lowpro2k3
Member
 
Registered: Oct 2003
Location: Canada
Distribution: Slackware
Posts: 340

Original Poster
Rep: Reputation: 30
Smile

Quote:
Originally posted by grautu
Code:
/dev/hda1        /mnt/c-drive     ntfs        ro,umask=0               1   0
Quote:
Originally posted by Woodsman
This is from my fstab:

/dev/hda2 /mnt/nt_c1 ntfs noauto,user,ro,exec,umask=0222 0 0

/dev/hda7 /mnt/nt_e ntfs ro,exec,umask=0222 0 0

In the first line I use noauto because I don't always need access to that partition. I use the user option so that any user login account on my box can mount the partition later if needed. You can ignore those options if you want the partition accessible all the time and the second line shows how I mount an ntfs partition that I usually always need access to.

I hope this helps.
Thanks very much, I appended a umask of 0 to mount options field and it works the way I had hoped. Theres one issue crossed off my list
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
regular user mounts and fstab (again) clawder Slackware 7 12-31-2004 12:37 PM
Can root access be gained from regular user account without password? jdruin Linux - Security 5 11-22-2004 10:20 AM
Can't access NTFS partition as regular user Spasmolytic Linux - Newbie 3 05-13-2004 05:46 PM
access NTFS mounts without root btaber Linux - Hardware 4 03-23-2004 04:05 PM
can't login to regular user account luchobucho Linux - General 2 10-27-2003 05:11 AM


All times are GMT -5. The time now is 04:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration