LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-13-2012, 04:29 AM   #1
parcox
LQ Newbie
 
Registered: Jan 2007
Location: Pontianak, Indonesia
Distribution: Slackware64-14.0
Posts: 26

Rep: Reputation: 5
"nmcli con" failed "Can't obtain connections: settings service is not running."


Salut,
I have switched to use Network Manager, and sometimes I use the nmcli command line to manage my network connection. But I dont know why, since the last update of Slackware64-current (Aug 10, 2012), the "nmcli con" command does not work anymore. It shows "Can't obtain connections: settings service is not running." error message, although plasma-networkmanagement still works . I rebuilt the package with patch provided by this link[1], and now "nmcli con" works again as expected. Hope this will be fixed soon. Thanks

[1] http://patch-tracker.debian.org/patc...settings.patch

--
Greeting from Indonesia
 
Old 08-14-2012, 04:24 PM   #2
zakame
Member
 
Registered: Apr 2012
Distribution: Debian, Ubuntu, Slackware
Posts: 119

Rep: Reputation: 42
Yep, confirming this on latest -current. I can do "nmcli nm" and "nmcli dev" to check NM/device status but not "nmcli con". As patch indicates, it is a regression in nm_remote_settings_new().
 
Old 08-14-2012, 04:26 PM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,178

Rep: Reputation: Disabled
Will be fixed in the next batch of updates.

Eric
 
1 members found this post helpful.
  


Reply

Tags
network manager


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting "SIOCADDRT: No such process" when running "service network restart" cmlorentz Linux - Networking 1 11-26-2010 01:06 PM
Need solution to "failed to fork PTY" and "error creating the child process" problems Gnusboy Linux - Newbie 4 01-02-2010 07:54 AM
"Failed Dependency error" while installing RPM for "DateTime" perl modules giridhargopal.cj Linux - Newbie 7 11-19-2008 12:05 AM
How might I restore kmail folders/mail/settings from a "badly" saved "home"? deh6 Linux - Software 5 03-08-2008 09:25 PM
Logs filling up with "smbd/service.c:make_connection" - "couldn't find service" DumbTerminal Linux - Networking 14 07-16-2007 06:33 AM


All times are GMT -5. The time now is 01:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration