LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-04-2012, 12:11 PM   #1
roger_
LQ Newbie
 
Registered: Nov 2012
Posts: 2

Rep: Reputation: Disabled
nm-applet problems with 'user'


Hi all, I've installed slackware 14 before and added groups plugdev and netdev, whether I need them both i'm not sure but I can't get nm-applet to work under user. NetworkManager is started, does anyone have any clues?

Here is my paste when starting it as user. The paste is starting nm-applet from a terminal as user.
http://pastebin.com/HcANjRbA


Thanks....

Last edited by roger_; 11-04-2012 at 12:12 PM.
 
Old 11-04-2012, 06:09 PM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,433

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Welcome to LQ!

What window manager/desktop environment are you using?
nm-applet is a systemtray application. The systemtray is provided by KDE and xfce but in Windowmaker I needed to install 'wmsystemtray' from SlackBuilds for the nm-applet to work.
 
Old 11-07-2012, 12:06 PM   #3
madder
LQ Newbie
 
Registered: Nov 2012
Posts: 15

Rep: Reputation: Disabled
ive been using fluxbox and i receive the same message...but when run as root it creates an icon on the toolbar. i previously have been using ubuntu and it work(dont know why though). Still not managed to get networkmanager working yet on slackware.
 
Old 11-07-2012, 01:49 PM   #4
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,047

Rep: Reputation: 170Reputation: 170
Quote:
Originally Posted by madder View Post
ive been using fluxbox and i receive the same message...but when run as root it creates an icon on the toolbar. i previously have been using ubuntu and it work(dont know why though). Still not managed to get networkmanager working yet on slackware.
In your case, it's a consolekit issue (and *may* be the op's issue, but he's mia)

Either edit your .xinitrc and add this:

Code:
 exec ck-launch-session dbus-launch --sh-syntax --exit-with-session startfluxbox
or put the ck-launch stuff in your .fluxbox/startup file.

cheers,
 
1 members found this post helpful.
Old 11-08-2012, 11:22 AM   #5
madder
LQ Newbie
 
Registered: Nov 2012
Posts: 15

Rep: Reputation: Disabled
Thanks mrclisdue ...that worked for me! :-)
 
Old 11-26-2012, 07:13 PM   #6
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,667

Rep: Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440
Unfortunately, mrclisdue's solution didnt' work for me (with XMonad instead of Fluxbox). nm-applet still crashes with the same message.
 
Old 11-26-2012, 09:44 PM   #7
madder
LQ Newbie
 
Registered: Nov 2012
Posts: 15

Rep: Reputation: Disabled
This is what I have in .xinitrc using fluxbox.

exec ck-launch-session dbus-launch --sh-syntax --exit-with-session nm-applet&
exec fluxbox


I haven't tried putting it into ~/.fluxbox.startup but it would probably work the same.
 
Old 11-26-2012, 10:00 PM   #8
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,047

Rep: Reputation: 170Reputation: 170
@dugan

Do you get same message as OP's paste?

cheers,
 
Old 11-27-2012, 08:05 AM   #9
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,667

Rep: Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440Reputation: 1440
Quote:
Originally Posted by mrclisdue View Post
@dugan

Do you get same message as OP's paste?

cheers,
I did.
 
Old 11-29-2012, 10:30 AM   #10
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,047

Rep: Reputation: 170Reputation: 170
Quote:
Originally Posted by dugan View Post
I did.
Add this:

Code:
# Start DBUS session bus:
if [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
   eval $(dbus-launch --sh-syntax --exit-with-session)
fi
to your .xinitrc and it *should* work (just installed xmonad to verify....)

(shamelessly stolen from the .fluxbox/startup file)

cheers,

Last edited by mrclisdue; 11-29-2012 at 11:28 AM. Reason: additional info
 
Old 11-29-2012, 08:59 PM   #11
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 7,715

Rep: Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458
Edit your ~/.fluxbox/startup file to start nm-applet when Fluxbox starts by adding this line towards the end before "exec fluxbox."

Code:
nm-applet &
The ampersand means "keep running."

That's always worked for me.

More on the startup file:

http://fluxbox-wiki.org/index.php?ti...e_startup_file

Last edited by frankbell; 11-29-2012 at 09:07 PM. Reason: Clarity
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nm-applet problems with 'user' roger_ Slackware 1 11-26-2012 06:10 PM
cannot execute nm-applet as a normal user t_shit Linux - Software 0 08-08-2012 07:03 AM
Gnome Bluetooth applet in Lenny: root user vs. ordinary user SuSE_Lamer Linux - Desktop 1 03-20-2009 05:41 AM
Gnome Bluetooth applet in Lenny: root user vs. ordinary user SuSE_Lamer Debian 1 02-25-2009 01:30 AM


All times are GMT -5. The time now is 06:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration